HSRP IP Address

alliasneoalliasneo Member Posts: 186
Hey guys, so when choosing which device is going to be the 'Active' and which will be the 'Standby' if the priorities are the same then it will go on the highest IP address?

No 'Highest' IP address. Does this mean a number closer to 0 or higher to 255 if you know what I mean?

For example I have the following:

R3

interface Ethernet0/0
ip address 172.23.23.3 255.255.255.0
half-duplex
standby 5 ip 172.23.23.10
standby 5 preempt


R2

interface Ethernet0/0
ip address 172.23.23.2 255.255.255.0
half-duplex
standby 5 ip 172.23.23.10
standby 5 preempt





So I was think 'Oh R3 will be the active because 3 is higher than 2' But R2 became the active.

Comments

  • astorrsastorrs Member Posts: 3,139 ■■■■■■□□□□
    HSRP will only preempt (if enabled) based on priority value not IP address. R2 came up from boot first in your situation (I'm assuming). If you have a third router "R1" and set it with a priority of 90, then once its assumed the primary role shut it down and R3 will take over.
  • ampdeckampdeck Member Posts: 35 ■■□□□□□□□□
    here's a sample config for both distribution switch


    DSW1
    interface Vlan69
    description distribution switch1
    ip address 172.23.23.8 255.255.255.240
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip flow ingress
    ip route-cache flow
    standby 4 ip 172.23.23.10
    standby 4 priority 120
    standby 4 preempt


    DSW2
    interface Vlan69
    description distribution switch1
    ip address 172.23.23.9 255.255.255.240
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip flow ingress
    ip route-cache flow
    standby 4 ip 172.23.23.10
    standby 4 priority 140 <
    makes this switch active!
    standby 4 preempt
  • alliasneoalliasneo Member Posts: 186
    Thanks for responses. But say I don't set the priority at all and this stays at 100 for both, the default of choosing which is active and which is the standby is based on the IP Address, correct? So on the IP address alone which would it choose as a higher value .2 or .3?


    Thanks
  • networker050184networker050184 Mod Posts: 11,962 Mod
    The higher IP wins, so .3. That is if they come up at the same time and negotiate. If you configure the .2 side first and it declares itself master the .3 won't take over automatically.
    An expert is a man who has made all the mistakes which can be made.
Sign In or Register to comment.