Connected ipv6 network not showing in routing tabe

FatbunnyFatbunny Member Posts: 44 ■■□□□□□□□□
I'm having connectivity problems on an ipv6 p2p frame relay network. In the foundation learning network, p800 or 801, there is a network diagram of four routers that I am trying to set up. However when setting up a router I am creating mulitple p2p interfaces
interface Loopback1
 no ip address
 ipv6 address 102::1/64
!
interface FastEthernet0/0
 ip address 192.168.100.202 255.255.255.0
 duplex auto
 speed auto
!
interface BRI0/0
 no ip address
 encapsulation hdlc
 shutdown
!
interface Serial0/0
 description connected to serial 2
 no ip address
 encapsulation frame-relay
 no fair-queue
 no frame-relay inverse-arp
!
interface Serial0/0.1 point-to-point
 ipv6 address 123::2/64
 frame-relay interface-dlci 222
!
interface Serial0/0.4 point-to-point
 ipv6 address 224::2/64
 frame-relay interface-dlci 302
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
!
!
!
ip http server
no ip http secure-server
!
ipv6 route 224::/64 Serial0/0.4
!




the dlci's are ok. but the 224 (originally 24 in the book but I thought there might be a bug with two digit Ipv6 addresses so I tried 3 digit inital prefixes). The 123 networks work fine but the other network doesn't work. The ip routing table doesn't show the 224 network
R2_LabR2#sh ipv6 route
IPv6 Routing Table - 6 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
C   102::/64 [0/0]
     via ::, Loopback1
L   102::1/128 [0/0]
     via ::, Loopback1
C   123::/64 [0/0]
     via ::, Serial0/0.1
L   123::2/128 [0/0]
     via ::, Serial0/0.1
L   FE80::/10 [0/0]
     via ::, Null0
L   FF00::/8 [0/0]
     via ::, Null0




just for reference here is the other router that is connected to this one.
R2_LabR2#sh run | b inter
interface Loopback1
 no ip address
 ipv6 address 102::1/64
!
interface FastEthernet0/0
 ip address 192.168.100.202 255.255.255.0
 duplex auto
 speed auto
!
interface BRI0/0
 no ip address
 encapsulation hdlc
 shutdown
!
interface Serial0/0
 description connected to serial 2
 no ip address
 encapsulation frame-relay
 no fair-queue
 no frame-relay inverse-arp
!
interface Serial0/0.1 point-to-point
 ipv6 address 123::2/64
 frame-relay interface-dlci 222
!
interface Serial0/0.4 point-to-point
 ipv6 address 224::2/64
 frame-relay interface-dlci 302
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
!
 --More--




R2_LabR2#sh ipv6 route
IPv6 Routing Table - 6 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
C   102::/64 [0/0]
     via ::, Loopback1
L   102::1/128 [0/0]
     via ::, Loopback1
C   123::/64 [0/0]
     via ::, Serial0/0.1
L   123::2/128 [0/0]
     via ::, Serial0/0.1
L   FE80::/10 [0/0]
     via ::, Null0
L   FF00::/8 [0/0]
     via ::, Null0

I am doing something wrong but I cannot see what. Anyone see? Let me know if more info is needed

Comments

  • ZartanasaurusZartanasaurus Member Posts: 2,008 ■■■■■■■■□□
    Are you actually getting DLCI 302 from the FRSW?
    Currently reading:
    IPSec VPN Design 44%
    Mastering VMWare vSphere 5​ 42.8%
  • TrifidwTrifidw Member Posts: 281
    Have you enabled ipv6 unicast-routing?
  • FatbunnyFatbunny Member Posts: 44 ■■□□□□□□□□
    Not to worry...I rebuilt each router including the frame relay switch and have it working now. Silly problems but you do learn from them. I had ipv6 unicast-routing enabled on the routers and the dlci's should have been correct but the dlci's on the frame relay switch were ambiguous, I had never changed them from when I got it just worked with what was on it. Turned out that some of the interfaces on the frame relay switch were shutdown. I did notice that if the link isn't up, the route doesn't get put in the routing table. Thanks for the assistance guys!!
  • ZartanasaurusZartanasaurus Member Posts: 2,008 ■■■■■■■■□□
    In the future, use show frame-relay pvc | i STATUS on the router.

    This is a great shortcut to debug FR config issues. If you see "DELETED" that's bad. 95% of the time, it's because you configured the wrong DLCI on the router side. 5% of the time it's because the main interface is shutdown.
    Currently reading:
    IPSec VPN Design 44%
    Mastering VMWare vSphere 5​ 42.8%
Sign In or Register to comment.