Help With Challenge Lab OSPF

Danielh22185Danielh22185 Senior MemberMember Posts: 1,195 ■■■■□□□□□□
I am using the CCNP route lab manual and am attempting the challenge lab. It seems I have everything configured correctly. I am in the final step of the lab. It does not tell you how to do anything just what to do:

1. Configure the interfaces in the diagram with the IP addresses shown.
2. Configure the bandwidth to reflect the actual bandwidth of all serial links.
3. Configure OSPF with interfaces in the areas shown in the diagram.
4. Configure R2 to summarize area 20 with the most specific mask possible.
5. Make the link between R1 and R2 have the OSPF network type of broadcast, with R1 as the DR.
6. Configure R1 to always originate a default route.
7. Modify the link between R2 and R3 to have hello timers and dead timers that are double the default values.
8. Make the link between R2 and R3 have a cost of 500.
9. Configure area 34 to be a totally stubby area.
10. Use MD5 authentication with the keyword “cisco” over the link between R3 and R4.
11. Figure out the hidden issue in the topology that you need to address to have full connectivity.
12. Run a Tcl script on all routers to verify that there is connectivity between the IP addresses in the topology.

Here is my topology:

TopologyOSPFChallengelab_zpsc7be3ed8.jpg

I am on step 11 where I have to find the hidden issue of the network. I know what the problem is. It had me configure a totally stubby area (34) which will refuse a virtual link so I can connect area 34 back to the backbone. My question is... as a fix should I configure the area 34 as a different type of stub area so that I can configure it with a virtual link so in essence it can receive the OSPF connectivity with the remainder of the topology? Or what would be the best solution?

My configs of each router is attached below.
R1# sh run
Building configuration...
 
Current configuration : 1178 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
ip domain name lab.local
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 172.16.1.1 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 172.16.12.1 255.255.255.0
 ip ospf network broadcast
 ip ospf priority 200
 clock rate 64000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
router ospf 1
 router-id 1.1.1.1
 log-adjacency-changes
 network 172.16.1.1 0.0.0.0 area 0
 network 172.16.12.1 0.0.0.0 area 0
 default-information originate always
!
ip route 0.0.0.0 0.0.0.0 Null0
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end
 
================================================================================
R2#sh run
Building configuration...
 
Current configuration : 1658 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
ip domain name lab.local
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 172.16.2.1 255.255.255.224
!
interface Loopback1
 ip address 172.16.2.33 255.255.255.224
!
interface Loopback2
 ip address 172.16.2.65 255.255.255.224
!
interface Loopback3
 ip address 172.16.2.97 255.255.255.224
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 172.16.23.2 255.255.255.0
 ip ospf cost 500
 ip ospf hello-interval 20
 clock rate 64000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
interface Serial0/2
 ip address 172.16.12.2 255.255.255.0
 ip ospf network broadcast
 clock rate 2000000
!
interface Serial0/3
 no ip address
 shutdown
 clock rate 2000000
!
router ospf 1
 router-id 2.2.2.2
 log-adjacency-changes
 area 20 range 172.16.2.0 255.255.255.128
 network 172.16.2.1 0.0.0.0 area 20
 network 172.16.2.33 0.0.0.0 area 20
 network 172.16.2.65 0.0.0.0 area 20
 network 172.16.2.97 0.0.0.0 area 20
 network 172.16.12.2 0.0.0.0 area 0
 network 172.16.23.2 0.0.0.0 area 23
!
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end
 
============================================================================================
R3#sh run
Building configuration...
 
*Mar  1 03:02:54.095: %SYS-5-CONFIG_I: Configured from console by console
Current configuration : 1261 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
ip domain name lab.local
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 172.16.3.1 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 172.16.23.3 255.255.255.0
 ip ospf cost 500
 ip ospf hello-interval 20
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 ip address 172.16.34.3 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 clock rate 64000
!
router ospf 1
 router-id 3.3.3.3
 log-adjacency-changes
 area 34 stub no-summary
 network 172.16.3.1 0.0.0.0 area 23
 network 172.16.23.3 0.0.0.0 area 23
 network 172.16.34.3 0.0.0.0 area 34
!
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end
 
===================================================================================================
R4#sh run
Building configuration...
 
Current configuration : 1143 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
ip domain name lab.local
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 172.16.4.1 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 172.16.34.4 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
router ospf 1
 router-id 4.4.4.4
 log-adjacency-changes
 network 172.16.4.1 0.0.0.0 area 34
 network 172.16.34.4 0.0.0.0 area 34
!
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end
Currently Studying: IE Stuff...kinda...for now...
My ultimate career goal: To climb to the top of the computer network industry food chain.
"Winning means you're willing to go longer, work harder, and give more than anyone else." - Vince Lombardi

Comments

  • iamme4evaiamme4eva Senior Member Member Posts: 272
    I'm only just learning OSPF, and haven't got as far as TSA's yet, but from what I've read so far, every area has to connect to area 0. I don't know if TSA's change that rule, but that's my first thought.

    I'm sure someone qualified / further along in their studies might have more to say!
    Current objective: CCNA Security
    My blog: mybraindump.co.uk
  • Danielh22185Danielh22185 Senior Member Member Posts: 1,195 ■■■■□□□□□□
    You are correct that every area must connect to area 0 however this lab throws you the curve ball that you will have a remote area that cannot directly connect to area 0 and is configured as a TSA. I am just trying to determine basically if it is possible to keep the area as a TSA AND find a way to connect it to area 0.
    Currently Studying: IE Stuff...kinda...for now...
    My ultimate career goal: To climb to the top of the computer network industry food chain.
    "Winning means you're willing to go longer, work harder, and give more than anyone else." - Vince Lombardi
  • srgsrg Senior Member Member Posts: 140
    Area 23 is a regular area, no? It's the virtual-link transit area (23) that can't be TSA. Area 34 can still be stub/TSA and linked to area0 via the virtual-link in area 23.
  • iamme4evaiamme4eva Senior Member Member Posts: 272
    Yeah, it's beyond me for the minute.

    *bows out and goes back to reading 1st grade OSPF!*
    Current objective: CCNA Security
    My blog: mybraindump.co.uk
  • mattaumattau Senior Member Member Posts: 218
    R3 has

    area 34 stub no-summary

    R4 doesnt have any of this so they wont be neighbors. - So thats the first problem
    R4 needs to have area 34 stub

    Secondly - make the virtual link over area 23 as that is transit. You do virtual links over nonbackbone transit areas that arent stubs.

    On R2 and R3 point each other at their RID's to make the virtual link and job done








    _____________________________________
    CCNP ROUTE - passed 20/3/12
    CCNP SWITCH - passed 25/10/12
    CCNP TSHOOT - passed 11/12/12




  • JackaceJackace Senior Member Member Posts: 335
    As was said above you have to make a virtual-link between routers R2 and R3 through area 23. That will virtually connect area 34 with area 0.
  • Danielh22185Danielh22185 Senior Member Member Posts: 1,195 ■■■■□□□□□□
    Great thanks! I'll go back and do some re-configures. I guess this ties into me still trying to fully understand the Area types / ways they can connect. Probably the most confusing parts of OSPF.
    Currently Studying: IE Stuff...kinda...for now...
    My ultimate career goal: To climb to the top of the computer network industry food chain.
    "Winning means you're willing to go longer, work harder, and give more than anyone else." - Vince Lombardi
  • Danielh22185Danielh22185 Senior Member Member Posts: 1,195 ■■■■□□□□□□
    Thanks again everyone for the help. My problem was indeed how and where I was attempting to setup the virtual link. I plugged in these commands and it worked perfectly:

    R2(config-router)#area 23 virtual-link 3.3.3.3
    R3(config-router)#area 23 virtual-link 2.2.2.2

    I feel accomplished and learned something big here. Thanks again!
    Currently Studying: IE Stuff...kinda...for now...
    My ultimate career goal: To climb to the top of the computer network industry food chain.
    "Winning means you're willing to go longer, work harder, and give more than anyone else." - Vince Lombardi
  • srgsrg Senior Member Member Posts: 140
  • hbkhbk Junior Member Member Posts: 24 ■□□□□□□□□□
    I think you can try a GRE tunnel to connect the areas together
  • Danielh22185Danielh22185 Senior Member Member Posts: 1,195 ■■■■□□□□□□
    hbk wrote: »
    I think you can try a GRE tunnel to connect the areas together

    essentially this is a tunnel however I am not too well versed on tunnels yet so I have some learning to do in that respect.
    Currently Studying: IE Stuff...kinda...for now...
    My ultimate career goal: To climb to the top of the computer network industry food chain.
    "Winning means you're willing to go longer, work harder, and give more than anyone else." - Vince Lombardi
  • MrXpertMrXpert Senior Member Member Posts: 586 ■■■□□□□□□□
    I prefer virtual links method to do this. I am very rusty with gre but i think it would be configured like this if using GRE tunnels

    On R4
    router ospf 1
    router-id 4.4.4.4
    log-adjacency-changes
    network 24.24.24.0 0.0.0.255 area 0
    network 172.16.4.1 0.0.0.0 area 34
    network 172.16.34.4 0.0.0.0 area 34

    R4#show ip ospf neighbor

    Neighbor ID Pri State Dead Time Address Interface
    2.2.2.2 0 FULL/ - 00:00:36 24.24.24.2 Tunnel4
    3.3.3.3 0 FULL/ - 00:00:38 172.16.34.3 Serial0/0

    R4#show run | b ip route
    ip route 172.16.23.0 255.255.255.0 172.16.34.3






    On R2

    R2#SHOW run | sec ospf

    router ospf 1
    router-id 2.2.2.2
    log-adjacency-changes
    passive-interface default
    no passive-interface Serial0/0
    no passive-interface Serial0/1
    no passive-interface Tunnel2
    network 24.24.24.0 0.0.0.255 area 0

    R2#show run | inc ip route
    ip route 172.16.34.0 255.255.255.0 172.16.23.3




    R2#show ip ospf neighbor

    Neighbor ID Pri State Dead Time Address Interface
    4.4.4.4 0 FULL/ - 00:00:38 24.24.24.4 Tunnel2
    1.1.1.1 0 FULL/ - 00:00:37 172.16.12.1 Serial0/0
    3.3.3.3 0 FULL/ - 00:00:38 172.16.23.3 Serial0/1

    Doing a show ip route ospf on R4 and R2 yields full reachability


    R4#show ip route ospf
    172.16.0.0/16 is variably subnetted, 10 subnets, 2 masks
    O IA 172.16.2.32/27 [110/11112] via 24.24.24.2, 00:00:00, Tunnel4
    O IA 172.16.23.0/24 [110/11175] via 24.24.24.2, 00:00:00, Tunnel4
    O 172.16.12.0/24 [110/11175] via 24.24.24.2, 00:00:00, Tunnel4
    O 172.16.1.0/24 [110/11176] via 24.24.24.2, 00:00:00, Tunnel4
    O IA 172.16.2.0/27 [110/11112] via 24.24.24.2, 00:00:00, Tunnel4
    O IA 172.16.3.0/24 [110/11176] via 24.24.24.2, 00:00:00, Tunnel4
    O IA 172.16.2.96/27 [110/11112] via 24.24.24.2, 00:00:00, Tunnel4
    O IA 172.16.2.64/27 [110/11112] via 24.24.24.2, 00:00:00, Tunnel4


    R2#show ip route ospf
    172.16.0.0/16 is variably subnetted, 10 subnets, 2 masks
    O IA 172.16.4.0/24 [110/11112] via 24.24.24.4, 00:02:02, Tunnel2
    O 172.16.1.0/24 [110/65] via 172.16.12.1, 00:05:57, Serial0/0
    O 172.16.3.0/24 [110/65] via 172.16.23.3, 00:07:08, Serial0/1


    I don't know if I configured it the correct way but it does work.
    I'm an Xpert at nothing apart from remembering useless information that nobody else cares about.
Sign In or Register to comment.