Options

IPv6 Redistribution - missing something

FatbunnyFatbunny Member Posts: 44 ■■□□□□□□□□
Need some help here, I cannot see what I am missing, I am working through the example on Route FLG p800, four routers, R1 running RIP, R4 running OSPF, R2 and R3 redistributing between RIP and OSPF. Routing tables look fine but I cannot ping the loopback on R1 from R4. All routers can ping their directly connected routers fine.






R1
R1#sh run
Building configuration...

Current configuration : 1446 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
no network-clock-participate slot 1
no network-clock-participate wic 0
ip cef
!
!
!
!
ipv6 unicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback1
 no ip address
 ipv6 address 101::1/64
!
interface FastEthernet0/0
 ip address 192.168.100.201 255.255.255.0
 shutdown
 duplex auto
 speed auto
!
interface BRI0/0
 no ip address
 encapsulation hdlc
 shutdown
!
interface Serial0/0
 description connected to serial 1
 no ip address
 encapsulation frame-relay
 ipv6 address FE80::1 link-local
 ipv6 address 123::1/64
 ipv6 rip R1R3 enable
 ipv6 rip R1R2 enable
 no fair-queue
 frame-relay map ipv6 123::2 112 broadcast
 frame-relay map ipv6 123::3 113 broadcast
 no frame-relay inverse-arp
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
!
!
no ip http server
no ip http secure-server
!
ipv6 router rip R1R2
 redistribute connected
 redistribute rip R1R3
!
ipv6 router rip R1R3
 redistribute connected
 redistribute rip R1R2
  no split-horizon
  port 1013 multicast-group FF02::9
!
!
!
ipv6 prefix-list PREFIX_103 seq 5 permit 103::/64
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
!
end

R1#sh ipv6 route
IPv6 Routing Table - 11 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
R   24::/64 [120/2]
     via FE80::2, Serial0/0
R   34::/64 [120/2]
     via FE80::3, Serial0/0
C   101::/64 [0/0]
     via ::, Loopback1
L   101::1/128 [0/0]
     via ::, Loopback1
R   102::1/128 [120/2]
     via FE80::2, Serial0/0
R   103::/64 [120/2]
     via FE80::3, Serial0/0
R   104::/64 [120/2]
     via FE80::3, Serial0/0
C   123::/64 [0/0]
     via ::, Serial0/0
L   123::1/128 [0/0]
     via ::, Serial0/0
L   FE80::/10 [0/0]
     via ::, Null0
L   FF00::/8 [0/0]
     via ::, Null0
R1#ping 24::2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 24::2, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R1#

R2
R2#sh run
Building configuration...

Current configuration : 1481 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
no network-clock-participate slot 1
no network-clock-participate wic 0
ip cef
!
!
!
!
no ip domain lookup
ipv6 unicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback1
 no ip address
 ipv6 address 102::1/128
!
interface FastEthernet0/0
 ip address 192.168.100.202 255.255.255.0
 duplex auto
 speed auto
!
interface BRI0/0
 no ip address
 encapsulation hdlc
 shutdown
!
interface Serial0/0
 description connected to serial 2
 no ip address
 encapsulation frame-relay
 no fair-queue
 no frame-relay inverse-arp
!
interface Serial0/0.1 point-to-point
 ipv6 address FE80::2 link-local
 ipv6 address 123::2/64
 ipv6 rip R1R2 enable
 frame-relay interface-dlci 121
!
interface Serial0/0.4 point-to-point
 ipv6 address FE80::2 link-local
 ipv6 address 24::2/64
 ipv6 ospf 1 area 0
 frame-relay interface-dlci 125
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
!
!
!
ip http server
no ip http secure-server
!
ipv6 router ospf 1
 log-adjacency-changes
 redistribute connected
 redistribute rip R1R2
!
ipv6 router rip R1R2
 redistribute connected
 redistribute ospf 1 metric 1
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
!
end

R2#sh ipv6 route
IPv6 Routing Table - 11 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
C   24::/64 [0/0]
     via ::, Serial0/0.4
L   24::2/128 [0/0]
     via ::, Serial0/0.4
OE2  34::/64 [110/20]
     via FE80::4, Serial0/0.4
R   101::/64 [120/2]
     via FE80::1, Serial0/0.1
LC  102::1/128 [0/0]
     via ::, Loopback1
R   103::/64 [120/3]
     via FE80::1, Serial0/0.1
OE2  104::/64 [110/20]
     via FE80::4, Serial0/0.4
C   123::/64 [0/0]
     via ::, Serial0/0.1
L   123::2/128 [0/0]
     via ::, Serial0/0.1
L   FE80::/10 [0/0]
     via ::, Null0
L   FF00::/8 [0/0]
     via ::, Null0
R2#ping 101::1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 101::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/67/112 ms
R2#



R3
R3#sh run
Building configuration...

Current configuration : 1946 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
no dot11 syslog
ip source-route
!
!
!
!
ip cef
ipv6 unicast-routing
ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
!
!
interface Loopback0
 no ip address
 ipv6 address 103::1/64
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface ATM0/0/0
 no ip address
 shutdown
 no atm ilmi-keepalive
!
interface Serial0/1/0
 no ip address
 encapsulation frame-relay
 no fair-queue
 no frame-relay inverse-arp
!
interface Serial0/1/0.1 point-to-point
 snmp trap link-status
 ipv6 address FE80::3 link-local
 ipv6 address 123::3/64
 ipv6 rip R1R3 enable
 frame-relay interface-dlci 131
!
interface Serial0/1/0.4 point-to-point
 snmp trap link-status
 ipv6 address FE80::3 link-local
 ipv6 address 34::3/64
 ipv6 ospf 2 area 0
 frame-relay interface-dlci 135
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
ipv6 router ospf 2
 router-id 3.3.3.3
 log-adjacency-changes
 redistribute connected metric-type 1 tag 3333
 redistribute rip R1R3
!
ipv6 router rip R1R3
 redistribute connected
 redistribute ospf 2 metric 1
  port 1013 multicast-group FF02::9
!
!
!
!
!
route-map CONN_PREFIX permit 10
 match ipv6 address PREFIX_34
 set metric 15
!
route-map CONN_PREFIX permit 20
 match ipv6 address prefix-list PREFIX_103
 set metric 5
!
route-map LOOPBACKS permit 10
 match ipv6 address L103
!
!
!
!
ipv6 access-list PREFIX_34
 permit ipv6 34::/64 any
!
ipv6 access-list L103
 permit ipv6 103::/64 any
!
control-plane
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
scheduler allocate 20000 1000
end

R3#sh ipv6 route
IPv6 Routing Table - Default - 11 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, M - MIPv6, R - RIP, I1 - ISIS L1
       I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP
       EX - EIGRP external
       O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
OE2 24::/64 [110/20]
     via FE80::4, Serial0/1/0.4
C   34::/64 [0/0]
     via Serial0/1/0.4, directly connected
L   34::3/128 [0/0]
     via Serial0/1/0.4, receive
OE2 101::/64 [110/20]
     via FE80::4, Serial0/1/0.4
OE2 102::1/128 [110/20]
     via FE80::4, Serial0/1/0.4
C   103::/64 [0/0]
     via Loopback0, directly connected
L   103::1/128 [0/0]
     via Loopback0, receive
OE2 104::/64 [110/20]
     via FE80::4, Serial0/1/0.4
C   123::/64 [0/0]
     via Serial0/1/0.1, directly connected
L   123::3/128 [0/0]
     via Serial0/1/0.1, receive
L   FF00::/8 [0/0]
     via Null0, receive
R3#


R4
R4_2851#sh run
Building configuration...

Current configuration : 1578 bytes
!
! No configuration change since last restart
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4_2851
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
no network-clock-participate wic 0
!
!
ip cef
!
!
no ip domain lookup
ipv6 unicast-routing
!
!
!
voice-card 0
 no dspfarm
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
controller E1 0/0/0
!
!
!
!
!
!
interface Loopback0
 no ip address
 ipv6 address 104::1/64
!
interface GigabitEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1/0
 no ip address
 encapsulation frame-relay
 no frame-relay inverse-arp
!
interface Serial0/1/0.1 point-to-point
!
interface Serial0/1/0.2 point-to-point
 ipv6 address FE80::4 link-local
 ipv6 address 24::4/64
 ipv6 ospf 1 area 0
 frame-relay interface-dlci 152
!
interface Serial0/1/0.3 point-to-point
 ipv6 address FE80::4 link-local
 ipv6 address 34::4/64
 ipv6 ospf 2 area 0
 frame-relay interface-dlci 153
!
!
!
ip http server
no ip http secure-server
!
ipv6 router ospf 1
 router-id 4.4.4.4
 log-adjacency-changes
 redistribute connected
 redistribute ospf 2
!
ipv6 router ospf 2
 router-id 4.4.4.5
 log-adjacency-changes
 redistribute connected
 redistribute ospf 1
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
!
gatekeeper
 shutdown
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
scheduler allocate 20000 1000
!
end

R4_2851#sh ipv6 route
IPv6 Routing Table - 12 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
C   24::/64 [0/0]
     via ::, Serial0/1/0.2
L   24::4/128 [0/0]
     via ::, Serial0/1/0.2
C   34::/64 [0/0]
     via ::, Serial0/1/0.3
L   34::4/128 [0/0]
     via ::, Serial0/1/0.3
OE2  101::/64 [110/20]
     via FE80::2, Serial0/1/0.2
OE2  102::1/128 [110/20]
     via FE80::2, Serial0/1/0.2
OE2  103::/64 [110/20]
     via FE80::2, Serial0/1/0.2
C   104::/64 [0/0]
     via ::, Loopback0
L   104::1/128 [0/0]
     via ::, Loopback0
OE2  123::/64 [110/20]
     via FE80::2, Serial0/1/0.2
L   FE80::/10 [0/0]
     via ::, Null0
L   FF00::/8 [0/0]
     via ::, Null0
R4_2851#ping 123::2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 123::2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/56/60 ms
R4_2851#ping 123::3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 123::3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 112/112/116 ms
R4_2851#ping 101::1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 101::1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R4_2851#ping 123::1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 123::1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R4_2851#

Sign In or Register to comment.