Help With Lab Please

Danielh22185Danielh22185 Member Posts: 1,195 ■■■■□□□□□□
I am doing the last OSPF CBT Video / Lab.

Jeremy has you setup a large multi area ospf topology. I am not far in but ran into a snag. For some reason I cannot figure out why I cannot see loopbacks from R3 in R2's routing table and or any other router that should see them, like R1. This has got to be something simple but its killing me. FYI Jermey basically has you setup loopbacks to simulate additional networks in the area.

Any ideas what I am missing that is prevent me from seeing the 172.30.x.x routes (my loopbacks) in R2's table and or any other routers that should see them? I am assuming its something that isn't configured right on R3 however I have provided configs for R3, R2, and R1.



Configs:
R3# sh runBuilding configuration...


Current configuration : 1513 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
ip domain name lab.local
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 172.30.0.1 255.255.255.0
 ip ospf network point-to-point
!
interface Loopback1
 ip address 172.30.1.1 255.255.255.0
 ip ospf network point-to-point
!
interface Loopback2
 ip address 172.30.2.1 255.255.255.0
 ip ospf network point-to-point
!
interface Loopback3
 ip address 172.30.3.1 255.255.255.0
 ip ospf network point-to-point
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 10.23.1.3 255.255.255.0
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
router ospf 1
 router-id 3.3.3.3
 log-adjacency-changes
 network 10.23.1.3 0.0.0.0 area 23
 network 172.30.0.1 0.0.0.0 area 23
 network 172.30.1.1 0.0.0.0 area 23
 network 172.30.2.1 0.0.0.0 area 23
 network 172.30.3.1 0.0.0.0 area 23
 network 172.30.0.0 0.0.255.255 area 23
!
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end






---------------------


R2#sh run
Building configuration...


Current configuration : 1012 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
ip domain name lab.local
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 10.100.1.2 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 10.23.1.2 255.255.255.0
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
router ospf 1
 router-id 2.2.2.2
 log-adjacency-changes
 network 10.23.1.2 0.0.0.0 area 24
 network 10.100.1.2 0.0.0.0 area 0
!
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end




----------


R1# sh run
Building configuration...


Current configuration : 1126 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
ip domain name lab.local
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 10.100.1.1 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 shutdown
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
router ospf 1
 router-id 1.1.1.1
 log-adjacency-changes
 network 10.100.1.1 0.0.0.0 area 0
!
ip route 172.31.0.0 255.255.255.0 Null0
ip route 172.31.1.0 255.255.255.0 Null0
ip route 172.31.2.0 255.255.255.0 Null0
ip route 172.31.3.0 255.255.255.0 Null0
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end


Currently Studying: IE Stuff...kinda...for now...
My ultimate career goal: To climb to the top of the computer network industry food chain.
"Winning means you're willing to go longer, work harder, and give more than anyone else." - Vince Lombardi

Comments

  • aquillaaquilla South East, UKMember Posts: 148 ■■■□□□□□□□
    Hi Danielh,

    I've only looked at this briefly so there might be more than one problem, but I've seen the following:

    - Check your OSPF configuration on R2 and R3 for the point-to-point link between the two routers. On R3 you have configured the area ID as 23 and on R2 you have configured it as 24.

    Regards,

    Stuart.
    Regards,

    CCNA R&S; CCNP R&S
  • Danielh22185Danielh22185 Member Posts: 1,195 ■■■■□□□□□□
    HAHA! You are good! I swear I looked at the configs on the affecting routers for quite a while. I Can't believe I didn't catch this!! Thanks so much! That was the problem. After configuring R2 for area 23 instead of 24 like it should be, everything worked.

    Silly me. Thanks again!
    Currently Studying: IE Stuff...kinda...for now...
    My ultimate career goal: To climb to the top of the computer network industry food chain.
    "Winning means you're willing to go longer, work harder, and give more than anyone else." - Vince Lombardi
Sign In or Register to comment.