Virtual Box OpenSuse question

DragonrangerDragonranger Posts: 101Member
Howdy! First post in the Linux section! So Im really trying to improve my technical knowledge. Recently I missed out on a tech job in my company due to my inexperience with linux. Ive want to try and accustom myself to it so I decided to run a virtual box with OpenSuse 12.2 KDE installed.
I thought using Opensuse to do my regular internet browsing would be a good way to start myself off. However I cant seem to get it to run updates or install flash so I can get youtube up and running. Whenever I run the update Opensuse just sits there and does nothing at all. Yes ive let it run for awhile before deciding its not working. Is running a virtual box preventing these updates from working?
Thanks!

Comments

  • hiddenknight821hiddenknight821 ■■■■■□□□□□ Posts: 1,209Member ■■■■■□□□□□
    Not very familiar with OpenSUSE, but since all Linux OSes are fundamentally the same, I can help. I can assure you that the VirtualBox is not the culprit, unless it didn't boot the OS at all, which could indicate architecture incompatibility (which is not the case here).

    Did you update it through the YaST (Yet another Setup Tool), which is a GUI front-end for Zypp update-package-manager? I'd hate to stare at the GUI, not seeing what's running and later learned it's broken. I'll have you know that I like to get my hands dirty under the hood in the command-line, and so should you. The Zypper command looks intriguing. Have a look at the command ****-sheet PDF straight from the horse's mouth. I gotta say it looks sexy. icon_lol.gif
  • brownwrapbrownwrap Posts: 549Member
    I had never seen that Opensuse **** sheet. A great healp.
  • DragonrangerDragonranger Posts: 101Member
    Ok I have flash support! Heres what I did. I updated the system through YAST (Wow long download) Afterward I went to the adobe site to download Flash. None of the Yum., Tar.gz or RPM files from adobe's site did anything for me. I found a download link on some opensuse site and installed from there. I now have flash support on my Susebox. Hoping it makes it easier for me to boot it up and use it for my homework and professor messer making it easier for me to use it.
    Tho i do have another question. Whenever I minimize my Konqueror browser I cant figure out where it minimizes too. I certainly dont see in in the taskbar and opening the browser icon again does not reopen the page I was looking at. So where is it? Haha I feel very noobish right now.
  • petedudepetedude Posts: 1,510Member
    Ok I have flash support! Heres what I did.
    . . .

    About OpenSUSE updates, as you're sure to run into this-- I personally don't usually take all of the recommended updates at once. Usually I right-click on the list, uncheck all, right-click again and select security updates. I then usually sift through the security updates and check a screenful at a time for installation. This way it helps to avoid the dreaded long download waits.

    Also, there's a zypper command that you can run to update your repositories, but I can't remember it at the moment. Idea is that sometimes update download sites change after a distro is released. Updating the repositories helps the downloads move more quickly as your update software won't have to hunt for the servers and/or there may be download servers added that are closer to you.
    Even if you're on the right track, you'll get run over if you just sit there.
    --Will Rogers
  • N2ITN2IT Posts: 7,483Inactive Imported Users
    Thanks for sharing your findings. I run the same exact set up V box with OpenSUSE and was wondering about this.

    Thanks
  • DragonrangerDragonranger Posts: 101Member
    @N2IT - Yup no worries
    So hey guys im really confused. When I minimize my browser whether it be Firefox or Konquerer the browser simply disappears. I really cant find it accessible anywhere on the desktop. So where does it go? I'd love for it to simply goto the taskbar. So what am I missing here? Any help is appreciated. Btw browsing this forum from my Linux box ! :) hahaha
  • DragonrangerDragonranger Posts: 101Member
    Ok so I figured it out. For anyone like me having problems with this. Heres what I did. You need to open the Widgets menu. Scroll over to Task Manager and add it to your Widgets list. Now I see the 10s of browsers I have open lol. Hope it helps.
  • DaBirdDaBird ■□□□□□□□□□ Posts: 8Registered Users ■□□□□□□□□□
    That OpenSUSE **** sheet is awesome. starting to get into OpenSUSE and that is actuaally pretty mad.
Sign In or Register to comment.