Runtime errors in vMA

EssendonEssendon Member Posts: 4,546 ■■■■■■■■■■
vMA is joined to the domain and can ping all hosts and vCenter like a star. When I run the following command I dont get an output, all it says is - Runtime error

esxcli --server vcenter.domain.local --vihost vesxi1.domain.local network nic list

I have tried adding both my vCenter and ESXi host using both adauth and fpauth authentication policies, but get the the same runtime error. If I target my ESXi host directly, the command esxicli network nic list runs without an issue.

Seems there's some kind of issue running the command against the vCenter machine. What could it be?

Another question - I ran the following command

resxtop --server vcenter.domain.local --vihost vesxi1.domain.local

The error I get is: Login failed, reason: Cannot find esxtop service on the host. Is the host powered on?

If I run the command - resxtop --vesxi1.domain.local

The command runs successfully. I ran esxtop by putty'ing to the host and it ran with no issues. Some weird stuff going on here for sure.
NSX, NSX, more NSX..

Blog >> http://virtual10.com

Comments

  • dave330idave330i Member Posts: 2,091 ■■■■■■■■■■
    Never ran vMA like that. I've always used vifptarget -s <host name>, then ran the commands directly against the host.
    2018 Certification Goals: Maybe VMware Sales Cert
    "Simplify, then add lightness" -Colin Chapman
  • EssendonEssendon Member Posts: 4,546 ■■■■■■■■■■
    Yeah I'd do that too, but the vMA guide from VMware runs commands against vCenter. Just wanted to know what I was missing.

    I'll keep plugging away at this and will update if I fix it.
    NSX, NSX, more NSX..

    Blog >> http://virtual10.com
  • blargoeblargoe Self-Described Huguenot NC, USAMember Posts: 4,174 ■■■■■■■■■□
    I don't think you need the --vihost part unless your esxi servers are in lockdown mode. I've never used it myself... just vifptarget -s servername, then the command (except for resxtop, which is resxtop --server servername)
    IT guy since 12/00

    Recent: 11/2019 - RHCSA (RHEL 7); 2/2019 - Updated VCP to 6.5 (just a few days before VMware discontinued the re-cert policy...)
    Working on: RHCE/Ansible
    Future: Probably continued Red Hat Immersion, Possibly VCAP Design, or maybe a completely different path. Depends on job demands...
Sign In or Register to comment.