Switch cant ping PC,

RemzRRRemzRR Member Posts: 11 ■□□□□□□□□□
Passed My CCNA back in June of 2012
Getting started in CCNP Switch and a lil rusty
Using CBT Nuggets and actual Hardware
Hardware I own
-x2 Cisco 2950
-x1 Cisco 3550 x24 Power

Having an issue w/ upgrading the Cisco IOS thru TFTP Server (Solarwinds TFTP Server) Switch cant ping PC
-Windows 7/Windows Security Essentials AV
-PC Connected to 3550 Switch via Ethernet Cable on Port 1 and Console Cable (PuttY)
-Computer/Motherboard has 2 ethernet ports (1 going to router/1 going to the switch)
--Both Ports are configured in the same subnet as router
---Router 192.168.0.1/PC Port 1 192.168.0.10/ PC Port 2 192.168.0.11
-Port 1 on the switch is configured to Vlan 100 which has an ip address which is in the same subnet as computer/router
-Verified Port 1 is UP/UP
-Switch has pc in the mac address table

From the PC I can ping the switch
The switch can ping itself but not the computer ???

I am lost here
The config file is listed below

Building configuration...

Current configuration : 1604 bytes
!
version 12.1
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch
!
!
ip subnet-zero
!
!
spanning-tree extend system-id
!
!
!
interface FastEthernet0/1
switchport access vlan 100
no ip address
!
interface FastEthernet0/2
no ip address
!
interface FastEthernet0/3
no ip address
!
interface FastEthernet0/4
no ip address
!
interface FastEthernet0/5
no ip address
!
interface FastEthernet0/6
no ip address
!
interface FastEthernet0/7
no ip address
!
interface FastEthernet0/8
no ip address
!
interface FastEthernet0/9
no ip address
!
interface FastEthernet0/10
no ip address
!
interface FastEthernet0/11
no ip address
!
interface FastEthernet0/12
no ip address
!
interface FastEthernet0/13
no ip address
!
interface FastEthernet0/14
no ip address
!
interface FastEthernet0/15
no ip address
!
interface FastEthernet0/16
no ip address
!
interface FastEthernet0/17
no ip address
!
interface FastEthernet0/18
no ip address
!
interface FastEthernet0/19
no ip address
!
interface FastEthernet0/20
no ip address
!
interface FastEthernet0/21
no ip address
!
interface FastEthernet0/22
no ip address
!
interface FastEthernet0/23
no ip address
!
interface FastEthernet0/24
no ip address
!
interface GigabitEthernet0/1
no ip address
!
interface GigabitEthernet0/2
no ip address
!
interface Vlan1
no ip address
shutdown
!
interface Vlan100
ip address 192.168.0.13 255.255.255.0
!
ip default-gateway 192.168.0.1
ip classless
ip http server
!
!
!
line con 0
line vty 5 15
!
end

Comments

  • mdominomdomino Member Posts: 81 ■■□□□□□□□□
    Not sure if you tried it already, but have you disabled the windows firewall (or whatever firewall software you are using)? It could be blocking the ICMP packets in addition to the TFTP. If the computer can ping the switch then the echos are being returned so you should have two-way communication.

    Check your firewall configuration and make sure you don't have internet security enabled, other than that it all looks good to me.

    backstory: this same issue KILLED me on GNS3 TFTP for like 3 hours...
  • FloOzFloOz Member Posts: 1,614 ■■■■□□□□□□
    Had the same issue awhile ago when I first started labbing and it drove me insane. The windows firewall was the issue as stated above
  • RemzRRRemzRR Member Posts: 11 ■□□□□□□□□□
    Disabled Windows Firewall but still can't ping from the switch to the PC in the same subnet..
  • mdominomdomino Member Posts: 81 ■■□□□□□□□□
    I know windows can be finnicky, as well, so you could try disabling all NICs that you aren't using for the process. It may be trying to route the packets out of the wrong one. If that works then I think you can throw a static route in windows to force it to use interface X for subnet XXX.
  • phoeneousphoeneous Go ping yourself... Member Posts: 2,333 ■■■■■■■□□□
    Why do you have both of your nic ports on the same subnet?
  • RemzRRRemzRR Member Posts: 11 ■□□□□□□□□□
    Before when I had the 2nd nic port on a different subnet the PC couldnt ping the switch
    When I added it to the same subnet it made a slight difference and now the pc can ping the switch but not vice versa
  • RemzRRRemzRR Member Posts: 11 ■□□□□□□□□□
    Thnx Mdomino....After taking a break I figured it out silly mistake
    I was trying to ping the 1st nic card's ip address and when I realized this and pinged the 2nd nic card it is fine and 100% success rate. In addition Windows firewall was getting in the way
    So Windows Firewall and the wrong ip address was the reason for this issue
    I will keep both nics on the same subnet moving forward...onto upgrading the IOS
  • mdominomdomino Member Posts: 81 ■■□□□□□□□□
    Good to hear! Windows loses it's mind sometime with multiple NICs, with my virtual loopback I'm using for GNS3 sometimes I have to set a static route or disable my real NIC to get it working.
  • FloOzFloOz Member Posts: 1,614 ■■■■□□□□□□
    oh yes be careful if you are using a laptop and you are also connected through wifi to your home network. Make sure you turn the wifi off or else your pings will be sent to through the wireless adapter. At least that's what was happening in my case.
  • b4s1cb4s1c Registered Users Posts: 1 ■□□□□□□□□□
    Thanks guys, after a few hours of frustration, finally found this thread and realized that could only be it. Perfect. icon_wink.gif
  • RemzRRRemzRR Member Posts: 11 ■□□□□□□□□□
    Damn blast to the past lol. Got an email notification on this issue. My lab is built, completely different than this 2013 setup. Currently studying for CCIE. My problems today are SSL VPN, IPv6 DMVPN etc. Thanks for all the help. Currently active in certcollection and INE forums
Sign In or Register to comment.