New IP Phones: My Voice Journey Begins :)

astrogeekastrogeek Member Posts: 251 ■■■□□□□□□□
I finally got around to picking up some IP phones off of ebay so I can start on the Voice track, but I have a few basic questions. Here's what I'm using for now in my voice lab:
  • 2611XM router with CME4.1 - Containing an SCCP image (P00308010200.bin, .loads, .sb2, & .sbn)
  • 3550 24 port POE switch
  • (4) 7940 IP Phones - Loaded with a SIP image (POS3-06-2-00)
  • (1) 7960 IP Phone - Also loaded with the same SIP image
  • Official Cert Guide - 640-461
Should I go with SCCP or SIP images? I'm not really sure which is better, but at this point since the router has SCCP and the phones have SIP images on them I guess I have to change one or the other.

I also can't seem to reset these phones to factory default. The instructions to hold down the # key as it boots up doesn't seem to work and I've noticed a lot of other people experiencing this same problem but I haven't read a solution for this. I was wondering maybe phones with a SIP image have a different process for resetting it to factory defaults. But because I don't have the same images on the router maybe I should wait on doing that since they do load up just fine. When they boot up they are loading the old firmware from the company they came from, along with other people's phone numbers in the directory - that's really the only reason I wanted to wipe the phones.

I also noticed this other thread, but didn't want to hijack it since I'm pretty sure the reason my phones aren't registering is because they are looking for SIP images that aren't in the router.


  • Options
    astrogeekastrogeek Member Posts: 251 ■■■□□□□□□□
    I'm a bit confused with how to flash the firmware on these phones. They are running SIP and I want to flash them to SCCP, I've downloaded the following files:

    The last zip file includes four .bin, .loads, .sb2, .sbn files I believe need to be on the router for the phones to load, but I'm not sure what the other 3 .cop, .cop.sgn, and .exe files are for. I tried to run the .exe file but came up with an error, I was hoping it would be an easy wizzard for flashing the phones icon_rolleyes.gif

    The instructions on Cisco's website mentions editing a text file named OS79XX.txt, but I don't have that one. This is what is currently on my router's flash:
    CME_Router#dir flash:
    Directory of flash:/
        1  -rw-    34584712                    <no date>  c2600-adventerprisek9-mz.124-15.T14.bin
        2  -rw-      130552                    <no date>  P00308010200.bin
        3  -rw-         461                    <no date>  P00308010200.loads
        4  -rw-      708448                    <no date>  P00308010200.sb2
        5  -rw-      130956                    <no date>  P00308010200.sbn
        6  -rw-        4802                    <no date>  admin_user.html
        7  -rw-      672015                    <no date>  admin_user.js
        8  -rw-       18836                    <no date>  app-b-acd-
        9  -rw-       24985                    <no date>  app-b-acd-
       10  -rw-       35485                    <no date>  app-b-acd-aa-
       11  -rw-        1602                    <no date>  CiscoLogo.gif
       12  -rw-         716                    <no date>  CME_GUI_README.TXT
       13  -rw-     1505280                    <no date>  common.tar
       14  -rw-      340631                    <no date>  CP7912080001SCCP051117A.sbin
       15  -rw-         953                    <no date>  Delete.gif
       16  -rw-       16344                    <no date>  dom.js
       17  -rw-         864                    <no date>  downarrow.gif
       18  -rw-       75650                    <no date>  en_bacd_allagentsbusy.au
       19  -rw-       83291                    <no date>  en_bacd_disconnect.au
       20  -rw-       63055                    <no date>  en_bacd_enter_dest.au
       21  -rw-       37952                    <no date>  en_bacd_invalidoption.au
       22  -rw-      496521                    <no date>  en_bacd_music_on_hold.au
       23  -rw-      123446                    <no date>  en_bacd_options_menu.au
       24  -rw-       42978                    <no date>  en_bacd_welcome.au
       25  -rw-       34794                    <no date>  en_bacd_xferto_operator.au
       26  -rw-        6146                    <no date>  ephone_admin.html
       27  -rw-      931840                    <no date>  es.tar
       28  -rw-        1038                    <no date>  home.shtml
       29  -rw-      112640                    <no date>  home.tar
       30  -rw-        4658                    <no date>  logohome.gif
       31  -rw-      496521                    <no date>  music-on-hold.au
       32  -rw-        3724                    <no date>  normal_user.html
       33  -rw-       81443                    <no date>  normal_user.js
       34  -rw-        1347                    <no date>  Plus.gif
       35  -rw-     6389760                    <no date>  sdm.tar
       36  -rw-        2754                    <no date>  sdmconfig-26xx.cfg
       37  -rw-         843                    <no date>  sxiconad.gif
       38  -rw-         174                    <no date>  Tab.gif
       39  -rw-        2431                    <no date>  telephony_service.html
       40  -rw-         870                    <no date>  uparrow.gif
       41  -rw-        9968                    <no date>  xml-test.html
       42  -rw-        3412                    <no date>  xml.template

    I haven't yet added the SCCP files I just downloaded, mostly because I'm not sure exactly what needs to be on the router. The current SCCP files are an older version that was on there when I bought the router. I'm just a little nervous about bricking these things so I want to make sure I'm flashing them right.
  • Options
    azaghulazaghul Member Posts: 569 ■■■■□□□□□□
    Given the version of CME you are using, I'd stick with the SCCP loads for the 7940's and 60's, as the handset features will be better supported. That said, I'm sure SIP has come a long way since then.

    With resetting, holding down the # when booting should work, when the line button lamps start to cycle release the # key and it will should display something like "Enter Reset Sequence", then enter the sequence:


    All things being equal (everything else is configured ok), the phones should start the firmware update process. Even with a PoE switch, I occasionally need a power brick plugged into the phone as well.

    Looking at your dir flash: the P00308010200 files look to be the ones to serve via TFTP for the 7940/60.
    tftp-server flash:P00308010200.bin
    tftp-server flash:P00308010200.loads
    tftp-server flash:P00308010200.sbn
    tftp-server flash:P00308010200.sb2

    Hopefully that should give you a start.
  • Options
    astrogeekastrogeek Member Posts: 251 ■■■□□□□□□□
    azaghul wrote: »
    With resetting, holding down the # when booting should work, when the line button lamps start to cycle release the # key and it will should display something like "Enter Reset Sequence", then enter the sequence:


    All things being equal (everything else is configured ok), the phones should start the firmware update process. Even with a PoE switch, I occasionally need a power brick plugged into the phone as well.
    I've tried this a ton of times and the phone doesn't go through the reset process, it just boots up as if I wasn't holding the # key down. I've looked around and it seems that some other people have this same issue. Do they need to be plugged into a power brick in order to be reset? I can try when I get home, but no where in any of the instructions did it mention that so who knows, worth a try at this point.
  • Options
    azaghulazaghul Member Posts: 569 ■■■■□□□□□□
    No, not all phones need a power brick for firmware updates, but I've found in the home lab on a 3550 that it does help for the 7941/42/61/62.

    Can you post the relevant bits of your config:
    Router: DHCP server, TFTP server, LAN interface/sub-interface, and telephony-service.
    Switch: trunk and user interface.

    Should be enough to get us started.

    ps: from your previous post, the .cop and .cop.sgn would be for uploading to CUCM, but I'd guess the .zip contains the actual files.
  • Options
    astrogeekastrogeek Member Posts: 251 ■■■□□□□□□□
    I just tried with the power brick connected but it's the same issue, nothing happens after holding down the # key. I'm thinking maybe that only works with SCCP firmware but not on SIP firmware - at least that would explain why some other people have the same problem.

    It's also worth mentioning that I've tried the only other known method for resetting the phones by going into Settings>Network Configuration, then pressing * * #, then entering 33, but that method doesn't work either.

    So now the question is how do I change these back to SCCP? icon_confused.gif:
  • Options
    DiggsDiggs Member Posts: 97 ■■□□□□□□□□
    I had a bit of an issue getting mine to factory reset as well - here's what I did:

    1. Unplugged the phone from the PoE switch
    2. Held down the # button
    3. While holding it down plug the Ethernet cable back into the switch
    4. Continue to hold it down until the lines start flashing in sequence from top to bottom
    5. Release the # button
    6. 123456789*0#

    Not sure if this will but hope it helps
  • Options
    astrogeekastrogeek Member Posts: 251 ■■■□□□□□□□
    Yea that's basically the same procedure I've been following, I've tried holding the # key before plugging the phone in (both with POE and just now using the power brick), but the phone never asks to enter in the reset sequence (123456789*0#). I've even tried entering this sequence when it should be asking for it, still nothing. I've watched some youtube videos showing the process and I'm just not getting the request to enter that sequence that others get.

    The weird thing is a lot of people with this issue seem to have a manually configured TFTP server that they can't change, but these phones are getting all new IP address information from my voice router, along with the option 150 pointing to the same voice router, so the DHCP and TFTP settings appear to be okay. I did run a debug tftp events while watching them boot up and they are looking for the OS79XX.TXT file, as well as their configuration files, none of which are in the router. I tried to create the OS79XX.TXT file and pointed it to the SCCP images that are in the router, but that didn't do anything differently.

    I wish I could just plug a console cable directly into these phones and wipe them like any router or switch!

    Here's the output from debug tftp events when the phone was booting up:
    *Mar 13 04:29:49.225: TFTP: Looking for OS79XX.TXT
    *Mar 13 04:29:49.237: TFTP: Looking for SIPDefault.cnf
    *Mar 13 04:29:49.249: TFTP: Looking for ./sip_phone/SIP000F2322E4BD.cnf
    *Mar 13 04:30:03.741: TFTP: Looking for RINGLIST.DAT
    *Mar 13 04:30:03.741: TFTP: Looking for dialplan.xml
  • Options
    DiggsDiggs Member Posts: 97 ■■□□□□□□□□
    By request you mean the line lights flashing from top to bottom?
  • Options
    astrogeekastrogeek Member Posts: 251 ■■■□□□□□□□
    No, I mean the phone never says "Reset key sequence detected", it just goes through the normal boot process.

    I tried again this time with a power brick attached to the phone and it's the same effect.
  • Options
    astrogeekastrogeek Member Posts: 251 ■■■□□□□□□□
    I've got a little bit of an update....I still can't seem to factory reset these phones, no clue why, but I can only guess it's because they are running SIP and maybe they use a different process, or this was locked by the previous owner?

    But the good news is I figured out how to get the phones to at least take new configuration files. I found some website that offered the SIPdefault.cnf, SIPXXXXXXXXXXXX.cnf, and dialplan.xml files and kinda shows how you can edit them (although to be honest I'm still a bit confused what edits I should be making). So far I figured out how to get the phones to boot up and change the banner name at the top and the names of the nodes for the buttons, woo hoo lol. They still aren't registering on my CME router though and I imagine it has something to do with them running SIP, and not SCCP which I'd prefer to use anyway.

    The problem I have is that the SCCP files I have that came with my router are 8.1(2), listed as P00308010200. However, in order to upgrade from an earlier version I need to first upgrade the phones to 8.1(1) listed as P00308010100. My Cisco account will let me download the ones I already have and newer versions, but not the 8.1(1) which I need. I tried to upgrade the phones anyway but it just fails and reboots them.

    Any ideas how to get the older firmware version?
Sign In or Register to comment.