Protocol Application Invalid Error when converting from SIP to SCCP

astrogeekastrogeek Senior MemberMember Posts: 251 ■■■□□□□□□□
I have 3 7940/7960 phones that I've been trying to convert to SCCP so I can follow along in the CCNA Voice book, but I keep getting this Protocol Application Invalid message and I'm not sure what I'm doing wrong.

This is the equipment I have:
(1) 2611XM router with CME 4.1
(1) 3550 POE switch
(2) 7940 IP phones w/SIP image P0S3-06-2-00
(1) 7960 IP phone w/SIP image P0S3-06-2-00

I'm trying to convert the phones to an SCCP image, (P00307020200).

I have the SCCP 7.2(2) images on the router and have the OS79XX.txt file pointing to this image, and the phones start the upgrade process but when they reboot they are looking for some configuration files that I don't have. At this point they are giving me the "Protocol Application Invalid" message and continue to look for the configuration files over and over. This is the tftp debug output:
CME_Router#*Mar 13 10:03:42.637: TFTP: Looking for OS79XX.TXT
*Mar 13 10:03:42.641: TFTP: Opened flash:OS79XX.TXT, fd 0, size 12 for process 168
*Mar 13 10:03:42.645: TFTP: Finished flash:OS79XX.TXT, time 00:00:00 for process 168
*Mar 13 10:03:43.026: TFTP: Looking for P00307020200.sbn
*Mar 13 10:03:43.026: TFTP: Opened flash:P00307020200.sbn, fd 0, size 129196 for process 168
CME_Router#
*Mar 13 10:03:45.386: TFTP: Finished flash:P00307020200.sbn, time 00:00:02 for process 168
CME_Router#
*Mar 13 10:04:24.214: TFTP: Looking for CTLSEP0006D79C2B6F.tlv
*Mar 13 10:04:24.242: TFTP: Looking for SEP0006D79C2B6F.cnf.xml
*Mar 13 10:04:24.242: TFTP: Opened system:/its/XMLDefault7960.cnf.xml, fd 0, size 0 for process 168
*Mar 13 10:04:24.250: TFTP: Finished system:/its/XMLDefault7960.cnf.xml, time 00:00:00 for process 168
CME_Router#
*Mar 13 10:04:53.333: TFTP: Looking for CTLSEP0006D79C2B6F.tlv
*Mar 13 10:04:53.361: TFTP: Looking for SEP0006D79C2B6F.cnf.xml
*Mar 13 10:04:53.361: TFTP: Opened system:/its/XMLDefault7960.cnf.xml, fd 0, size 0 for process 168
*Mar 13 10:04:53.365: TFTP: Finished system:/its/XMLDefault7960.cnf.xml, time 00:00:00 for process 168
CME_Router#
If I leave the phone on with the PAI error message on the screen it just continues looking for the above files over and over. I can get the phones back onto the SIP images, but whenever I try to convert to SCCP the same thing happens all over.

I'm not sure what I'm doing wrong here, here are the configs of both the router and switch, plus the router's flash:

CME Router configs:
CME_Router#sh run
Building configuration...

Current configuration : 4271 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CME_Router
!
boot-start-marker
boot-end-marker
!
logging buffered 4096
!
no aaa new-model
no network-clock-participate slot 1 
no network-clock-participate wic 0 
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 172.16.1.1 172.16.1.10
ip dhcp excluded-address 172.16.2.1 172.16.2.10
!
ip dhcp pool Data
   network 172.16.1.0 255.255.255.0
   default-router 172.16.1.1 
!
ip dhcp pool Phones
   network 172.16.2.0 255.255.255.0
   default-router 172.16.2.1 
   option 150 ip 172.16.2.1 
   dns-server 4.2.2.2 
!
!
no ip domain lookup
ip dhcp-server 172.16.2.1
!
multilink bundle-name authenticated
!
!
!
!
!
!
!         
!
!
!
!
!
!
!
!
!
!
!
crypto pki trustpoint TP-self-signed-3302339967
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-3302339967
 revocation-check none
 rsakeypair TP-self-signed-3302339967
!
!
crypto pki certificate chain TP-self-signed-3302339967
 certificate self-signed 01
  30820242 308201AB A0030201 02020101 300D0609 2A864886 F70D0101 04050030 
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274 
  69666963 6174652D 33333032 33333939 3637301E 170D3133 30333133 30343537 
  33355A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649 
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 33303233 
  33393936 3730819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281 
  81008F39 40B5A5D6 F9BA5B75 431EAF64 A172584E 95E670D7 E690472B BCC84999 
  7FA6D2E0 2EF2EDB9 E8383A37 CE8D81FA 02B08D30 7A5A8FD6 6CD1A36B 78EF77F7 
  C24DFD52 11F46B52 1E7D0B57 B92F1011 6C537E11 C87286B9 86C762FE 3E57A8E7 
  B923946A 2B61A7E1 D584EE67 BB69E5C2 1B02F326 076BBCB8 636E64F4 8EBFEF30 
  DF8F0203 010001A3 6A306830 0F060355 1D130101 FF040530 030101FF 30150603 
  551D1104 0E300C82 0A434D45 5F526F75 74657230 1F060355 1D230418 30168014 
  7B333357 C8800A24 5AB70C8A A53FF2C2 C598FE6E 301D0603 551D0E04 1604147B 
  333357C8 800A245A B70C8AA5 3FF2C2C5 98FE6E30 0D06092A 864886F7 0D010104 
  05000381 81002305 9C48F832 1B1B220A DF94723B 88FFC947 A4901A36 39F45984 
  B7082042 99101F1B A82071B4 474E3AB7 4108BA1F 9B2CCD77 84C8CAD5 74D8EFE0 
  A9BD11D0 AB3F254B 4B605954 1585B735 CAEEE94B 880B0E3F 74649C3C EBC2E9C0 
  EE54ACDE AFB4E7C1 1F2821C7 B555FC41 CD499C0F D5528C54 2B989DDD 867C6DFE 
  E95CD41D AFB7
        quit
!
!
username aaron privilege 15 secret 5 $1$v9ow$07UH4jyjnyeQENhtHhKIE/
archive
 log config
  hidekeys
! 
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.1
 description Data
 encapsulation dot1Q 10
 ip address 172.16.1.1 255.255.255.0
!
interface FastEthernet0/0.2
 description Voice
 encapsulation dot1Q 20 native
 ip address 172.16.2.1 255.255.255.0
!         
interface FastEthernet0/0.3
 description Admin
 encapsulation dot1Q 99
 ip address 172.16.10.1 255.255.255.0
!
interface Serial0/0
 no ip address
 shutdown
 no fair-queue
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
ip forward-protocol nd
!
!
ip http server
ip http secure-server
!
!         
!
!
!
tftp-server flash:P00307020200.bin alias P00307020200.bin
tftp-server flash:P00307020200.loads alias P00307020200.loads
tftp-server flash:P00307020200.sb2 alias P00307020200.sb2
tftp-server flash:P00307020200.sbn alias P00307020200.sbn
tftp-server flash:OS79XX.TXT alias OS79XX.TXT
!
control-plane
!
!
!
voice-port 1/0/0
!
voice-port 1/0/1
!
voice-port 1/1/0
!
voice-port 1/1/1
!
!
!         
!
!
!
!
!
telephony-service
 load 7960-7940 P00307020200
 max-ephones 24
 max-dn 48
 ip source-address 172.16.2.1 port 2000
 max-conferences 4 gain -6
 transfer-system full-consult
!
!
ephone-dn  1
 number 1000
!
!
ephone-dn  2  dual-line
 number 1001 secondary 6615101001
!
!
ephone  1 
 device-security-mode none
 mac-address 0030.94C2.DB93
 type 7960
 button  1:1 2:2
!
!
!
ephone  2
 device-security-mode none
 mac-address 000F.2322.E4BD
 type 7940
 button  1:1 2:2
!
!
!
ephone  3
 device-security-mode none
 mac-address 0006.D79C.2B6F
 type 7940
 button  1:1 2:2
!
!
!         
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 exec-timeout 0 0
 login local
 transport input telnet ssh
!
!
end


CME_Router#

CME_Router Flash:
CME_Router#dir flash:
Directory of flash:/

    1  -rw-    34584712                    <no date>  c2600-adventerprisek9-mz.124-15.T14.bin
    2  -rw-      130552                    <no date>  P00308010200.bin
    3  -rw-         461                    <no date>  P00308010200.loads
    4  -rw-      708448                    <no date>  P00308010200.sb2
    5  -rw-      130956                    <no date>  P00308010200.sbn
    6  -rw-        4802                    <no date>  admin_user.html
    7  -rw-      672015                    <no date>  admin_user.js
    8  -rw-       18836                    <no date>  app-b-acd-2.1.2.2-ReadMe.txt
    9  -rw-       24985                    <no date>  app-b-acd-2.1.2.2.tcl
   10  -rw-       35485                    <no date>  app-b-acd-aa-2.1.2.2.tcl
   11  -rw-        1602                    <no date>  CiscoLogo.gif
   12  -rw-         716                    <no date>  CME_GUI_README.TXT
   13  -rw-     1505280                    <no date>  common.tar
   14  -rw-      340631                    <no date>  CP7912080001SCCP051117A.sbin
   15  -rw-         953                    <no date>  Delete.gif
   16  -rw-       16344                    <no date>  dom.js
   17  -rw-         864                    <no date>  downarrow.gif
   18  -rw-       75650                    <no date>  en_bacd_allagentsbusy.au
   19  -rw-       83291                    <no date>  en_bacd_disconnect.au
   20  -rw-       63055                    <no date>  en_bacd_enter_dest.au
   21  -rw-       37952                    <no date>  en_bacd_invalidoption.au
   22  -rw-      496521                    <no date>  en_bacd_music_on_hold.au
   23  -rw-      123446                    <no date>  en_bacd_options_menu.au
   24  -rw-       42978                    <no date>  en_bacd_welcome.au
   25  -rw-       34794                    <no date>  en_bacd_xferto_operator.au
   26  -rw-        6146                    <no date>  ephone_admin.html
   27  -rw-      931840                    <no date>  es.tar
   28  -rw-        1038                    <no date>  home.shtml
   29  -rw-      112640                    <no date>  home.tar
   30  -rw-        4658                    <no date>  logohome.gif
   31  -rw-      496521                    <no date>  music-on-hold.au
   32  -rw-        3724                    <no date>  normal_user.html
   33  -rw-       81443                    <no date>  normal_user.js
   34  -rw-        1347                    <no date>  Plus.gif
   35  -rw-     6389760                    <no date>  sdm.tar
   36  -rw-        2754                    <no date>  sdmconfig-26xx.cfg
   37  -rw-         843                    <no date>  sxiconad.gif
   38  -rw-         174                    <no date>  Tab.gif
   39  -rw-        2431                    <no date>  telephony_service.html
   40  -rw-         870                    <no date>  uparrow.gif
   41  -rw-        9968                    <no date>  xml-test.html
   42  -rw-        3412                    <no date>  xml.template
   45  -rw-      486570                    <no date>  P0S3-06-2-00.bin
   46  -rw-      486974                    <no date>  P0S3-06-2-00.sbn
   49  -rw-        1769                    <no date>  SIP000f2322e4bd.cnf
   50  -rw-        1769                    <no date>  SIP0006d79c2b6f.cnf
   51  -rw-        1769                    <no date>  SIP003094c2db93.cnf
   53  -rw-          69                    <no date>  syncinfo.xml
   54  -rw-        1837                    <no date>  SIPDefault.cnf
   55  -rw-        3579                    <no date>  softkeyDefault_kpml.xml
   56  -rw-        3613                    <no date>  softkeyDefault.xml
   59  -rw-      128792                    <no date>  P00307020200.bin
   60  -rw-         458                    <no date>  P00307020200.loads
   61  -rw-      680394                    <no date>  P00307020200.sb2
   62  -rw-      129196                    <no date>  P00307020200.sbn
   65  -rw-          12                    <no date>  OS79XX.TXT


49807356 bytes total (689820 bytes free)
CME_Router#

3550 Switch configs:
Switch#sh run
Building configuration...

Current configuration : 3092 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Switch
!
!
username aaron privilege 15 secret 5 $1$JHQZ$vRl8h9xN5JbEdrXPP8t2Q/
no aaa new-model
ip subnet-zero
no ip domain-lookup
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
! 
!
!
!
interface Loopback1
 no ip address
!
interface FastEthernet0/1
 description Phone 1
 switchport access vlan 10
 switchport mode access
 switchport voice vlan 20
 shutdown
 spanning-tree portfast
!
interface FastEthernet0/2
 description Phone 2
 switchport access vlan 10
 switchport mode access
 switchport voice vlan 20
 shutdown
 spanning-tree portfast
!
interface FastEthernet0/3
 description Phone 3
 switchport access vlan 10
 switchport mode access
 switchport voice vlan 20
 shutdown
 spanning-tree portfast
!
interface FastEthernet0/4
 switchport access vlan 10
 switchport mode access
 shutdown
 spanning-tree portfast
!
interface FastEthernet0/5
 switchport access vlan 10
 switchport mode access
 shutdown
 spanning-tree portfast
!
interface FastEthernet0/6
 switchport mode access
 shutdown
!
interface FastEthernet0/7
 switchport access vlan 10
 switchport mode access
 shutdown
!
interface FastEthernet0/8
 switchport mode access
 shutdown
!
interface FastEthernet0/9
 switchport mode access
 shutdown
!
interface FastEthernet0/10
 switchport mode access
 shutdown
!
interface FastEthernet0/11
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/12
 switchport access vlan 10
 switchport mode access
 shutdown
 spanning-tree portfast
!
interface FastEthernet0/13
 switchport mode access
 shutdown
!
interface FastEthernet0/14
 switchport mode access
 shutdown
!         
interface FastEthernet0/15
 switchport mode access
 shutdown
!
interface FastEthernet0/16
 switchport mode access
 shutdown
!
interface FastEthernet0/17
 switchport mode access
 shutdown
!
interface FastEthernet0/18
 switchport mode access
 shutdown
!
interface FastEthernet0/19
 switchport mode access
 shutdown
!
interface FastEthernet0/20
 switchport mode access
 shutdown
!
interface FastEthernet0/21
 switchport mode access
 shutdown
!
interface FastEthernet0/22
 switchport mode access
 shutdown
!
interface FastEthernet0/23
 switchport mode access
 shutdown
!
interface FastEthernet0/24
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 20
 switchport mode trunk
!
interface GigabitEthernet0/1
 switchport mode access
 shutdown
!
interface GigabitEthernet0/2
 switchport mode access
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan99
 description Admin
 ip address 172.16.10.10 255.255.255.0
!
ip classless
no ip http server
no ip http secure-server
!
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line vty 0 4
 exec-timeout 0 0
 logging synchronous
 login local
 transport input telnet ssh
line vty 5 15
 exec-timeout 0 0
 logging synchronous
 login local
 transport input telnet ssh
!
end


Switch#

Comments

  • astrogeekastrogeek Senior Member Member Posts: 251 ■■■□□□□□□□
    Oh never mind, I finally figured it out. I was missing the command create cnf-files under telephony-service. Once I added that and rebooted the phones they finished the upgrade process. I'm now on the SCCP images and registered with the router.

    This is the configuration in full that was my problem area:
    telephony-service load 7960-7940 P00307020200
     max-ephones 24
     max-dn 48
     ip source-address 172.16.2.1 port 2000
     max-conferences 4 gain -6
     transfer-system full-consult
     [COLOR=#ff0000][B]create cnf-files[/B][/COLOR] version-stamp 7960 Mar 13 2013 05:14:02
    

    It's kind of weird this command and the deal with the OS79XX.txt files aren't even mentioned in the CCNA Voice book. Oh well, it was a good learning experience. Now it's time to have some real fun with the phones :)
Sign In or Register to comment.