PLEASE HELP: unable to download the kickstart file...

uberwebguruuberwebguru Member Posts: 29 ■□□□□□□□□□
i have tried for several hours to get this kickstart installation going but to no avail
i have port 21, 22 and 80 opened and even tried ftp and http to access this kickstart file but it won't work

i keep getiing the same error "unable to download the kickstart file."

What do i do now?
kickstart file has 755 permission and is on the host server accessible via http and also ftp
httpd and vsftpd are both running and no problem with them

so what exactly am i doing wrong here?

Thanks.

Comments

  • uberwebguruuberwebguru Member Posts: 29 ■□□□□□□□□□
    Just to also add...i have another VM and i was able to access the kickstart file easily via http and ftp no problem
    so where is this problem coming from?
  • log32log32 Users Awaiting Email Confirmation Posts: 217
    does the problematic computer get network access at all before attempting the http connection?
  • uberwebguruuberwebguru Member Posts: 29 ■□□□□□□□□□
    What do you by problematic computer?
    well yes there was http connection as the host is the one to perform the kickstart installation. I also mentioned that one VM was able to access the file via http with no problem...just that kickstart installation just was having problem getting the file
  • log32log32 Users Awaiting Email Confirmation Posts: 217
    not sure I understand fully..
    the client uses the config of the server for the kickstart installation, you said you already have a VM that is working perfectly, and another one that doesn't. so it sounds like a client problem, not a server(?!)
    if the kickstart startup loads network configuration O.K after the network manager is doing its' thing, and then it cannot find the cfg, make sure you point to the correct path. and that it is actually on the same network of the server.
    please spread some light if I did not understand the situation.
  • uberwebguruuberwebguru Member Posts: 29 ■□□□□□□□□□
    How do i know the kickstart startups network configuration correctly? How do i fix that because i mean is there a way to know if network is working fine on the VM while performing the kickstart? because i think that is where the problem is..i think there is just no network setup properly or something
  • BodanelBodanel Member Posts: 214 ■■■□□□□□□□
    Check the selinux file context. I've had the same issue. Also check the logs. It will point you in the right direction
  • uberwebguruuberwebguru Member Posts: 29 ■□□□□□□□□□
    here is selinux file context of the kickstart file

    unconfined_u : object_r : user_home_t : s0
  • uberwebguruuberwebguru Member Posts: 29 ■□□□□□□□□□
    Here is the content of FRESH /var/log/messages file after clearing all previous logs

    #####
    [[email protected] ~]# cat /var/log/messages
    Apr 2 23:38:30 host kernel: device vnet1 entered promiscuous mode
    Apr 2 23:38:30 host kernel: virbr0: topology change detected, propagating
    Apr 2 23:38:30 host kernel: virbr0: port 3(vnet1) entering forwarding state
    Apr 2 23:38:30 host NetworkManager[2257]: <warn> /sys/devices/virtual/net/vnet1: couldn't determine device driver; ignoring...
    Apr 2 23:38:30 host qemu-kvm: Could not find keytab file: /etc/qemu/krb5.tab: No such file or directory
    Apr 2 23:38:31 host avahi-daemon[2269]: Registering new address record for fe80::fc54:ff:fea7:14e2 on vnet1.*.
    Apr 2 23:40:41 host kernel: kvm: 5603: cpu0 disabled perfctr wrmsr: 0xc1 data 0xabcd
    Apr 2 23:41:03 host dnsmasq-dhcp[3135]: DHCPDISCOVER(virbr0) 52:54:00:a7:14:e2
    Apr 2 23:41:03 host dnsmasq-dhcp[3135]: DHCPOFFER(virbr0) 192.168.122.192 52:54:00:a7:14:e2
    Apr 2 23:41:03 host dnsmasq-dhcp[3135]: DHCPREQUEST(virbr0) 192.168.122.192 52:54:00:a7:14:e2
    Apr 2 23:41:03 host dnsmasq-dhcp[3135]: DHCPACK(virbr0) 192.168.122.192 52:54:00:a7:14:e2

    #####
  • BodanelBodanel Member Posts: 214 ■■■□□□□□□□
    If you share the file via ftp it should be public_content_t or something like this. For http is http_content_r. Try to access the file and post the /var/log/audit/audit.log
  • uberwebguruuberwebguru Member Posts: 29 ■□□□□□□□□□
    actually it miraculiusly just worked
    i mean i don't know what happened...i shutdown and then started the computer system and then i remember tryin git again and it failed again with same error and now i cleared the log in /var/log/messages and it still failed then i cleared the log in /var/log/httpd/error_log and then it worked...it is crazy..i have no idea what exactly the previous issue was...maybe in clearing the apache error log? cos that is the only thing i can think of right now

    Anyways it works now kickstart went 100% right.
Sign In or Register to comment.