QOS cos-map to dscp-map by queue help!

itdaddyitdaddy Senior MemberMember Posts: 2,088 ■■■■□□□□□□
/configure ques

//map cos-map to dscp-map input

mls qos srr-queue input cos-map queue 1 threshold 1 5
mls qos srr-queue input cos-map queue 2 threshold 1 6

mls qos srr-queue input dscp-map queue 1 threshold 1 40 41 42 43 44 45 46 47
mls qos srr-queue input dscp-map queue 2 threshold 1 48 49 50 51 52 53 54 55

//map cos-map to dscip-map output

mls qos srr-queue output cos-map queue 1 threshold 1 6
mls qos srr-queue output cos-map queue 4 threshold 1 5

mls qos srr-queue output dscp-map queue 1 threshold 1 48 49 50 51 52 53 54 55
mls qos srr-queue output dscp-map queue 4 threshold 1 40 41 42 43 44 45 46 47

// enable qos on switch

mls qos

//config interface boundary
//mitel phones cost set at phone

interface FastEthernet0/1
switchport access vlan 101
switchport trunk encapsulation dot1q
switchport trunk native vlan 101
switchport trunk allowed vlan 101,121
switchport mode trunk
priority-queue out //
mls qos trust cos //trust cos set by phone which is priority = 6
spanning-tree portfast

//configured trunk with DSCP set trust
interface GigabitEthernet0/3
description trunk to FourthAveDMZ Switch
switchport trunk encapsulation dot1q
switchport mode trunk
priority-queue out
mls qos trust dscp //trust the cos to dscp mapping on trunks


I have no clue what the DSCP values mean? like 40 to 47 etc....what doe they mean?
I do know that it is a cos to dscp mapping per que

but why dont they use queue 3? is there a reason to use only queue 1, 2, and 4 only?
and why would this guy make cos value of 6 for voice and cos value of 5 for data?
on our mitel phones the cos value or priority is hard coded to 6 that is how i know what it is on the access ports
coming in..but normal QOS says 5 is voice and maybe 4 is data? why would this guy make cos 6 voice when
maybe internet protocols use this? isnt this bad practice?

and do the routers see the dscp values since there is a trunk to our gateways from the switches?
is that how the routers use QOS to allow voice first priority in the interface queue? cause I see
no commands on our gateway router to allow for QOS just see the DSCP values? so the routers
by default use this diffserv stuf?

thanks for anyone helps just trying to understand this thanks ;)
sorry i was gone so long I have been in Philippines with my new sexy wife haahha gettting married in August 2013
2nd time is a charm..filipinas rock!
Sign In or Register to comment.