Options

HELP: STP Question

t5yll4t5yll4 Member Posts: 54 ■■□□□□□□□□
Hello,

I'm currently working on a lab and am having trouble figuring out how to resolve the following step:

Task 5: Configure STP.

Step 1. Configure STP on switch 1 so that it will dynamically make itself the root for vlans 10 and 20.



I issued the command (under global config): 'spanning-tree vlan 10,20 priority 0 but that didn't complete the step.

The subsequent step "Step 2. Configure STP on switch 3 so that it will be the root by having a specific priority on vlan 30 of 4096." was successfully completed after i issued 'spanning-tree vlan 30 priority 4096'

From my understanding of stp, the lowest priority will cause a switch to get elected as root. I made sure that stp mode was pvst but I'm still not able to figure out Step1. Not sure what i'm missing.

Here are the configs (still can't attach..getting invalid filetype erroricon_exclaim.gif )
++++++++
Switch1
++++++++
Current configuration : 1569 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname S1
!
enable secret 5 $1$mERr$9cTjUIEqNGurQiFU.ZeCi1
!
no ip domain-lookup
ip name-server 0.0.0.0
!
spanning-tree mode pvst
spanning-tree vlan 10,20 priority 0
!
interface FastEthernet0/1
switchport trunk native vlan 99
switchport mode trunk
!
interface FastEthernet0/2
switchport trunk native vlan 99
switchport mode trunk
!
interface FastEthernet0/3
switchport trunk native vlan 99
switchport mode trunk
!
interface FastEthernet0/4
switchport trunk native vlan 99
switchport mode trunk
!
interface FastEthernet0/5
switchport trunk native vlan 99
switchport mode trunk
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!
interface Vlan1
no ip address
shutdown
!
interface Vlan99
ip address 192.168.99.11 255.255.255.0
!
ip default-gateway 192.168.99.1
!
!
line con 0
password cisco
login
!
line vty 0 4
password cisco
login
line vty 5 15
login
!
!
end

*********************************************


++++++++
Switch3
++++++++
Current configuration : 1569 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname S3
!
enable secret 5 $1$mERr$9cTjUIEqNGurQiFU.ZeCi1
!
no ip domain-lookup
ip name-server 0.0.0.0
!
spanning-tree mode pvst
spanning-tree vlan 30 priority 4096
!
interface FastEthernet0/1
switchport trunk native vlan 99
switchport mode trunk
!
interface FastEthernet0/2
switchport trunk native vlan 99
switchport mode trunk
!
interface FastEthernet0/3
switchport trunk native vlan 99
switchport mode trunk
!
interface FastEthernet0/4
switchport trunk native vlan 99
switchport mode trunk
!
interface FastEthernet0/5
switchport trunk native vlan 99
switchport mode trunk
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!
interface Vlan1
no ip address
shutdown
!
interface Vlan99
ip address 192.168.99.13 255.255.255.0
!
ip default-gateway 192.168.99.1
!
!
line con 0
password cisco
login
!
line vty 0 4
password cisco
login
line vty 5 15
login
!
!
end

Your help is much appreciated.
2015 Certification Goals:
[ ] JNCDA (August), [ ] JNCIA-Junos (September), [ ] CCDA (pending), [ ] CCNP RS (tentative November)

"Duty then is the sublimest word in the English language. You should do your duty in all things. You can never do more, you should never wish to do less."
- Robert E. Lee

Comments

  • Options
    boobobobobobboobobobobob Member Posts: 118
    try the spanning-tree vlan 10,20 root primary ​command
  • Options
    DCDDCD Member Posts: 473 ■■■■□□□□□□
    Try some of your show commands it should display the information you want, Also if you could put the topology up as well.
  • Options
    t5yll4t5yll4 Member Posts: 54 ■■□□□□□□□□
    try the spanning-tree vlan 10,20 root primary ​command

    Tried that to no avail. Even tried line by line for each vlan thinking that the 10,20 syntax might be the culprit.
    DCD wrote: »
    Try some of your show commands it should display the information you want, Also if you could put the topology up as well.

    Here goes Topo:
    2015 Certification Goals:
    [ ] JNCDA (August), [ ] JNCIA-Junos (September), [ ] CCDA (pending), [ ] CCNP RS (tentative November)

    "Duty then is the sublimest word in the English language. You should do your duty in all things. You can never do more, you should never wish to do less."
    - Robert E. Lee
  • Options
    cisco_nerdcisco_nerd Member Posts: 198
    t5yll4 wrote: »
    Tried that to no avail. Even tried line by line for each vlan thinking that the 10,20 syntax might be the culprit.

    enter the command sh spanning-tree on both of the switches and post that up...

    by configuring S1 with a root priority of 0, it will make the BID for VLANs 10 and 20 to be 10 and 20 (priority + VLAN ID). S2 should then have a BID of 4126 (4096+30).
  • Options
    t5yll4t5yll4 Member Posts: 54 ■■□□□□□□□□
    cisco_nerd wrote: »
    enter the command sh spanning-tree on both of the switches and post that up...

    by configuring S1 with a root priority of 0, it will make the BID for VLANs 10 and 20 to be 10 and 20 (priority + VLAN ID). S2 should then have a BID of 4126 (4096+30).

    S1#sh spanning-tree
    VLAN0001
    Spanning tree enabled protocol ieee
    Root ID Priority 32769
    Address 0030.F20D.D6B1
    Cost 19
    Port 3(FastEthernet0/3)
    Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

    Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)
    Address 0050.0F68.146E
    Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
    Aging Time 20

    Interface Role Sts Cost Prio.Nbr Type
    ---- ---


    Fa0/1 Desg FWD 19 128.1 P2p
    Fa0/2 Desg FWD 19 128.2 P2p
    Fa0/3 Root FWD 19 128.3 P2p
    Fa0/4 Altn BLK 19 128.4 P2p
    Fa0/5 Desg FWD 19 128.5 P2p

    VLAN0010
    Spanning tree enabled protocol ieee
    Root ID Priority 10
    Address 0050.0F68.146E
    This bridge is the root
    Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

    Bridge ID Priority 10 (priority 0 sys-id-ext 10)
    Address 0050.0F68.146E
    Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
    Aging Time 20

    Interface Role Sts Cost Prio.Nbr Type
    ---- ---


    Fa0/1 Desg FWD 19 128.1 P2p
    Fa0/2 Desg FWD 19 128.2 P2p
    Fa0/3 Desg FWD 19 128.3 P2p
    Fa0/4 Desg FWD 19 128.4 P2p
    Fa0/5 Desg FWD 19 128.5 P2p

    VLAN0020
    Spanning tree enabled protocol ieee
    Root ID Priority 20
    Address 0050.0F68.146E
    This bridge is the root
    Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

    Bridge ID Priority 20 (priority 0 sys-id-ext 20)
    Address 0050.0F68.146E
    Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
    Aging Time 20

    Interface Role Sts Cost Prio.Nbr Type
    ---- ---


    Fa0/1 Desg FWD 19 128.1 P2p
    Fa0/2 Desg FWD 19 128.2 P2p
    Fa0/3 Desg FWD 19 128.3 P2p
    Fa0/4 Desg FWD 19 128.4 P2p
    Fa0/5 Desg FWD 19 128.5 P2p

    VLAN0030
    Spanning tree enabled protocol ieee
    Root ID Priority 4126
    Address 0030.F20D.D6B1
    Cost 19
    Port 3(FastEthernet0/3)
    Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

    Bridge ID Priority 32798 (priority 32768 sys-id-ext 30)
    Address 0050.0F68.146E
    Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
    Aging Time 20

    Interface Role Sts Cost Prio.Nbr Type
    ---- ---


    Fa0/1 Desg FWD 19 128.1 P2p
    Fa0/2 Desg FWD 19 128.2 P2p
    Fa0/3 Root FWD 19 128.3 P2p
    Fa0/4 Altn BLK 19 128.4 P2p
    Fa0/5 Desg FWD 19 128.5 P2p

    VLAN0099
    Spanning tree enabled protocol ieee
    Root ID Priority 32867
    Address 0030.F20D.D6B1
    Cost 19
    Port 3(FastEthernet0/3)
    Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

    Bridge ID Priority 32867 (priority 32768 sys-id-ext 99)
    Address 0050.0F68.146E
    Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
    Aging Time 20

    Interface Role Sts Cost Prio.Nbr Type
    ---- ---


    Fa0/1 Desg FWD 19 128.1 P2p
    Fa0/2 Desg FWD 19 128.2 P2p
    Fa0/3 Root FWD 19 128.3 P2p
    Fa0/4 Altn BLK 19 128.4 P2p
    Fa0/5 Desg FWD 19 128.5 P2p

    ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++


    S3#sh spanning-tree
    VLAN0001
    Spanning tree enabled protocol ieee
    Root ID Priority 32769
    Address 0030.F20D.D6B1
    This bridge is the root
    Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

    Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)
    Address 0030.F20D.D6B1
    Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
    Aging Time 20

    Interface Role Sts Cost Prio.Nbr Type
    ---- ---


    Fa0/1 Desg FWD 19 128.1 P2p
    Fa0/2 Desg FWD 19 128.2 P2p
    Fa0/3 Desg FWD 19 128.3 P2p
    Fa0/4 Desg FWD 19 128.4 P2p

    VLAN0010
    Spanning tree enabled protocol ieee
    Root ID Priority 10
    Address 0050.0F68.146E
    Cost 19
    Port 3(FastEthernet0/3)
    Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

    Bridge ID Priority 32778 (priority 32768 sys-id-ext 10)
    Address 0030.F20D.D6B1
    Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
    Aging Time 20

    Interface Role Sts Cost Prio.Nbr Type
    ---- ---


    Fa0/1 Desg FWD 19 128.1 P2p
    Fa0/2 Desg FWD 19 128.2 P2p
    Fa0/3 Root FWD 19 128.3 P2p
    Fa0/4 Altn BLK 19 128.4 P2p

    VLAN0020
    Spanning tree enabled protocol ieee
    Root ID Priority 20
    Address 0050.0F68.146E
    Cost 19
    Port 3(FastEthernet0/3)
    Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

    Bridge ID Priority 32788 (priority 32768 sys-id-ext 20)
    Address 0030.F20D.D6B1
    Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
    Aging Time 20

    Interface Role Sts Cost Prio.Nbr Type
    ---- ---


    Fa0/1 Desg FWD 19 128.1 P2p
    Fa0/2 Desg FWD 19 128.2 P2p
    Fa0/3 Root FWD 19 128.3 P2p
    Fa0/4 Altn BLK 19 128.4 P2p

    VLAN0030
    Spanning tree enabled protocol ieee
    Root ID Priority 4126
    Address 0030.F20D.D6B1
    This bridge is the root
    Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

    Bridge ID Priority 4126 (priority 4096 sys-id-ext 30)
    Address 0030.F20D.D6B1
    Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
    Aging Time 20

    Interface Role Sts Cost Prio.Nbr Type
    ---- ---


    Fa0/1 Desg FWD 19 128.1 P2p
    Fa0/2 Desg FWD 19 128.2 P2p
    Fa0/3 Desg FWD 19 128.3 P2p
    Fa0/4 Desg FWD 19 128.4 P2p

    VLAN0099
    Spanning tree enabled protocol ieee
    Root ID Priority 32867
    Address 0030.F20D.D6B1
    This bridge is the root
    Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

    Bridge ID Priority 32867 (priority 32768 sys-id-ext 99)
    Address 0030.F20D.D6B1
    Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
    Aging Time 20

    Interface Role Sts Cost Prio.Nbr Type
    ---- ---


    Fa0/1 Desg FWD 19 128.1 P2p
    Fa0/2 Desg FWD 19 128.2 P2p
    Fa0/3 Desg FWD 19 128.3 P2p
    Fa0/4 Desg FWD 19 128.4 P2p
    2015 Certification Goals:
    [ ] JNCDA (August), [ ] JNCIA-Junos (September), [ ] CCDA (pending), [ ] CCNP RS (tentative November)

    "Duty then is the sublimest word in the English language. You should do your duty in all things. You can never do more, you should never wish to do less."
    - Robert E. Lee
  • Options
    cisco_nerdcisco_nerd Member Posts: 198
    t5yll4 wrote: »

    S1

    VLAN0010
    Spanning tree enabled protocol ieee
    Root ID Priority 10
    Address 0050.0F68.146E
    This bridge is the root

    -- output omitted --

    VLAN0020
    Spanning tree enabled protocol ieee
    Root ID Priority 20
    Address 0050.0F68.146E
    This bridge is the root

    -- output omitted --

    ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

    S3

    VLAN0001
    Spanning tree enabled protocol ieee
    Root ID Priority 32769
    Address 0030.F20D.D6B1
    This bridge is the root

    -- output omitted --

    VLAN0030
    Spanning tree enabled protocol ieee
    Root ID Priority 4126
    Address 0030.F20D.D6B1
    This bridge is the root

    -- output omitted --

    VLAN0099
    Spanning tree enabled protocol ieee
    Root ID Priority 32867
    Address 0030.F20D.D6B1
    This bridge is the root

    -- output omitted --

    If you refer to the above in bold, the switches are configured and behaving as you would expect them to. S1 is configured as the Root Bridge for VLANs 10 (BID 10) and 20 (BID 20). And S3 is configured as the Root Bridge for VLAN 30 (BID 4126) (also happens to be the Root for VLANs 1 and 99 as a bonus).

    So your config is correct and STP is as it should be as per your lab questions.

    A point to note that whenever configuring devices to follow up with some verification of the config to ensure that it is behaving the way you want it to do. By using a few show and debug commands, and if using Telnet/SSH by enabling Terminal Monitor, you can quickly ascertain if the device is configured correctly and where you need to concetrate your efforts if changes are required.

    Hope this helps!
  • Options
    t5yll4t5yll4 Member Posts: 54 ■■□□□□□□□□
    cisco_nerd wrote: »
    If you refer to the above in bold, the switches are configured and behaving as you would expect them to. S1 is configured as the Root Bridge for VLANs 10 (BID 10) and 20 (BID 20). And S3 is configured as the Root Bridge for VLAN 30 (BID 4126) (also happens to be the Root for VLANs 1 and 99 as a bonus).

    So your config is correct and STP is as it should be as per your lab questions.

    A point to note that whenever configuring devices to follow up with some verification of the config to ensure that it is behaving the way you want it to do. By using a few show and debug commands, and if using Telnet/SSH by enabling Terminal Monitor, you can quickly ascertain if the device is configured correctly and where you need to concetrate your efforts if changes are required.

    Hope this helps!


    I did notice those and was telling myself that I set it up as the lab requested, but packet tracer still wouldn't award me the points so I was stumped and figured there must be something wrong. When checking results, its telling me that the 'Priority' settings are incorrect. I guess I can't always rely on packet tracer's grading as I've heard that its finicky.

    Anyways, thanks for your help!! You're absolutely right on verifying the config. Lesson learned!
    2015 Certification Goals:
    [ ] JNCDA (August), [ ] JNCIA-Junos (September), [ ] CCDA (pending), [ ] CCNP RS (tentative November)

    "Duty then is the sublimest word in the English language. You should do your duty in all things. You can never do more, you should never wish to do less."
    - Robert E. Lee
  • Options
    xXErebuSxXErebuS Member Posts: 230
    t5yll4 wrote: »
    I did notice those and was telling myself that I set it up as the lab requested, but packet tracer still wouldn't award me the points so I was stumped and figured there must be something wrong. When checking results, its telling me that the 'Priority' settings are incorrect. I guess I can't always rely on packet tracer's grading as I've heard that its finicky.

    Anyways, thanks for your help!! You're absolutely right on verifying the config. Lesson learned!

    You are not getting points b/c you are not doing it correctly. It is asking you to dynamically assign it so its the root bridge; not statically configure a priority... AKA:
    try the spanning-tree vlan 10,20 root primary ​command
  • Options
    cisco_nerdcisco_nerd Member Posts: 198
    xXErebuS wrote: »
    You are not getting points b/c you are not doing it correctly. It is asking you to dynamically assign it so its the root bridge; not statically configure a priority... AKA:

    This is true, to the OP if you want to verify this, you can issue the command spanning-tree vlan 10 root primary and then check the spanning-tree details (show spanning-tree) and you will notice that STP has changed the Root ID value to something that is less than the default value of 37268.

    If another switch comes along with a lower priority because it was statically assigned with the spanning-tree vlan 10 priority 4096 command, then it will become the primary root bridge.

    *Remember
    Root ID = Priority:MAC Address (e.g. 4096:aabc.0012.fa10)
    BridgeID = Priority + VLAN ID (e.g. 4106 [4096+10])


    If left alone, then obviously the MAC address will work out the Root, but when using a dynamic approach, the value of the Bridge ID will be a decrement with a factor of 4096. This is because you can have VLAN IDs ranging from 0 - 4095 (gives you 4096 VLANs).

    Keeping in mind that the Bridge ID (combination of the priority [Root ID] and MAC Address) is 8 bytes (BPDU message) and that a MAC address is 6 bytes by default, that leaves 2 bytes from the BPDU message for the Root ID (16 bits). Since 12 bits are needed to assign a unique ID to a VLAN (4096 = 12 bits) then that means that there is 4 bits left over for the Root ID, so every increment of 4096 (0, 4096, 8192... etc.) can be assigned as a static Root ID for a particular switch.

    i.e.

    0000xxxx xxxxxxxx
    thru
    1111xxxx xxxxxxxx

    where x = some value between 1 and 4095 for the VLAN ID.
    and 0000 -> 1111 the increment values for each block of VLANs (see below switch output)

    This gives you 16 possible values that you use to statically assign as a Root ID (2^4 = 16). Also keep in mind that the VLAN ID is added to the Root ID value to establish the Bridge ID (BID).

    Putting all this together you can see that the IDs for a VLAN will only ever be 1 - 4095, and the Root ID has to be an increment value of 4096.

    You can test this out by trying to tell the switch to use a priority of some other value. For example:
    S1(config)#spanning-tree vlan 10 priority 8000
    % Bridge Priority must be in increments of 4096.
    % Allowed values are:
      0     4096  8192  12288 16384 20480 24576 28672
      32768 36864 40960 45056 49152 53248 57344 61440
    S1(config)#
    

    Here you can see that the switch will not take the value supplied as it is not an incremnt of 4096.

    I hope that all makes sense and I havnt made it worse!! but i'm happy to further explain if required.
  • Options
    DCDDCD Member Posts: 473 ■■■■□□□□□□
    Spanning-tree vlan (XX) root primary which determines the best bridge priority and sets it to become the root bridgeor you can use the spanning-tree vlan (X) priority (X) which manually specifies the priority on a per vlan basis.
    Use these show commands to verify show spanning-tree vlan (XX) command and the show spanning-tree vlanroot. An you should be able to zip the PT file and upload it here.
Sign In or Register to comment.