Notes Prepared for Studying Passive Interface (CCNA/CCNP)

shabeermshabeerm Posts: 29Member ■□□□□□□□□□
Passive-interface command is used in all routing protocols to disable sending updates out from a specific interface.However the command behavior varies from one protocol to another.
In RIP this command will disable sending multicast updates via a specific interface but will allow listening to incoming updates from other RIP enabled neighbors.This simply means that the router will still be able to receive updates o*n that passive interface and use them in the routing table.

Syntax
R1(config)# router rip
R1(config-router)# Version 2
R1(config-router)# network 10.4.0.0
R1(config-router)# network 10.2.0.0
R1(config-router)# passive-interface s0

The passive-interface command will prevent updates from being sent out of the Serial0 interface, but R1 will still receive updates on this interface.We can configure all interfaces to be passive using the passive-interface default command, and then individually use the no passive-interface command on the interfaces we do want updates to be sent out:
Syntax
R1(config)#router rip
R1(config-router)# network 10.4.0.0
R1(config-router)# network 10.2.0.0
R1(config-router)# passive-interface default
R1(config-router)# no passive-interface e0
If you used the neighbor command under the RIP process, the router will send unicast updates as well as multicast updates.The passive-interface command must be used disable Multicast/broadcast updates and allowing only unicast.

Router(config)#router rip
Router(config-router)# passive-interface s0
Router(config-router)# passive-interface s1
Router(config-router)# neighbor 10.3.5.1
Router(config-router)# neighbor 10.4.5.1

In EIGRP the passive-interface command stops sending outgoing hello packets, hence the router can not form any neighbor relationship via the passive interface.This behavior stops both outgoing and incoming routing updates.
Syntax :
R1(config)# router eigrp 10
R1(config-router)# network 10.4.0.0
R1(config-router)# network 10.2.0.0
R1(config-router)# passive-interface s0

In OSPF
the passive-interface has a similar behavior to EIGRP.The command suppresses hello packets and hence neighbor relationships.
R1(config)# router OSPF 101
R1(config-router)# network 10.4.0.0
R1(config-router)# network 10.2.0.0
R1(config-router)# passive-interface s0

Passive interface default command can be used in both EIGRP and OSPF like we used in RIP

Always remember, that the passive-interface command will prevent EIGRP (and OSPF) from forming neighbor relationships out of that interface. No routing updates are passed in either direction.

Important: Passive interface command applying on interfaces wont effect on the sub interfaces created under it.If you want to active "passive interface" command on sub interface,it should be given on that specific sub interface

Interview Questions
  • What is passive interface ?
  • Explain effect of Passive interface on RIP,EIGRP and OSPF ?
  • What is the effect of default passive interface command ?
  • Why does the EIGRP passive-interface command remove all neighbors for an interface?
  • How do I stop individual interfaces from developing adjacency in an OSPF network?
  • What command is used to stop RIP routing updates from exiting out an interface but still allow the interface to receive RIP route updates?
  • How Does the Passive Interface Feature Work in EIGRP?
For CCNA / CCNP notes visit my blog http://sysnetnotes.blogspot.in/
Sign In or Register to comment.