Options

BGP routes redistribution into EIGRP problem

saurabh_avsaurabh_av Registered Users Posts: 1 ■□□□□□□□□□


I am trying to redistribute the BGP routes of ISP 5 into EIGRP.
The run config of ISP5 is as follows:
ISP5#show run
Building configuration...


Current configuration : 1280 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname ISP5
!
!
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0/0
ip address 10.255.254.85 255.255.255.252
!
interface Serial0/0/1
ip address 10.255.254.81 255.255.255.252
clock rate 64000
!
interface Serial0/1/0
ip address 10.255.254.5 255.255.255.252
clock rate 64000
!
interface Serial0/1/1
ip address 10.255.254.17 255.255.255.252
clock rate 64000
!
interface Serial0/2/0
no ip address
clock rate 2000000
shutdown
!
interface Serial0/2/1
no ip address
clock rate 2000000
shutdown
!
interface Serial0/3/0
no ip address
clock rate 2000000
shutdown
!
interface Serial0/3/1
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown
!
router eigrp 1
redistribute bgp 200
network 10.0.0.0
auto-summary
!
router bgp 200
bgp log-neighbor-changes
bgp redistribute-internal
no synchronization
neighbor 10.255.254.86 remote-as 100
!
ip classless
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end

I have used redistribute command in the ISP5 router. But I cannot see the redistributed routes in the routers connected to ISP5.
I am using CPT 6.0.
I also tried using the "default-metric" command but I dont think CPT supports this command.

PLease HELP!
net.jpg 35.5K

Comments

  • Options
    networker050184networker050184 Mod Posts: 11,962 Mod
    You need a metric under EIGRP. Not sure if this is something beyond the scope of PT or not though. You will probably be better off doing this in dynamips.
    An expert is a man who has made all the mistakes which can be made.
  • Options
    deth1kdeth1k Member Posts: 312
    if default-metric doesn't work under EIGRP process, try adding K values under your redistribute statement.
  • Options
    chapapachapapa Member Posts: 40 ■■□□□□□□□□
    when you redistribute routes into eigrp by default it advertises them with infinite metrics (same in RIP) so they don't appear in the routing tables to fix this you have to set a metric.
    ex.
    router eigrp 1
    redistribute bgp 200 metric <BW> <DLY> <RELIABILITY> <LOAD> <MTU>

    or

    router eigrp 1
    default-metrics <BW> <DLY> <RELIABILITY> <LOAD> <MTU>
Sign In or Register to comment.