Promoting 2nd domain controller fails

So when I assign my 2ndary domain controller a static IP and then promote it after ad and dns are added, it can't finished because the dns can't be found, now I am stuck at creating the NTDS Setting

What is the right way about adding a 2ndary DC?

Comments

  • PsoasmanPsoasman Senior Member Posts: 2,687Member ■■■■■■■■■□
    I just finished setting up 2 DCs and a server core for a lab.

    Dcsrv1:
    static IP: 172.16.0.2
    SM: 255.255.0.0
    DNS: 172.16.0.2


    Boston:
    static IP: 172.16.0.3
    SM: 255.255.0.0.
    DNS: 172.16.0.2
    172.16.0.3

    Can your computers ping each other?
  • gbdavidxgbdavidx Posts: 840Member
    it joined to the domain, but i dont see a host record for it and i had to restart it, when I try and redo it it can't authenticate

    its on the network and i can ping it but no A host record
  • PsoasmanPsoasman Senior Member Posts: 2,687Member ■■■■■■■■■□
    What are you trying to redo? Can you log into your domain?
  • gbdavidxgbdavidx Posts: 840Member
    I can login to it, i just can't "promote" it after installing ad/dns, I had to promoting it to a DC failed, i see the computer in "computers" but still no host record for it, shouldn't their be one?

    Now when I try and enter my credentials to finish the promoting, it fails like they doesn't exist

    I get "verification of replica failed. an active director dc for the domain could not be found"

    ugh, why the f can't i connect to my dns server? i tried just a "server" and it says it can't connect to it when I can ping to it just fine
  • gbdavidxgbdavidx Posts: 840Member
    for my primary domain controller? I see there's a _ldap (SRV) record for my server1 (name for primary DC). when I try to connect anything (member server, client to it) I get a new error

    The folllowing error occured attempting to join the domain

    the request is not supported

    I am able to ping back and forth so I dont think its a networking issue
  • whatthehellwhatthehell Posts: 920Member
    Hmmmm perhaps using dc diag verbose would help in troubleshooting? Thoughts?

    /v for verbose
    /s to specify a domain controller

    See here for more info:

    Dcdiag

    Hope this helps a bit!

    If you pinged the other DC, there is only one hop right? If not, maybe tracert it then to see where the heck it is going through?
    2017 Goals:
    [ ] Security + [ ] 74-409 [ ] CEH
    Future Goals:
    TBD
  • ptilsenptilsen Posts: 2,835Member ■■■■■■■■■■
    Yes, both servers need A records. If the IP addresses are configured statically (which they should be), you have to create the A records manually. You should be able to Ping both servers by hostname and by FQDN from each other. The first domain controller's IP address should also be the primary DNS server in the second server's NIC configuration.
    Working B.S., Computer Science
    Complete: 55/120 credits SPAN 201, LIT 100, ETHS 200, AP Lang, MATH 120, WRIT 231, ICS 140, MATH 215, ECON 202, ECON 201, ICS 141, MATH 210, LING 111, ICS 240
    In progress: CLEP US GOV,
    Next up: MATH 211, ECON 352, ICS 340
  • gbdavidxgbdavidx Posts: 840Member
    I created a NEW domain controller and brand new win8 host and can't connect the host, this is all through Vmware, is vmware not supported?
  • gbdavidxgbdavidx Posts: 840Member
    I was able to fix it - the domain controller got f'd up - replication is not replicating i had to recreate (this time i created a back up before replication) but it is doing the same thing and still taking a long ass time

    i was watching cbt nugget video and james said its only 36(?) mb file, it seems to be going on for 30+ minutes... something is not right
Sign In or Register to comment.