EIGRP pop question I

phoeneousphoeneous Go ping yourself...Member Posts: 2,333 ■■■■■■■□□□
I had to give a brief intro to eigrp for a friend and followed it up with this pop question, so thought I'd share.

1. With the following configs, will R1 be able to ping R6’s loopback interfaces regardless of source? If yes, justify your answer. If no, what command(s) are needed to make it work? (excluding static routes!)

R1
router eigrp 12345
network 1.1.1.1 0.0.0.0
network 11.11.11.11 0.0.0.0
network 192.168.12.0
network 192.168.13.0
network 192.168.14.0
network 192.168.15.0
no auto-summary

R2
router eigrp 12345
network 2.2.2.2 0.0.0.0
network 172.16.23.0 0.0.0.255
network 192.168.12.0
no auto-summary
eigrp stub connected summary
!
router eigrp 62
network 10.0.62.0 0.0.0.255
network 22.0.0.0
no auto-summary

R6
router eigrp 62
network 6.6.6.6 0.0.0.0
network 10.0.62.0 0.0.0.255
network 66.66.66.66 0.0.0.0
no auto-summary

Comments

  • iamme4evaiamme4eva Member Posts: 272
    Good question. :D
    Current objective: CCNA Security
    My blog: mybraindump.co.uk
  • boobobobobobboobobobobob Member Posts: 118
    No, router 2 will need to use route redistribution in order for 2 EIGRP networks with different AS to communicate.

    R2
    router eigrp 12345
    redistribute eigrp 62 route-map to12345
    network 2.2.2.2 0.0.0.0
    network 172.16.23.0 0.0.0.255
    network 192.168.12.0
    no auto-summary
    eigrp stub connected summary
    !
    router eigrp 62
    redistribute 12345 route-map to62
    network 10.0.62.0 0.0.0.255
    network 22.0.0.0
    no auto-summary

    you'll then have to create the route maps that allow the two networks, i do not remember the exact syntax but i think

    route-map to12345 permit 10
    route-map to62 permit 10

    should work? maybe someone can verify the route map information.
  • atorvenatorven Member Posts: 319
    R1 won’t be able to ping R6’s loopbacks because they are in different AS, you need to redistribute both ways between AS 12345 and AS 62, also could remove eigrp stub connected summary or add the redistributed keyword to it.

    R2
    router eigrp 12345
    network 2.2.2.2 0.0.0.0
    network 172.16.23.0 0.0.0.255
    network 192.168.12.0
    redistribute eigrp 62
    no auto-summary
    eigrp stub connected summary redistributed
    !
    router eigrp 62
    network 10.0.62.0 0.0.0.255
    network 22.0.0.0
    no auto-summary
    redistribute eigrp 12345
  • xXErebuSxXErebuS Member Posts: 230
    I don't think adding the redistributed command will fix it since R6 subnets are not connected or in different AS (being redistributed) ; You would have to remove eigrp stub status completely (like you said). You could make R6 a stub router though.
  • iamme4evaiamme4eva Member Posts: 272
    Adding the redistributed keyword to the stub command should work, as long as you redistribute them too. However, you are right, you'd most likely remove the stub command from there, as it's not really a stub router.


    To add a question to phoeneous's original question then, based on boobob's answer:

    Would you need a route-map in this scenario, and why or why not?
    Current objective: CCNA Security
    My blog: mybraindump.co.uk
  • atorvenatorven Member Posts: 319
    Well, using a route map would allow you to match specific networks to be redistributed into each AS instead of redistributing all the networks, is this needed, no but it's good practice.
  • xXErebuSxXErebuS Member Posts: 230
    atorven wrote: »
    Well, using a route map would allow you to match specific networks to be redistributed into each AS instead of redistributing all the networks, is this needed, no but it's good practice.

    WHY is it not needed in this scenario? I'll leave this for someone else; I think he was digging for a little bit more =D.
  • boobobobobobboobobobobob Member Posts: 118
    I only added the route map because that's often what i see in production networks. I didn't even remember it could be used without the route map command, lol.
  • phoeneousphoeneous Go ping yourself... Member Posts: 2,333 ■■■■■■■□□□
    I only added the route map because that's often what i see in production networks. I didn't even remember it could be used without the route map command, lol.

    I supposed that would be a smart move if there were full mutual redistribution going on with multiple routers in eigrp as 62 but since only R2 is redistributing to R6 then there is no need to worry about a routing loop?

    But to answer the question, either of these would work:

    router eigrp 12345
    redistribute eigrp 62
    eigrp stub connected summary redistributed

    router eigrp 12345
    redistribute eigrp 62
    no eigrp stub connected
  • phoeneousphoeneous Go ping yourself... Member Posts: 2,333 ■■■■■■■□□□
    Q2. Either of the above solutions have been applied and R4 can ping R6 and vice versa. Given the following route and eigrp topology tables from R1 and R3, who will R4 learn the 6.6.6.6/32 route from? Variance is currently not applied on R2. Justify your answer.
    R1#  sh ip route eigrp
         2.0.0.0/32 is subnetted, 1 subnets
    D       2.2.2.2 [90/2297856] via 192.168.12.2, 00:42:13, Serial0/0
         4.0.0.0/32 is subnetted, 1 subnets
    D       4.4.4.4 [90/2297856] via 192.168.14.4, 00:46:49, Serial0/2
         99.0.0.0/32 is subnetted, 1 subnets
    D EX    99.99.99.99 [170/2809856] via 192.168.14.4, 00:46:49, Serial0/2
         66.0.0.0/32 is subnetted, 1 subnets
    D EX    66.66.66.66 [170/2809856] via 192.168.12.2, 00:42:13, Serial0/0
         6.0.0.0/32 is subnetted, 1 subnets
    D EX    6.6.6.6 [170/2809856] via 192.168.12.2, 00:42:13, Serial0/0
         172.16.0.0/24 is subnetted, 3 subnets
    D       172.16.45.0 [90/2195456] via 192.168.14.4, 00:46:44, Serial0/2
    D       172.16.34.0 [90/2195456] via 192.168.14.4, 00:46:44, Serial0/2
    D       172.16.23.0 [90/2195456] via 192.168.12.2, 00:42:13, Serial0/0
         22.0.0.0/32 is subnetted, 1 subnets
    D EX    22.22.22.22 [170/2297856] via 192.168.12.2, 00:42:13, Serial0/0
         9.0.0.0/32 is subnetted, 1 subnets
    D EX    9.9.9.9 [170/2809856] via 192.168.14.4, 00:46:49, Serial0/2
         10.0.0.0/24 is subnetted, 2 subnets
    D EX    10.0.62.0 [170/2681856] via 192.168.12.2, 00:42:14, Serial0/0
    D EX    10.0.49.0 [170/2681856] via 192.168.14.4, 00:46:50, Serial0/2
         44.0.0.0/32 is subnetted, 1 subnets
    D EX    44.44.44.44 [170/2297856] via 192.168.14.4, 00:46:50, Serial0/2
    R1#
    
    R1#sh ip eigrp top all-links
    IP-EIGRP Topology Table for AS(12345)/ID(11.11.11.11)
    Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
           r - reply Status, s - sia Status
    
    
    P 66.66.66.66/32, 1 successors, FD is 2809856, serno 61
            via 192.168.12.2 (2809856/2297856), Serial0/0
    P 6.6.6.6/32, 1 successors, FD is 2809856, serno 60
            via 192.168.12.2 (2809856/2297856), Serial0/0
    P 2.2.2.2/32, 1 successors, FD is 2297856, serno 59
            via 192.168.12.2 (2297856/128256), Serial0/0
    P 22.22.22.22/32, 1 successors, FD is 2297856, serno 57
            via 192.168.12.2 (2297856/128256), Serial0/0
    P 99.99.99.99/32, 1 successors, FD is 2809856, serno 19
            via 192.168.14.4 (2809856/2297856), Serial0/2
    P 9.9.9.9/32, 1 successors, FD is 2809856, serno 18
            via 192.168.14.4 (2809856/2297856), Serial0/2
    P 4.4.4.4/32, 1 successors, FD is 2297856, serno 15
            via 192.168.14.4 (2297856/128256), Serial0/2
    P 44.44.44.44/32, 1 successors, FD is 2297856, serno 14
            via 192.168.14.4 (2297856/128256), Serial0/2
    P 11.11.11.11/32, 1 successors, FD is 128256, serno 2
            via Connected, Loopback11
    P 1.1.1.1/32, 1 successors, FD is 128256, serno 1
            via Connected, Loopback1
    P 10.0.62.0/24, 1 successors, FD is 2681856, serno 58
            via 192.168.12.2 (2681856/2169856), Serial0/0
    P 10.0.49.0/24, 1 successors, FD is 2681856, serno 13
            via 192.168.14.4 (2681856/2169856), Serial0/2
    P 192.168.12.0/24, 1 successors, FD is 2169856, serno 3
            via Connected, Serial0/0
    P 192.168.13.0/24, 1 successors, FD is 2169856, serno 4
            via Connected, Serial0/1
    P 192.168.14.0/24, 1 successors, FD is 2169856, serno 5
            via Connected, Serial0/2
    P 192.168.15.0/24, 1 successors, FD is 2169856, serno 6
            via Connected, Serial0/3
    P 172.16.45.0/24, 1 successors, FD is 2172416, serno 21
            via 192.168.14.4 (2195456/281600), Serial0/2
    P 172.16.34.0/24, 1 successors, FD is 2172416, serno 22
            via 192.168.14.4 (2195456/281600), Serial0/2
    P 172.16.23.0/24, 1 successors, FD is 2195456, serno 62
            via 192.168.12.2 (2195456/281600), Serial0/0
    R1#
    
    
    
    

    R3#sh ip route eigrp
    D    192.168.12.0/24 [90/2195456] via 172.16.23.2, 00:44:17, FastEthernet0/0
         1.0.0.0/32 is subnetted, 1 subnets
    D       1.1.1.1 [90/2297856] via 192.168.13.1, 00:48:38, Serial0/0
         2.0.0.0/32 is subnetted, 1 subnets
    D       2.2.2.2 [90/409600] via 172.16.23.2, 00:44:16, FastEthernet0/0
    D    192.168.14.0/24 [90/2195456] via 172.16.34.4, 00:48:37, FastEthernet0/1
    D    192.168.15.0/24 [90/2681856] via 192.168.13.1, 00:48:38, Serial0/0
         4.0.0.0/32 is subnetted, 1 subnets
    D       4.4.4.4 [90/409600] via 172.16.34.4, 00:48:37, FastEthernet0/1
         99.0.0.0/32 is subnetted, 1 subnets
    D EX    99.99.99.99 [170/2323456] via 172.16.34.4, 00:48:37, FastEthernet0/1
         66.0.0.0/32 is subnetted, 1 subnets
    D EX    66.66.66.66 [170/2323456] via 172.16.23.2, 00:44:16, FastEthernet0/0
         6.0.0.0/32 is subnetted, 1 subnets
    D EX    6.6.6.6 [170/2323456] via 172.16.23.2, 00:44:16, FastEthernet0/0
         172.16.0.0/24 is subnetted, 3 subnets
    D       172.16.45.0 [90/307200] via 172.16.34.4, 00:48:38, FastEthernet0/1
         22.0.0.0/32 is subnetted, 1 subnets
    D EX    22.22.22.22 [170/409600] via 172.16.23.2, 00:44:18, FastEthernet0/0
         8.0.0.0/32 is subnetted, 1 subnets
    D       8.8.8.8 [90/2297856] via 10.0.38.8, 00:48:53, Serial0/1
         9.0.0.0/32 is subnetted, 1 subnets
    D EX    9.9.9.9 [170/2323456] via 172.16.34.4, 00:48:39, FastEthernet0/1
         10.0.0.0/24 is subnetted, 3 subnets
    D EX    10.0.62.0 [170/2195456] via 172.16.23.2, 00:44:19, FastEthernet0/0
    D EX    10.0.49.0 [170/2195456] via 172.16.34.4, 00:48:40, FastEthernet0/1
         11.0.0.0/32 is subnetted, 1 subnets
    D       11.11.11.11 [90/2297856] via 192.168.13.1, 00:48:40, Serial0/0
         88.0.0.0/32 is subnetted, 1 subnets
    D       88.88.88.88 [90/2297856] via 10.0.38.8, 00:48:54, Serial0/1
         44.0.0.0/32 is subnetted, 1 subnets
    D EX    44.44.44.44 [170/409600] via 172.16.34.4, 00:48:40, FastEthernet0/1
    R3#
    
    
    R3#sh ip eigrp topology al
    IP-EIGRP Topology Table for AS(12345)/ID(33.33.33.33)
    Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
           r - reply Status, s - sia Status
    
    
    P 66.66.66.66/32, 1 successors, FD is 2323456, serno 77
            via 172.16.23.2 (2323456/2297856), FastEthernet0/0
            via 192.168.13.1 (3321856/2809856), Serial0/0
    P 6.6.6.6/32, 1 successors, FD is 2323456, serno 76
            via 172.16.23.2 (2323456/2297856), FastEthernet0/0
            via 192.168.13.1 (3321856/2809856), Serial0/0
    P 2.2.2.2/32, 1 successors, FD is 409600, serno 74
            via 172.16.23.2 (409600/128256), FastEthernet0/0
            via 192.168.13.1 (2809856/2297856), Serial0/0
    P 22.22.22.22/32, 1 successors, FD is 409600, serno 72
            via 172.16.23.2 (409600/128256), FastEthernet0/0
            via 192.168.13.1 (2809856/2297856), Serial0/0
    P 99.99.99.99/32, 1 successors, FD is 2300416, serno 47
            via 172.16.34.4 (2323456/2297856), FastEthernet0/1
            via 192.168.13.1 (3321856/2809856), Serial0/0
    P 9.9.9.9/32, 1 successors, FD is 2300416, serno 48
            via 172.16.34.4 (2323456/2297856), FastEthernet0/1
            via 192.168.13.1 (3321856/2809856), Serial0/0
    P 4.4.4.4/32, 1 successors, FD is 156160, serno 49
            via 172.16.34.4 (409600/128256), FastEthernet0/1
            via 192.168.13.1 (2809856/2297856), Serial0/0
    P 44.44.44.44/32, 1 successors, FD is 156160, serno 50
            via 172.16.34.4 (409600/128256), FastEthernet0/1
            via 192.168.13.1 (2809856/2297856), Serial0/0
    P 88.88.88.88/32, 1 successors, FD is 2297856, serno 18
            via Redistributed (2297856/0)
    P 8.8.8.8/32, 1 successors, FD is 2297856, serno 17
            via Redistributed (2297856/0)
    P 11.11.11.11/32, 1 successors, FD is 2297856, serno 8
            via 192.168.13.1 (2297856/128256), Serial0/0
    P 1.1.1.1/32, 1 successors, FD is 2297856, serno 7
            via 192.168.13.1 (2297856/128256), Serial0/0
    P 3.3.3.3/32, 1 successors, FD is 128256, serno 3
            via Connected, Loopback3
    P 33.33.33.33/32, 1 successors, FD is 128256, serno 1
            via Redistributed (128256/0)
    P 10.0.38.0/24, 1 successors, FD is 2169856, serno 2
            via Redistributed (2169856/0)
    P 10.0.62.0/24, 1 successors, FD is 2195456, serno 73
            via 172.16.23.2 (2195456/2169856), FastEthernet0/0
            via 192.168.13.1 (3193856/2681856), Serial0/0
    P 10.0.49.0/24, 1 successors, FD is 2172416, serno 51
            via 172.16.34.4 (2195456/2169856), FastEthernet0/1
            via 192.168.13.1 (3193856/2681856), Serial0/0
    P 192.168.12.0/24, 1 successors, FD is 2172416, serno 75
            via 172.16.23.2 (2195456/2169856), FastEthernet0/0
            via 192.168.13.1 (2681856/2169856), Serial0/0
    P 192.168.13.0/24, 1 successors, FD is 2169856, serno 6
            via Connected, Serial0/0
    P 192.168.14.0/24, 1 successors, FD is 2172416, serno 52
            via 172.16.34.4 (2195456/2169856), FastEthernet0/1
            via 192.168.13.1 (2681856/2169856), Serial0/0
    P 192.168.15.0/24, 1 successors, FD is 2681856, serno 11
            via 192.168.13.1 (2681856/2169856), Serial0/0
    P 172.16.45.0/24, 1 successors, FD is 307200, serno 40
            via 172.16.34.4 (307200/281600), FastEthernet0/1
            via 192.168.13.1 (2707456/2195456), Serial0/0
    P 172.16.34.0/24, 1 successors, FD is 281600, serno 39
            via Connected, FastEthernet0/1
            via 192.168.13.1 (2707456/2195456), Serial0/0
    P 172.16.23.0/24, 1 successors, FD is 281600, serno 38
            via Connected, FastEthernet0/0
            via 192.168.13.1 (2707456/2195456), Serial0/0
    IP-EIGRP Topology Table for AS(3[IMG]https://us.v-cdn.net/6030959/uploads/images/smilies/icon_cool.gif[/IMG]/ID(33.33.33.33)
    Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
           r - reply Status, s - sia Status
    
    
    P 88.88.88.88/32, 1 successors, FD is 2297856, serno 4
            via 10.0.38.8 (2297856/128256), Serial0/1
    P 8.8.8.8/32, 1 successors, FD is 2297856, serno 3
            via 10.0.38.8 (2297856/128256), Serial0/1
    P 33.33.33.33/32, 1 successors, FD is 128256, serno 2
            via Connected, Loopback33
    P 10.0.38.0/24, 1 successors, FD is 2169856, serno 1
            via Connected, Serial0/1
    R3#
    
  • xXErebuSxXErebuS Member Posts: 230
    phoeneous wrote: »
    I supposed that would be a smart move if there were full mutual redistribution going on with multiple routers in eigrp as 62 but since only R2 is redistributing to R6 then there is no need to worry about a routing loop?

    But to answer the question, either of these would work:

    router eigrp 12345
    redistribute eigrp 62
    eigrp stub connected summary redistributed

    router eigrp 12345
    redistribute eigrp 62
    no eigrp stub connected


    It's b/c they are both EIGRP which has EX with higher AD. The only time you can have a IGP LOOP is when you have two routing protocols that are not EIGRP (i.e. RIP>OSPF - neither has EX AD with higher AD) however; if you have one side thats not EIGRP you still get sub optimal routing.... so unless its EIGRP > EIGRP use a route map/filter.

    For example; OSPF is 110 by default for internal/external; if you redistribute as E2 (potentially E1 even) there is a very good chance that the cost for some routes in the OSPF AS (for some routers) will be lower to go via the redistributed route, then it goes into (lets say RIP) other AS where it gets sent back.
  • atorvenatorven Member Posts: 319
    Unless I’m missing something fairly obvious, I would say R4 would learn about 6.6.6.6/32 from both R1 and R3 because these routers are its neighbours and are both advertising this route to R4, R4 would prefer the route through R3 due to R3 having a better feasible distance to 6.6.6.6/32.

    I have learnt so much and forgotten so much, it’s starting to scare me.
  • xXErebuSxXErebuS Member Posts: 230
    atorven wrote: »
    Unless I’m missing something fairly obvious, I would say R4 would learn about 6.6.6.6/32 from both R1 and R3 because these routers are its neighbours and are both advertising this route to R4, R4 would prefer the route through R3 due to R3 having a better feasible distance to 6.6.6.6/32.

    I have learnt so much and forgotten so much, it’s starting to scare me.

    I will agree with bold (assuming normal interface BW, default cost [BW+DELAY]); however I do not agree with underlined - you can't go off just R1 and R3's FD b/c to R4 its going to be an AD (have to add link cost to get to R1/R3). Assuming everything is at default it will choose R3 because the cost of the R4-R3 link and R3's AD is lower. Now if BW has been modified, or you were using different types of connections (i.e. Serial > R4-R3 and gigabitethernet > R4-R1 it could be a different answer).
  • phoeneousphoeneous Go ping yourself... Member Posts: 2,333 ■■■■■■■□□□
    xXErebuS wrote: »
    or you were using different types of connections (i.e. Serial > R4-R3 and gigabitethernet > R4-R1 it could be a different answer.

    What do you mean by this? Wouldnt the path prefer ethernet over serial? In this case, wouldnt R4 choose R3 over R1 to get to 6.6.6.6/32?

    For the last two days, I've been trying to figure out why R4 is learning about 6.6.6.6/32 from R1 and not R3. R3's fd is 2300416, R4's fd is 2809856. 2300416 < 2809856 right? Confused.

    All interfaces have default bw and delay values.
    R1#sh ip eigrp top 6.6.6.6/32
    IP-EIGRP (AS 12345): Topology entry for 6.6.6.6/32
      State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2809856
      Routing Descriptor Blocks:
      192.168.12.2 (Serial0/0), from 192.168.12.2, Send flag is 0x0
          Composite metric is (2809856/2297856), Route is External
          Vector metric:
            Minimum bandwidth is 1544 Kbit
            Total delay is 45000 microseconds
            Reliability is 255/255
            Load is 1/255
            Minimum MTU is 1500
            Hop count is 2
          External data:
            Originating router is 22.22.22.22
            AS number of route is 62
            External protocol is EIGRP, external metric is 2297856
            Administrator tag is 0 (0x00000000)
    
    
    
    
    R3#sh ip eigrp top 6.6.6.6/32
    IP-EIGRP (AS 12345): Topology entry for 6.6.6.6/32
      State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2300416
      Routing Descriptor Blocks:
      172.16.23.2 (FastEthernet0/0), from 172.16.23.2, Send flag is 0x0
          Composite metric is (2323456/2297856), Route is External
          Vector metric:
            Minimum bandwidth is 1544 Kbit
            Total delay is 26000 microseconds
            Reliability is 255/255
            Load is 1/255
            Minimum MTU is 1500
            Hop count is 2
          External data:
            Originating router is 22.22.22.22
            AS number of route is 62
            External protocol is EIGRP, external metric is 2297856
            Administrator tag is 0 (0x00000000)
    
    
    
    
    R4#sh ip eigrp top 6.6.6.6/32
    IP-EIGRP (AS 12345): Topology entry for 6.6.6.6/32
      State is Passive, Query origin flag is 1, 1 Successor(s), FD is 3321856
      Routing Descriptor Blocks:
      192.168.14.1 (Serial0/0), from 192.168.14.1, Send flag is 0x0
          Composite metric is (3321856/2809856), Route is External
          Vector metric:
            Minimum bandwidth is 1544 Kbit
            Total delay is 65000 microseconds
            Reliability is 255/255
            Load is 1/255
            Minimum MTU is 1500
            Hop count is 3
          External data:
            Originating router is 22.22.22.22
            AS number of route is 62
            External protocol is EIGRP, external metric is 2297856
            Administrator tag is 0 (0x00000000)
    

    R4#sh ip route 6.6.6.6
    Routing entry for 6.6.6.6/32
      Known via "eigrp 12345", distance 170, metric 3321856, type external
      Redistributing via eigrp 12345
      Last update from 192.168.14.1 on Serial0/0, 00:36:23 ago
      Routing Descriptor Blocks:
      * 192.168.14.1, from 192.168.14.1, 00:36:23 ago, via Serial0/0
          Route metric is 3321856, traffic share count is 1
          Total delay is 65000 microseconds, minimum bandwidth is 1544 Kbit
          Reliability 255/255, minimum MTU 1500 bytes
          Loading 1/255, Hops 3
    
  • iamme4evaiamme4eva Member Posts: 272
    That is strange, if the default bandwidths are set, I'd expect R3 to be the logical next hop. It can't even be loop avoidance, as the AD of R3 is lower, so even if there was a massive cost to get to R3 it should still be a back up link.

    Is there any route filtering going on on any of the routers?

    Can you post a show ip eigrp topology all-links, and the relevant interfaces from show run?
    Current objective: CCNA Security
    My blog: mybraindump.co.uk
  • xXErebuSxXErebuS Member Posts: 230
    phoeneous wrote: »
    What do you mean by this? Wouldnt the path prefer ethernet over serial? In this case, wouldnt R4 choose R3 over R1 to get to 6.6.6.6/32?

    For the last two days, I've been trying to figure out why R4 is learning about 6.6.6.6/32 from R1 and not R3. R3's fd is 2300416, R4's fd is 2809856. 2300416 < 2809856 right? Confused.



    All interfaces have default bw and delay values.
    R1#sh ip eigrp top 6.6.6.6/32
    IP-EIGRP (AS 12345): Topology entry for 6.6.6.6/32
      State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2809856
      Routing Descriptor Blocks:
      192.168.12.2 (Serial0/0), from 192.168.12.2, Send flag is 0x0
          Composite metric is (2809856/2297856), Route is External
          Vector metric:
            Minimum bandwidth is 1544 Kbit
            Total delay is 45000 microseconds
            Reliability is 255/255
            Load is 1/255
            Minimum MTU is 1500
            Hop count is 2
          External data:
            Originating router is 22.22.22.22
            AS number of route is 62
            External protocol is EIGRP, external metric is 2297856
            Administrator tag is 0 (0x00000000)
    
    
    
    
    R3#sh ip eigrp top 6.6.6.6/32
    IP-EIGRP (AS 12345): Topology entry for 6.6.6.6/32
      State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2300416
      Routing Descriptor Blocks:
      172.16.23.2 (FastEthernet0/0), from 172.16.23.2, Send flag is 0x0
          Composite metric is (2323456/2297856), Route is External
          Vector metric:
            Minimum bandwidth is 1544 Kbit
            Total delay is 26000 microseconds
            Reliability is 255/255
            Load is 1/255
            Minimum MTU is 1500
            Hop count is 2
          External data:
            Originating router is 22.22.22.22
            AS number of route is 62
            External protocol is EIGRP, external metric is 2297856
            Administrator tag is 0 (0x00000000)
    
    
    
    
    R4#sh ip eigrp top 6.6.6.6/32
    IP-EIGRP (AS 12345): Topology entry for 6.6.6.6/32
      State is Passive, Query origin flag is 1, 1 Successor(s), FD is 3321856
      Routing Descriptor Blocks:
      192.168.14.1 (Serial0/0), from 192.168.14.1, Send flag is 0x0
          Composite metric is (3321856/2809856), Route is External
          Vector metric:
            Minimum bandwidth is 1544 Kbit
            Total delay is 65000 microseconds
            Reliability is 255/255
            Load is 1/255
            Minimum MTU is 1500
            Hop count is 3
          External data:
            Originating router is 22.22.22.22
            AS number of route is 62
            External protocol is EIGRP, external metric is 2297856
            Administrator tag is 0 (0x00000000)
    

    R4#sh ip route 6.6.6.6
    Routing entry for 6.6.6.6/32
      Known via "eigrp 12345", distance 170, metric 3321856, type external
      Redistributing via eigrp 12345
      Last update from 192.168.14.1 on Serial0/0, 00:36:23 ago
      Routing Descriptor Blocks:
      * 192.168.14.1, from 192.168.14.1, 00:36:23 ago, via Serial0/0
          Route metric is 3321856, traffic share count is 1
          Total delay is 65000 microseconds, minimum bandwidth is 1544 Kbit
          Reliability 255/255, minimum MTU 1500 bytes
          Loading 1/255, Hops 3
    

    That's what I was saying.


    I agree with iamme4eva; do a show ip eigrp topology all-links from R4 to see if you're even getting that route. Also, while you're at it post R1's and R3's EIGRP config.
  • iamme4evaiamme4eva Member Posts: 272
    iamme4eva wrote: »
    so even if there was a massive cost to get to R3 it should still be a back up link


    Did I actually just say that? I must've been hungry or something! It was lunch time.

    By back up link, I mean feasible successor.
    Current objective: CCNA Security
    My blog: mybraindump.co.uk
  • phoeneousphoeneous Go ping yourself... Member Posts: 2,333 ■■■■■■■□□□
    xXErebuS wrote: »
    That's what I was saying.


    I agree with iamme4eva; do a show ip eigrp topology all-links from R4 to see if you're even getting that route. Also, while you're at it post R1's and R3's EIGRP config.


    Yeah, I feel like an idiot now. I kept looking at the tables and interface values and I missed ' eigrp stub receive-only' in R3... :/



     6.0.0.0/32 is subnetted, 1 subnets
    D EX    6.6.6.6 [170/2349056] via 172.16.34.3, 00:05:00, FastEthernet0/1
    

    And that's why I do these questions, because it's always the simplest things that I overlook!
  • iamme4evaiamme4eva Member Posts: 272
    Ha. Nobody is an idiot, we are all just learning, and every day you learn is a day you haven't wasted!!!

    Out of interest, why is R3 a stub at all?

    The only routers I'd have as stubs in your topology are R6,7,8,9.
    Current objective: CCNA Security
    My blog: mybraindump.co.uk
  • phoeneousphoeneous Go ping yourself... Member Posts: 2,333 ■■■■■■■□□□
    iamme4eva wrote: »
    Ha. Nobody is an idiot, we are all just learning, and every day you learn is a day you haven't wasted!!!

    Out of interest, why is R3 a stub at all?

    The only routers I'd have as stubs in your topology are R6,7,8,9.

    For learning purposes only. I was trying different eigrp configs to see how routes were affected.
Sign In or Register to comment.