Serial link and frame relay question

politenessmanpolitenessman Member Posts: 19 ■□□□□□□□□□
I have two routers connected via a serial cable, and for the life of me I cannot get the link to work with Frame relay. I wonder if you folks can maybe give me a hint as to what I am missing. here is my set up:

Router 1 is a 2610XM with a 4A/S serial module.
interface Serial1/0
 description : DCE/DTE to r2620
 ip address 172.16.3.1 255.255.255.0
 encapsulation frame-relay
 clock rate 56000
 no frame-relay inverse-arp
 frame-relay lmi-type ansi


Router 2 is a 2620, with a WIC 1T
interface Serial0/1
 description : Frame Relay to r2610
 ip address 172.16.3.2 255.255.255.0
 encapsulation frame-relay
 no frame-relay inverse-arp
 frame-relay lmi-type ansi
 no shut


sh ip int brief on router 1 gives the following:
FastEthernet0/0            unassigned      YES NVRAM  administratively down down    
Serial0/0                  172.16.1.2      YES NVRAM  up                    up      
Serial0/1                  172.16.2.1      YES NVRAM  up                    up      
[B]Serial1/0                  172.16.3.1      YES NVRAM  up                    down           <-------------[/B]
Serial1/1                  unassigned      YES NVRAM  administratively down down    
Serial1/2                  unassigned      YES NVRAM  administratively down down    
Serial1/3                  unassigned      YES NVRAM  administratively down down 


sh controller serial 1/0 gives me:
CD2430 Slot 1, Port 0, Controller 0, Channel 0, Revision 19
Channel mode is synchronous serial 
idb 0x82DEF648, buffer size 1524, V.35 DCE cable, clockrate 56000

... so I know I have the serial cable in correctly.
I am missing something, I just don't know what.

Any ideas?
Currently working on CompTIA Linux+
Hoping to get CCNA: Sec (640-554) and CCNA:R&S (640-816) next year.
Watch my progress at http://tonypickett.com

Comments

  • networker050184networker050184 Mod Posts: 11,962 Mod
    I believe you need the no keep alive command and add some dlcis.
    An expert is a man who has made all the mistakes which can be made.
  • politenessmanpolitenessman Member Posts: 19 ■□□□□□□□□□
    ok, I added no keep and dlci numbers at each end of the link. Now the link is up, but if I ping the IP address of the other end of the link, I still get nothing.
    r2610#ping 172.16.3.2
    
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 172.16.3.2, timeout is 2 seconds:
    .....
    Success rate is 0 percent (0/5)
    
    Currently working on CompTIA Linux+
    Hoping to get CCNA: Sec (640-554) and CCNA:R&S (640-816) next year.
    Watch my progress at http://tonypickett.com
  • networker050184networker050184 Mod Posts: 11,962 Mod
    What does your frame map look like?
    An expert is a man who has made all the mistakes which can be made.
  • politenessmanpolitenessman Member Posts: 19 ■□□□□□□□□□
    r2610#sh frame-relay map       
    
    
    r2610#
    

    I guess I am missing something ... I should create a map?
    I was under the impression that for a simple link, I didn't need one?
    Currently working on CompTIA Linux+
    Hoping to get CCNA: Sec (640-554) and CCNA:R&S (640-816) next year.
    Watch my progress at http://tonypickett.com
  • networker050184networker050184 Mod Posts: 11,962 Mod
    It's been a while since I messed with this, but I don't think you do. What do your current configs look like?
    An expert is a man who has made all the mistakes which can be made.
  • politenessmanpolitenessman Member Posts: 19 ■□□□□□□□□□
    This is router 1:
    r2610#sh run
    Building configuration...
    
    
    Current configuration : 1305 bytes
    !
    version 12.4
    no service timestamps debug uptime
    no service timestamps log uptime
    no service password-encryption
    !
    hostname r2610
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    no network-clock-participate slot 1 
    no network-clock-participate wic 0 
    no ip cef
    !
    no ip domain lookup
    multilink bundle-name authenticated
    !
    username r2620 password 0 ccent
    archive
     log config
      hidekeys
    !
    !
    interface FastEthernet0/0
     no ip address
     shutdown
     duplex auto
     speed auto
    !
    interface Serial0/0
     description TI line to R1721
     ip address 172.16.1.2 255.255.255.0
     encapsulation ppp
     no fair-queue
    !
    interface Serial0/1
     description :T1 line to R2620
     ip address 172.16.2.1 255.255.255.0
     encapsulation ppp
    !
    interface Serial1/0
     description : DCE/DTE to r2620
     ip address 172.16.3.1 255.255.255.0
     encapsulation frame-relay
     no keepalive
     clock rate 56000
     frame-relay interface-dlci 321
     no frame-relay inverse-arp
     frame-relay lmi-type ansi
    !
    interface Serial1/1
     no ip address
     shutdown
    !
    interface Serial1/2
     no ip address
     shutdown
    !
    interface Serial1/3
     no ip address
     shutdown
    !
    router rip
     version 2
     network 172.16.0.0
     no auto-summary
    !
    ip forward-protocol nd
    !
    ip http server
    no ip http secure-server
    !
    !
    control-plane
    !
    !
    line con 0
    line aux 0
    line vty 0 4
     login
    !
    !
    end
    

    And for router 2:
    r2620#sh run
    Building configuration...
    
    
    Current configuration : 748 bytes
    !
    version 12.2
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname r2620
    !
    !
    ip subnet-zero
    !
    !
    no ip domain-lookup
    !
    call rsvp-sync
    !         
    !
    interface FastEthernet0/0
     no ip address
     shutdown
     duplex auto
     speed auto
    !
    interface Serial0/0
     description : T1 line to r2610
     ip address 172.16.2.2 255.255.255.0
     encapsulation ppp
    !
    interface Serial0/1
     description : Frame Relay to r2610
     ip address 172.16.3.2 255.255.255.0
     encapsulation frame-relay
     no keepalive
     frame-relay interface-dlci 123
     no frame-relay inverse-arp
    !
    router rip
     network 172.16.0.0
     no auto-summary
    !
    ip classless
    ip http server
    !
    !
    dial-peer cor custom
    !
    !
    line con 0
    line aux 0
    line vty 0 4
     no login
    !
    end
    
    Currently working on CompTIA Linux+
    Hoping to get CCNA: Sec (640-554) and CCNA:R&S (640-816) next year.
    Watch my progress at http://tonypickett.com
  • networker050184networker050184 Mod Posts: 11,962 Mod
    You need to enable inverse arp unless you do map statements.

    And I believe your dlcis need to match but I'm not 100% certain on that one.

    I just set it up and it works fine.
    R1#sho run int s1/0
    Building configuration...
    
    
    Current configuration : 161 bytes
    !
    interface Serial1/0
     ip address 10.0.0.1 255.255.255.252
     encapsulation frame-relay
     no keepalive
     serial restart-delay 0
     frame-relay interface-dlci 100
    end
    
    R2#sho run int s1/0
    Building configuration...
    
    
    Current configuration : 161 bytes
    !
    interface Serial1/0
     ip address 10.0.0.2 255.255.255.252
     encapsulation frame-relay
     no keepalive
     serial restart-delay 0
     frame-relay interface-dlci 100
    end
    
    R1#show frame map
    Serial1/0 (up): ip 10.0.0.2 dlci 100(0x64,0x1840), dynamic,
                  broadcast,
                  CISCO
    R1#ping 10.0.0.2
    
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 10.0.0.2, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 16/34/60 ms
    R1#
    
    An expert is a man who has made all the mistakes which can be made.
  • theodoxatheodoxa Member Posts: 1,340 ■■■■□□□□□□
    Frame Relay doesn't work like that. You need at least 3 routers to do Frame Relay since one has to act as the Frame Relay switch. I've heard that you can do it with two by connecting a Router to itself and making it both the Switch and one of the DTEs, but this seems a bit kludgy.

    R1 (DTE):
    R1(config)#interface s0/0
    R1(config-if)#encapsulation frame-relay
    R1(config-if)#ip add 10.0.0.1 255.255.255.0
    R1(config-if)#interface-dlci 101
    R1(config-if)#no shutdown
    

    R2 (DTE):
    R2(config)#interface s0/0
    R2(config-if)#ip address 10.0.0.2 255.255.255.0
    R2(config-if)#interface-dlci 102
    R2(config-if)#no shutdown
    

    R3 (Frame-Relay Switch/DCE):
    R3(config)#frame-relay switching
    R3(config)#interface s0/0
    R3(config-if)#encapsulation frame-relay
    R3(config-if)#clock rate 64000
    R3(config-if)#frame-relay intf-type dce
    R3(config-if)#frame-relay route 102 interface s0/1 101
    R3(config-if)#exit
    R3(config)#interface s0/1
    R3(config-if)#encapsulation frame-relay
    R3(config-if)#clock rate 64000
    R3(config-if)#frame-relay intf-type dce
    R3(config-if)#frame-relay route 101 interface s0/0 102
    
    R&S: CCENT CCNA CCNP CCIE [ ]
    Security: CCNA [ ]
    Virtualization: VCA-DCV [ ]
  • politenessmanpolitenessman Member Posts: 19 ■□□□□□□□□□
    Well, I do have another couple of routers but I'm waiting for a serial card for one of them.
    Do you really need three or is it that I need one of the two configured as a Frame Relay switch?
    (I'll add the third later)
    Currently working on CompTIA Linux+
    Hoping to get CCNA: Sec (640-554) and CCNA:R&S (640-816) next year.
    Watch my progress at http://tonypickett.com
  • theodoxatheodoxa Member Posts: 1,340 ■■■■□□□□□□
    Well, I do have another couple of routers but I'm waiting for a serial card for one of them.
    Do you really need three or is it that I need one of the two configured as a Frame Relay switch?
    (I'll add the third later)

    You need 3, but like I said, I read it can be done if you have one router with 3 serial ports. You would connect 1 port to the other router and the remaining 2 ports would be connected to each other and that router configured to acts as both the FR Switch and another DTE.

    BTW, if you want to save some money on serial cards, look into the WIC-1DSU-T1 or WIC-1DSU-T1 V2 (The older non-V2 is not supported on ISR Routers - 1841, 2801, 2811, 2821, etc...). They sell for $5-10/each on eBay and the cables can be purchased for $4-5/each or you can make your own cables with the right tools (Cable, RJ45 Connectors, and RJ45 Crimper/Stripper).
    R&S: CCENT CCNA CCNP CCIE [ ]
    Security: CCNA [ ]
    Virtualization: VCA-DCV [ ]
  • politenessmanpolitenessman Member Posts: 19 ■□□□□□□□□□
    I have a couple of T1 links running between my routers.
    Here is what I have at the moment:

    th_LabNetworkDiagram_zps45915caa.jpg
    The 2610XM is my main router, with the 2620 and 1721 hanging off these T1 links and that works. I can ping across both links.
    What I wanted to do was use the NAS4 module in the 2610XM as a frame relay hub, remove the T1 links and just run the serial links to see if I can. I could use the 2509 as a frame relay hub I guess ... that might be fun and allow me to play with nat and pat, as the 2509 is connected to my home network.
    Currently working on CompTIA Linux+
    Hoping to get CCNA: Sec (640-554) and CCNA:R&S (640-816) next year.
    Watch my progress at http://tonypickett.com
  • networker050184networker050184 Mod Posts: 11,962 Mod
    You don't need three. You can do back to back frame relay with two routers. I just posted the needed config above.
    An expert is a man who has made all the mistakes which can be made.
  • politenessmanpolitenessman Member Posts: 19 ■□□□□□□□□□
    I think there are some big holes in my understanding of frame relay. I can get the two T1 links working and routing packets just fine, but I've yet to make a frame relay connection even ping correctly. I'll play with it a while and see what I can make happen.
    Currently working on CompTIA Linux+
    Hoping to get CCNA: Sec (640-554) and CCNA:R&S (640-816) next year.
    Watch my progress at http://tonypickett.com
  • networker050184networker050184 Mod Posts: 11,962 Mod
    Did you try the config I posted? You need to get rid of the 'no frame-relay inverse-arp' command so the routers can resolve the L2 address. It's the same as with ethernet if you disabled arp you'd need to resolve the L2 MAC address somehow.
    An expert is a man who has made all the mistakes which can be made.
  • JoeBirdsJoeBirds Member Posts: 49 ■■□□□□□□□□
    Back-to-Back Frame Relay  [Frame Relay] - Cisco Systems

    Refer to this article on how to configure a back to back frame relay link. You do not need to have more than 2 router to do this. You need to add DLCI's to both of them and they MUST match as there is no frame relay switch to change them. Try this configuration and see if you have any luck. You shouldn't need to use subinterfaces like the article instructs, however.
  • politenessmanpolitenessman Member Posts: 19 ■□□□□□□□□□
    Yes, I tried that.
    I'm not sure what the issue is and at this time I'm thinking about wiping the configs across all the routers and starting from scratch. I suspect there is something set, somewhere that is screwing it up.
    I'll also do some more reading around Frame Relay.
    Currently working on CompTIA Linux+
    Hoping to get CCNA: Sec (640-554) and CCNA:R&S (640-816) next year.
    Watch my progress at http://tonypickett.com
  • JoeBirdsJoeBirds Member Posts: 49 ■■□□□□□□□□
    Yes, I tried that.
    I'm not sure what the issue is and at this time I'm thinking about wiping the configs across all the routers and starting from scratch. I suspect there is something set, somewhere that is screwing it up.
    I'll also do some more reading around Frame Relay.

    The config I listed didn't work...? Or was that in reponse to Networkers question?
  • networker050184networker050184 Mod Posts: 11,962 Mod
    The config you posted is the same config I posted except for using sub interfaces instead of the main interface. Either way all you have to do is disable keep alives and put the dlcis on there.
    An expert is a man who has made all the mistakes which can be made.
  • JoeBirdsJoeBirds Member Posts: 49 ■■□□□□□□□□
    The config you posted is the same config I posted except for using sub interfaces instead of the main interface. Either way all you have to do is disable keep alives and put the dlcis on there.

    Yup, those are really the only 2 areas that need to be changed when you don't have a frame switch. It should work.
  • Carpe PorcusCarpe Porcus Member Posts: 84 ■■□□□□□□□□
    Dedicated thread started, sorry for the hijack.
    “I'm always admitting I'm wrong. That's how I eventually get to right.”
  • politenessmanpolitenessman Member Posts: 19 ■□□□□□□□□□
    So the big part missing was the frame relay switch. I've implemented that and I'll get around to completing the config for the rest of the routers shortly. I decided to purchase another router and managed to pick up a 2610 for $12 locally (no shipping). This makes me very happy and makes it easier to put together a frame relay set up.
    This is what I have right now: More Lab Equipment | TonyPickett.com
    Currently working on CompTIA Linux+
    Hoping to get CCNA: Sec (640-554) and CCNA:R&S (640-816) next year.
    Watch my progress at http://tonypickett.com
  • Carpe PorcusCarpe Porcus Member Posts: 84 ■■□□□□□□□□
    I've managed to get a working setup as basic as possible command wise, the thread is in this forum. Hopefully it will answer a few questions and assist in your configuration as well?

    It all makes sense once you see it all working as it should.
    “I'm always admitting I'm wrong. That's how I eventually get to right.”
Sign In or Register to comment.