Options

Cisco 2600 router troubles, please help.

s0c0s0c0 Member Posts: 76 ■■□□□□□□□□
I have been attempting to configure 3 Cisco 2600 routers to talk with eachother, but have had no success. I can understand why. All routers are running eigrp, with an AS of 20. I have one main router called "s-houston" with 2 serial interfaces. s0/0 is configured with a 172.16.0.1/23 ip, s0/1 is 172.16.0.3/23. There is a w-houston with on serial interface, s0/0 configured as 172.16.0.2/23 this is directly connected in s0/0 on s-houston. I then have one called austin with an s0/0 as 172.16.0.4/23 that is directly connected to s0/1 on s-houston. All of the routers are running EIGRP w/ an AS 20 for the routing protocol. I can't get austin or w-houston to ping the serial interface they are directly connected to. I have pasted in the running configurations. Please advise. Thanks for reading.

s-houston#show running-config
Building configuration...

Current configuration : 757 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname s-houston
!
boot-start-marker
boot-end-marker
!
!
no network-clock-participate slot 1
no network-clock-participate wic 0
no aaa new-model
ip subnet-zero
ip cef
!
!
!
no ftp-server write-enable
!
!
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
ip address 172.16.0.1 255.255.254.0
clockrate 64000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
ip address 172.16.0.3 255.255.254.0
!
router eigrp 20
network 172.16.0.0
auto-summary
!
ip classless
ip http server
!
!
line con 0
line aux 0
line vty 0 4
!
!
!
end

w-houston#show running-config
Building configuration...

Current configuration : 635 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname w-houston
!
boot-start-marker
boot-end-marker
!
!
no network-clock-participate slot 1
no network-clock-participate wic 0
no aaa new-model
ip subnet-zero
ip cef
!
!
!
no ftp-server write-enable
!
!
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
ip address 172.16.0.2 255.255.254.0
no fair-queue
clockrate 64000
!
router eigrp 20
network 172.16.0.0
auto-summary
!
ip classless
ip http server
!
!
line con 0
line aux 0
line vty 0 4
!
!
!
end


austin>enable
austin#show running-config
Building configuration...

Current configuration : 622 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname austin
!
boot-start-marker
boot-end-marker
!
!
no network-clock-participate slot 1
no network-clock-participate wic 0
no aaa new-model
ip subnet-zero
ip cef
!
!
!
no ftp-server write-enable
!
!
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
ip address 172.16.0.4 255.255.254.0
no fair-queue
!
router eigrp 20
network 172.16.0.0
auto-summary
!
ip classless
ip http server
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
!
end

Comments

  • Options
    QUIX0TICQUIX0TIC Member Posts: 277
    S-Houston
    S0/0 - verify that the DCE side of the cable is connected to this router and verify that you have the proper clock rate and bandwidth variables set up on this interface.
    S0/1 - verify that the DCE side of the cable is connected to this router and verify that you have the proper clock rate and bandwidth variables set up on this interface.

    W-Houston
    S0/0 - verify that the DTE side of the cable is connected to this interface and only allow clocking to happen on the DCE side of the cable

    Austin - same as above
    "To realize one's destiny is a person's only obligation."
  • Options
    johnnynodoughjohnnynodough Member Posts: 634
    What WICs or NM's are you using for your serial connections? it looks like your config is right, you just pasted houstons config twice. Also how are they physically connected, as in Houston S1 conencts to AUtsin s0, etc. The reason I ask this is you have auto summarization enabled, and depending on your topology you could have a L3 problem with that. What are the status' of the inteface, post a show interfaces. Do you have L2 connectvity, i.e is CDP seeing a neighbor?
    Go Hawks - 7 and 2

    2 games againts San Fran coming up, oh yeah baby, why even play? just put then in the win category and call it good :p
  • Options
    s0c0s0c0 Member Posts: 76 ■■□□□□□□□□
    I never set bandwidth on any of the interfaces. Could this be the problem? I thought bandwidth was not neccessary? If this is the problem then what is a good setting?

    All interfaces show up/line protocol up.

    Quixotic - Are you saying that the ends of the actual serial cables I'm using (not the actuall router ports) determine whether its a DTE or DCE?

    So there is no problem with my subetting scheme of 255.255.254.0 right?

    Thanks again for reading.
  • Options
    johnnynodoughjohnnynodough Member Posts: 634
    YOu need to change your addressing scheme, you have all interfaces on all routers in the same subnet, subnet zero of net 172.16.0.0, Houson S0/0 and S0/1 should be in different subnets, put one in subnet 172.16.0.0 and one in subnet 172.16.2.0, along with their respective peers.

    Dont need bandwidth, the interfaces will default to T1 speeds.

    If you are up and up, your cabling should be correct.

    Does CDP show neighbors?
    Go Hawks - 7 and 2

    2 games againts San Fran coming up, oh yeah baby, why even play? just put then in the win category and call it good :p
  • Options
    s0c0s0c0 Member Posts: 76 ■■□□□□□□□□
    When I had them on different subnets I kept on getting this annoying error across all routers saying that they were not on the same subnet (I can't remember the exact wording of the error). That is why I changed the addressing scheme. When I set it up though I had both s-houston serial interfaces in the same subnet. Not one in austin's subnet and one in w-houston's subnet. Could this be the issue?

    So my new setup should be s-houston s0/0 172.16.2.1 connecting to w-houston s0/0 172.16.2.2 and s-houston s0/1 172.16.4.1 connecting to austin s0/0 172.16.4.2. Assuming a /23 subnet mask. Will this work with the ethernet interfaces as the s-houston office LAN is supposed to be 172.16.0.0/23?

    CDP - I do not have CDP enabled. I will turn on CDP.
  • Options
    johnnynodoughjohnnynodough Member Posts: 634
    So my new setup should be s-houston s0/0 172.16.2.1 connecting to w-houston s0/0 172.16.2.2 and s-houston s0/1 172.16.4.1 connecting to austin s0/0 172.16.4.2. Assuming a /23 subnet mask. Will this work with the ethernet interfaces as the s-houston office LAN is supposed to be 172.16.0.0/23?

    That should work, if not you have a layer 2 problem like Quixotix was angling towards, or you have some discrete comfig error which I dont see.
    CDP - I do not have CDP enabled. I will turn on CDP.

    CDP is your friend, ping tests layers 1-3, but if you cant get layer 3 up your pings wont work, so you can rely on CDP for layers 1-2, makes for easier troubleshooting if you can isolate layers.
    Go Hawks - 7 and 2

    2 games againts San Fran coming up, oh yeah baby, why even play? just put then in the win category and call it good :p
  • Options
    QUIX0TICQUIX0TIC Member Posts: 277
    JND is correct. But, I wouldnt exactly use a /23 SM. Try /24 or make sure they are in different subnets per serial link.

    You need to insure that one side is providing the clocking at it will always be the DCE side of the cable. Of course, since you are showing up/up... you have all ready provided the cabling correctly.

    Stick with a SM of /24 for now and Im pretty sure you will see your config work. Unless is there a reason why you need /23?
    "To realize one's destiny is a person's only obligation."
  • Options
    s0c0s0c0 Member Posts: 76 ■■□□□□□□□□
    I will switch to /24, but I wanted /23 for the extra hosts per subnet. Thanks for your input guys. I will let you know when this issue has been resolved.
  • Options
    YankeeYankee Member Posts: 157
    You don't need "extra subnets" on a serial interface. Most use a /30 or maybe a /29 on point to point interfaces.
    Disable auto-summary in your eigrp config and see what happens.

    Yankee
  • Options
    EdTheLadEdTheLad Member Posts: 2,111 ■■■■□□□□□□
    Hi s0c0, looks like you need to brush up on your VLSM.From your question it
    doesnt seem your comfortable with the whole classful,classless nature of routing protocols.This is what Yankee is pointing towards when he mentions
    disabling auto-summary.In your case disabling auto-summary will have no effect as you have not created a major network boundary in your configuration.
    Networking, sometimes i love it, mostly i hate it.Its all about the $$$$
  • Options
    YankeeYankee Member Posts: 157
    Disabling auto-summary is simply proper, normal procedure. I was hoping someone else would notice his addressing scheme...
    interface Serial0/0
    ip address 172.16.0.1 255.255.254.0
    !
    interface Serial0/1
    ip address 172.16.0.3 255.255.254.0

    When troubleshooting a problem it is good practice to correct a config to a normal baseline then proceed. You do this to prevent future or perhaps even present unintended consequences.

    Yankee
  • Options
    darkuserdarkuser Member Posts: 620 ■■■□□□□□□□
    you should disable auto-summary as a rule unless you'd like your routing protocol to behave classfully.
    otherwise you could just run rip v1.
    rm -rf /
  • Options
    EdTheLadEdTheLad Member Posts: 2,111 ■■■■□□□□□□
    darkuser wrote:
    you should disable auto-summary as a rule unless you'd like your routing protocol to behave classfully.
    otherwise you could just run rip v1.

    Not exactly true,i am in not way saying not to disable auto-summary i'm just trying to highlight what the command does.Generally of course i disable, but in the network described above there is no justification.Yankee specifically states to disable auto-summary and see the results.In this case senario there
    is not change.If auto-summary wasnt needed cisco would eliminate this from the default config.If you are running a network using the same major network address and only 1 access point out of your network auto-summary works perfect in this senario.I can still run a classless routing protocol in this case and have no routing loops.
    Networking, sometimes i love it, mostly i hate it.Its all about the $$$$
  • Options
    johnnynodoughjohnnynodough Member Posts: 634
    yankee
    Disabling auto-summary is simply proper, normal procedure. I was hoping someone else would notice his addressing scheme...

    Johnynodough
    The reason I ask this is you have auto summarization enabled, and depending on your topology you could have a L3 problem with that

    Yipee, I did catch it icon_lol.gif

    Austo sumarization can catch him on this situation (granted if he fixed the address scheme to have the interfaces in different subnets) His defined summary is 172.16.0.0, there are subnets in the 172.16.0.0 off both serial interfaces, so which direction would packets go destined for any subnet off of 172.16.0.0 summary.
    Go Hawks - 7 and 2

    2 games againts San Fran coming up, oh yeah baby, why even play? just put then in the win category and call it good :p
  • Options
    darkuserdarkuser Member Posts: 620 ■■■□□□□□□□
  • Options
    EdTheLadEdTheLad Member Posts: 2,111 ■■■■□□□□□□
    Yipee, I did catch it icon_lol.gif

    Austo sumarization can catch him on this situation (granted if he fixed the address scheme to have the interfaces in different subnets) His defined summary is 172.16.0.0, there are subnets in the 172.16.0.0 off both serial interfaces, so which direction would packets go destined for any subnet off of 172.16.0.0 summary.

    Johnny from what you have written it doesnt look like you've grasped the concept of auto-summarization completely.
    Having the addresses on different subnets and using a different level mask will not change the entries in the routing table of any of these routers with auto-summary enabled or disabled as long as all the routers are using the 172.16.x.x major network boundary.Auto-summary has nothing to do with VLSM within the network.

    The only time auto-summarization comes into play is when a route forms
    a major network boundary.As would be the case if one of these routers had to different interfaces configured with two different major class networks.An example would be 172.16.x.x and 172.15.x.x, in this case if auto-summarization is enabled the router will summarize all routes on the
    172.16.x.x side into 172.15.x.x as 172.16.0.0 and vice versa.
    Suppose you have designed a network which is designed to route completely within the same major classful boundary which is not uncommon and this network is a stub network .i.e. there is only one access point in and out of the network to an ISP, the interface to the ISP will be on a different classful boundary, with auto-summary enabled everywhere the effect which this will have on your network is to summarize out of your network your major class network address.Nothing will change inside your network and the auto-summay enabled on internal routers will have no effect anywhere.
    Good practice is to disable auto-summarization and summarize manually so you can have more control over summarization in your network.With auto-summarization enabled a topology change like adding an extra access point could create loops and screw your network.
    Networking, sometimes i love it, mostly i hate it.Its all about the $$$$
  • Options
    johnnynodoughjohnnynodough Member Posts: 634
    Doh, I see. If he had a summarized route of 172.16.16.0 defined and had subnets 172.16.16.0 and 172.16.0.0 off different inerfaces then he could have routing problems. I saw 172.16.0.0 and confused the network number and auto summarization with summarized routes.
    Go Hawks - 7 and 2

    2 games againts San Fran coming up, oh yeah baby, why even play? just put then in the win category and call it good :p
  • Options
    darkuserdarkuser Member Posts: 620 ■■■□□□□□□□
    woo-hoo !!!
    rm -rf /
Sign In or Register to comment.