Can't access internet with Cisco 2821 router, any suggestions?

pamccabepamccabe Member Posts: 315 ■■■□□□□□□□
Ok, this is a continuation from my earlier posts about getting a Cisco 2821 router working as a home router. I secured it with Auto Secure, setup PAT, setup the router to act a DHCP server and verified that clients can get an IP. I even setup a default route and pointed it to my ISP's default gateway. Before I plug in my cable modem, I go over the settings...

My ISP has assigned me a 72.xxxx.xxxx.xxxx address which I found from the web managment page of my NetGear router. I plug my cable modem into my Cisco router and do a 'sho ip int br'. The interface that points to my ISP is dhcp enabled, however, it grabs a 65.xxxx.xxxx.xxxx address.

The thing that really confuses me is that I do a 'sho ip nat trans' and see the ip address of my computer is being translated using PAT. However, I can't access the Internet at all.

Any suggestions?


  • pamccabepamccabe Member Posts: 315 ■■■□□□□□□□
    Here is the config of the interface:

    interface GigabitEthernet0/1
    description ISP Connection
    ip address dhcp
    ip access-group autosec_firewall_acl in
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip nat outside
    ip inspect autosec_inspect out
    ip virtual-reassembly in
    ip verify unicast source reachable-via rx allow-default 100
    duplex auto
    speed auto
    no mop enabled
  • jahsouljahsoul Member Posts: 453
    If you can ping a website Google or any other website from the router, you should be good. The only other thing that I can think of is setting the DNS you get from you ISP as the DNS for your DHCP scope.

    Also, since you are using DHCP on the outside interface, you shouldn't have to set a default route out. That route is automatically injected, at least it is on my router.
    Reading: What ever is on my desk that day :study:
  • pamccabepamccabe Member Posts: 315 ■■■□□□□□□□
    No, I can't ping anything from the router.

    I thought a default route to the ISP's default gateway was the way to make this work. I read something online about it.

    At any rate, it doesn't work. Why would I get a diff IP address when plugging it into a diff router?
  • jahsouljahsoul Member Posts: 453
    That I don't know, below is the configuration for my Internet facing interface.

    interface GigabitEthernet0/0
    description *INTERNET*
    ip address dhcp client-id GigabitEthernet0/0
    ip nat outside
    ip virtual-reassembly in
    zone-member security Internet
    duplex auto
    speed auto

    I didn't set a default route to TWC default gateway, but it was automatically set when my router got an IP address.

    S* [254/0] via x.x.x.x

    When you set your interface to DHCP, it should automatically get the default gateway and DNS, Do you think your access list on that interface might be part of the problem?
    Reading: What ever is on my desk that day :study:
  • deth1kdeth1k Member Posts: 312
    Take your CBAC / ACL off and try again.
  • pamccabepamccabe Member Posts: 315 ■■■□□□□□□□
    deth1k wrote: »
    Take your CBAC / ACL off and try again.

    Great, now I am able to ping from the router. Going to setup the network again and verify from clients...
  • networker050184networker050184 Mod Posts: 11,962 Mod
    Just an fyi you don't need to manually set up a default route when you set your wan interface to get an IP via DHCP. The router will install one automatically. Saves you from having to change your default route if the ISP decides to change addressing scheme.
    An expert is a man who has made all the mistakes which can be made.
  • Jason0352Jason0352 Member Posts: 59 ■■□□□□□□□□
    A good rule of thumb in setting up connectivity for the first time is to enable the most basic config then verify layer 3 connectivity. Once you know you're good, then start adding the services (ACLs, CBAC, firewalls) one at a time while confirming connectivity is still good. If connectivity breaks you have a better idea of what service is responsible.
  • pamccabepamccabe Member Posts: 315 ■■■□□□□□□□
    Thanks guys for all the input! This forum is an amazing resource.

    A late update, my network is up and running! I had to wait because the wife and kids just couldn't handle the network being down for troubleshooting. lol A guy on the Cisco IRC channel I frequent said to treat your home like a workplace environment to help with setting up concepts and troubleshooting. I guess he was right. My maintenance window is the very early morning. lol

    Anyway, yes, everything is working! I'm pumped! I guess that ACL was the problem. I also had to setup a trunk port because I changed the VLAN from 1 to another number. The only thing I'm noticing is my Mbps has taken a hit. I was gettgin 20Mbps from my desktop with a straight through connection, and now get 16Mbps. My laptop, over wireless, is getting 7Mbps. I can't complain though, I love the setup. For browsing, I don't see much of a difference. Loading up CCP now to see if I can what processes are taking up cpu and memory usage. I'll take a look via the CLI also, almost rather do that than CCP... anyway, I digress. Thanks for the help guys!
Sign In or Register to comment.