N7K-SUP2 Password Recovery

Hello all,

I tried to do a password recovery on a n7k-sup2 and can't seem to login. I issued a write erase in the switch(boot) mode and reloaded. I'm looking at the cisco manuals online but can't seem to find anything on the default password. All I can find is a reference to if a write erase is implemented then at startup you get this:

User Access Verifcation
login:admin
password: <password>

I tried every combination I could think of but can't seem to figure out the default password. Any help would be greatly appreciated.

Comments

  • FloOzFloOz Posts: 1,614Member ■■■■□□□□□□
    In switch(boot) don't try and wr erase. Go into conf t and set a new admin password.


    switch(boot)# conf t
    switch(boot)(config)#admin-password PASSWORD123
    switch(boot)(config)#exit

    After that look up your NX-OS image file name using the "dir" command and boot off of it.

    switch(boot)# load bootflash: filename

    When your device reboots go into global config and configure a new username and password

    NEXUS1(config)# username admin password PASSWORD123
    copy run start

    hope this helps you out
  • Legacy UserLegacy User Posts: 0Unregistered / Not Logged In ■□□□□□□□□□
    Flooz--Would you know how to enable the ports on a N7K-M132XP-12L and N7K-F248XP-25. I figured it would be similar to a 6500 or 7500 chassis but its not. After I type a show ip interface brief I get a blank output. I figure I have to enable them to come online.
  • FloOzFloOz Posts: 1,614Member ■■■■□□□□□□
    The m1 card and the f2 cards can not be in the same vdc. That is why you will not see all the interfaces when you do a show ip int brief. Allocate the m1 card to a separate vdc and you should be fine.
  • Legacy UserLegacy User Posts: 0Unregistered / Not Logged In ■□□□□□□□□□
    You sure know your Nexus. I got connectivity and can ping between 2 7010 chassis made separate vdc's. A bit perplexed on the blank show ip interface brief output:

    switch# sh ip int brief
    IP Interface Status for VRF "default"(1)
    Interface IP Address Interface Status
    Vlan1 10.1.1.25 protocol-down/link-down/admin-up
    switch#

    I do get connectivity so I'm pretty over it but out of curiosity what version of software were you running. I'm running 6.1.1 and are the interfaces supposed to be shown in the show ip interface brief or is it just not shown.
  • FloOzFloOz Posts: 1,614Member ■■■■□□□□□□
    haha thanks for the compliment but I am very very veryyyyy far from even knowing Nexus. Currently at work we are building out a new data center that consists of Nexus's so I pretty much took it upon myself to try and learn as much as I can in as little time as possible.

    As for my IOS I just upgraded the IOS, kickstart, and epld to 6.2. It was recently released and considering these Nexus's aren't in production yet, I figured I mine as well have the latest and greatest code installed.

    Yes when u boot up your Nexus and only the default VDC is active then your M1 card interfaces will not be shown until you allocate them to a different interface. When the F3 cards come out you will be able to have the F3 and M1 card in the same VDC.

    Say you have 2 F2 cards and 1 M1 card. If you boot up the nexus and move the F2 cards to a different VDC and then do a show int status you will then see the M1 cards interfaces
  • Legacy UserLegacy User Posts: 0Unregistered / Not Logged In ■□□□□□□□□□
    Yea I'm pretty much in the same boat. We got in 2 NXS-C7010 chassis loaded with cards and I was given the task to make sure all the ports works and everything works as it supposed too. Funny thing is noone really worked with these so I was pulling out my hair last friday figuring these things out. These were in deployment for a month elsewhere before we bought them and I was having a problem because the old config kept creeping up and made my life a lot more difficult not allowing me to issue certain cmds and a write erase wasn't doing it. I actually had the opposite happen with me. I have the M card in slot 1 and F2 cards in slot 2, 3 only the interfaces for the M card were allocated to the default VDC. Had to create another VDC for the F2 cards and allocated the ports there. But all in all despite the huge headache I figured these bad boys out and now I know in the future you are the go to guy.
  • FloOzFloOz Posts: 1,614Member ■■■■□□□□□□
    Feel free to message me anytime :)
Sign In or Register to comment.