Static NAT/FTP SERVER problem

deacongibsondeacongibson Posts: 8Member ■□□□□□□□□□
I am new to Firewall and about taking the FIREWALL v2.0 642-618. After several attemps, i am in this forum for solution.

I can ping from all lower secuity level interfaces to higher security level interface, I can also ping the DMZ server from outside interface.

But I cannot connect to my Filezilla server in DMZ server from an outside host when my DMZ NAT configuration is set from higher to lower eg (NAT (DMZ,OUTSIDE)), but I can connect to my Filezilla server when I reverse the configuration eg (NAT (OUTSIDE,DMZ)).

From all knowledge cisco books and toturials, is suppose to be (NAT (DMZ,OUTSIDE)). I need to connect to FTP server using the right NAT static configuration which is (NAT (DMZ,OUTSIDE)).

I need someone to help me out on what i am doing wrong.

See hereunder for config.

ASA2(config)# sh run
: Saved
:
ASA Version 8.4(2)
!
hostname ASA2
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface GigabitEthernet0
nameif inside
security-level 100
ip address 192.168.100.1 255.255.255.0
!
interface GigabitEthernet1
nameif OUTSIDE
security-level 0
ip address 192.168.137.2 255.255.255.0
!
interface GigabitEthernet2
nameif DMZ
security-level 50
ip address 172.100.100.1 255.255.255.0
!
interface GigabitEthernet3
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet4
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet5
shutdown
no nameif
no security-level
no ip address
!
ftp mode passive
dns domain-lookup inside
dns server-group Default
name-server 4.2.2.2
name-server 8.8.8.8
object network INSIDE-NET
subnet 192.168.100.0 255.255.255.0
object network DMZ-NAT
host 192.168.137.33
object network POOL-RANGE-4-INSIDE-NET
range 192.168.137.100 192.168.137.150
object network SERVER2-REAL-IP
host 172.100.100.3
object-group network DM_INLINE_NETWORK_1
network-object 172.100.100.0 255.255.255.0
network-object object INSIDE-NET
access-list OUTSIDE_access extended permit tcp any object SERVER2-REAL-IP eq ftp
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu OUTSIDE 1500
mtu DMZ 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
!
object network INSIDE-NET
nat (inside,any) dynamic POOL-RANGE-4-INSIDE-NET
object network SERVER2-REAL-IP
nat (OUTSIDE,DMZ) static DMZ-NAT
access-group OUTSIDE_access in interface OUTSIDE
!
router eigrp 1
no auto-summary
network 172.100.100.0 255.255.255.0
network 192.168.100.0 255.255.255.0
network 192.168.137.0 255.255.255.0
!
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
http server enable
http 192.168.100.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
telnet timeout 5
ssh timeout 5
console timeout 0
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
!
class-map global-class
match default-inspection-traffic
class-map global-class1
match any
!
!
policy-map global-policy
class global-class
inspect dns
inspect h323 h225
inspect h323 ras
inspect ip-options
inspect netbios
inspect rtsp
inspect sip
inspect esmtp
inspect rsh
inspect skinny
inspect sqlnet
inspect sunrpc
inspect tftp
inspect xdmcp
inspect ftp
inspect icmp
class global-class1
set connection advanced-options tcp-state-bypass
!
service-policy global-policy global
prompt hostname context
no call-home reporting anonymous
call-home
profile CiscoTAC-1
no active
destination address http https://tool

Comments

  • eteneten Posts: 67Member ■■□□□□□□□□
    have you tried to configure a port forward (static PAT) rather than a static nat?

    try replacing this in your network object

    nat (DMZ,outside) static DMZ-NAT service tcp ftp ftp
  • deacongibsondeacongibson Posts: 8Member ■□□□□□□□□□
    Thanks, Eten it works.

    Regards Gibson
Sign In or Register to comment.