trouble setting up Vlan routing:- cant ping pc from switch
Hello Dave
Member Posts: 5 ■□□□□□□□□□
in CCNA & CCENT
im trying to set up switch to start vlan routing
i can ping pc1 to pc2 and vice versa but i cant ping switch to pc or pc to switch
switch is 2960-24TT
show data as follows
(ignore vlan1 as only using vlan 10 and 20)
pc1 is plugged in to fe0/1 with ip 10.0.0.10/24 and pc 2 is in fe0/2 with ip 10.0.0.11/24
pc2 will change to ip 11.0.0.11/24 once i move it on to vlan 20
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
interface FastEthernet0/1
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/2
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/3
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/4
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/5
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/6
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/7
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/8
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/9
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/10
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/11
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/12
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/13
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/14
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/15
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/16
switchport access vlan 20
!
interface FastEthernet0/17
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/18
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/19
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/20
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!
interface Vlan1
ip address 10.0.0.2 255.0.0.0
shutdown
!
interface Vlan10
ip address 10.0.0.2 255.255.255.0
!
interface Vlan20
ip address 11.0.0.2 255.255.255.0
!
ip default-gateway 10.0.0.1
i can ping pc1 to pc2 and vice versa but i cant ping switch to pc or pc to switch
switch is 2960-24TT
show data as follows
(ignore vlan1 as only using vlan 10 and 20)
pc1 is plugged in to fe0/1 with ip 10.0.0.10/24 and pc 2 is in fe0/2 with ip 10.0.0.11/24
pc2 will change to ip 11.0.0.11/24 once i move it on to vlan 20
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
interface FastEthernet0/1
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/2
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/3
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/4
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/5
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/6
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/7
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/8
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/9
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/10
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/11
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/12
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/13
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/14
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/15
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/16
switchport access vlan 20
!
interface FastEthernet0/17
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/18
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/19
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/20
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!
interface Vlan1
ip address 10.0.0.2 255.0.0.0
shutdown
!
interface Vlan10
ip address 10.0.0.2 255.255.255.0
!
interface Vlan20
ip address 11.0.0.2 255.255.255.0
!
ip default-gateway 10.0.0.1
Comments
-
atorven Member Posts: 3192960 Switches can't route between vlans, you need either need to connect it to a router and then go with a router on a stick setup or change the switch to a layer 3 switch, I think packet tracer has a 3550 switch which should work for you.
-
pamccabe Member Posts: 315 ■■■□□□□□□□What is the output when you try to ping from switch to pc?
What is the default gateway set as on the pc's? -
Hello Dave Member Posts: 5 ■□□□□□□□□□atorven
at this point im trying to set the switch up
will be attaching a 1841 router once i can get the vlans to ping the pc's
pamccabe
switch tto pc1
Sw1#ping 10.0.0.10
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.10, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
pc1 to switch
PC>ping 10.0.0.2
Pinging 10.0.0.2 with 32 bytes of data:
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Ping statistics for 10.0.0.2:
Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),
pc1 to pc2
PC>ping 10.0.0.11
Pinging 10.0.0.11 with 32 bytes of data:
Reply from 10.0.0.11: bytes=32 time=18ms TTL=128
Reply from 10.0.0.11: bytes=32 time=7ms TTL=128
Reply from 10.0.0.11: bytes=32 time=8ms TTL=128
Reply from 10.0.0.11: bytes=32 time=11ms TTL=128
Ping statistics for 10.0.0.11:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 7ms, Maximum = 18ms, Average = 11ms -
powmia Users Awaiting Email Confirmation Posts: 322I don't believe that command is available on the 2960 switch.
Catalyst 2960 and 2960-S Switches Software Configuration Guide, Cisco IOS Release 15.0(2)SE and Later - Configuring Static IP Routing [Cisco Catalyst 2960 Series Switches] - Cisco Systems
RTFM -
Hello Dave Member Posts: 5 ■□□□□□□□□□
Sw1(config)#ip routing
^
% Invalid input detected at '^' marker.
ip routing wont work
does give me these options those
Sw1(config)#ip ?
access-list Named access-list
default-gateway Specify default gateway (if not routing IP)
domain IP DNS Resolver
domain-lookup Enable IP Domain Name System hostname translation
ftp FTP configuration commands
host Add an entry to the ip hostname table
name-server Specify address of name server to us -
Hello Dave Member Posts: 5 ■□□□□□□□□□powmia
sorry ip routing didnt work
Sw1(config)#ip routing
^
% Invalid input detected at '^' marker.
what is avalable is
Sw1(config)#ip ?
access-list Named access-list
default-gateway Specify default gateway (if not routing IP)
domain IP DNS Resolver
domain-lookup Enable IP Domain Name System hostname translation
ftp FTP configuration commands
host Add an entry to the ip hostname table
name-server Specify address of name server to use -
powmia Users Awaiting Email Confirmation Posts: 322K, try issuing "sdm prefer lanbase-routing" and reload, then enter "ip routing." If not, you don't have an image that supports it. I think the software you would need is actually the lanbase image.
You can still setup your router-on-a-stick with the 1841, you just won't be able to get any inter-vlan routing to happen locally on the switch. -
Hello Dave Member Posts: 5 ■□□□□□□□□□K, try issuing "sdm prefer lanbase-routing" and reload, then enter "ip routing." If not, you don't have an image that supports it. I think the software you would need is actually the lanbase image.
You can still setup your router-on-a-stick with the 1841, you just won't be able to get any inter-vlan routing to happen locally on the switch.
still not playing nice
Sw1(config)#sdm prefer lanbase-routing
^
% Invalid input detected at '^' marker.
is this the part where i hit it with a hammer?
lol
any way
will try with a different switch see if i can get it to work that way
suppose i should have said before im using packet tracer 5 for my CCNA course
wish i could get my hands on PT6 as have had less issues with that when im in the classroom -
Monkerz Member Posts: 842Just upgrade the IOS on that switch to 12.2(55)SE or greater and turn on IP routing. It will not support routing protocols, but you will accomplish what you are attempting to do.