Options

Eigrp Flapping on subinterfaces

amb1s1amb1s1 Member Posts: 408
Hi, I'm doing a lab and I encounter an issue with EIGRP where my EIGRP neighbor keep flapping. Here is the messages:
*Feb 17 20:40:46.121: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 172.16.35.5 (FastEthernet0/0.60) is down: Interface Goodbye received
*Feb 17 20:40:46.169: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 172.16.35.5 (FastEthernet0/0.60) is up: new adjacency
*Feb 17 20:42:05.683: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 172.16.35.5 (FastEthernet0/0.60) is down: retry limit exceeded
*Feb 17 20:42:10.179: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 172.16.35.5 (FastEthernet0/0.60) is up: new adjacency
*Feb 17 20:43:29.697: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 172.16.35.5 (FastEthernet0/0.60) is down: retry limit exceeded
*Feb 17 20:43:30.066: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 172.16.35.5 (FastEthernet0/0.60) is up: new adjacency
*Feb 17 20:44:49.584: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 172.16.35.5 (FastEthernet0/0.60) is down: retry limit exceeded
*Feb 17 20:44:53.791: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 172.16.35.5 (FastEthernet0/0.60) is up: new adjacency

It is a large lab, but I will point out the routers with this issues:

R3 is connect to Sw1 and Sw1 connects to R5

R3 config:
interface FastEthernet0/0
 no ip address
 speed auto
 full-duplex
!
interface FastEthernet0/0.50
 encapsulation dot1Q 50
 ip address 172.16.30.3 255.255.255.0
 ip irdp
 ip irdp multicast
 ip irdp maxadvertinterval 20
 ip irdp minadvertinterval 20
 ip irdp holdtime 60
 ip irdp preference 100
 shutdown
!
interface FastEthernet0/0.60
 encapsulation dot1Q 60
 ip address 172.16.35.3 255.255.255.128
!
router eigrp 100
 redistribute eigrp 300
 redistribute rip
 network 172.16.35.3 0.0.0.0
 default-metric 10000 100 255 1 1500
 auto-summary
!
router eigrp 300
 redistribute rip
 network 172.16.34.3 0.0.0.0
 default-metric 10000 100 255 1 1500
 auto-summary
!
router rip
 version 2
 redistribute eigrp 100 metric 1
 redistribute eigrp 300 metric 1
 passive-interface default
 no passive-interface Serial0/0.123
 network 172.16.0.0
 neighbor 172.16.123.1
!

Switch1
interface FastEthernet0/3
description R3
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 50,60
 switchport mode trunk
 switchport nonegotiate
 duplex full
!
interface FastEthernet0/5
 description R5
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 10,60
 switchport mode trunk
 switchport nonegotiate
 duplex full

Router 5
interface FastEthernet0/0
 no ip address
 speed auto
 full-duplex
!
interface FastEthernet0/0.10
 encapsulation dot1Q 10
 ip address 172.16.10.5 255.255.255.192
!
interface FastEthernet0/0.60
 encapsulation dot1Q 60
 ip address 172.16.35.5 255.255.255.0
!
router eigrp 100
 network 172.16.35.5 0.0.0.0
 auto-summary
!
router eigrp 200
 redistribute connected route-map L5551
 network 172.16.10.0 0.0.0.255
 network 172.16.200.12 0.0.0.3
 default-metric 10000 100 255 1 1500
 auto-summary
 neighbor 172.16.10.1 FastEthernet0/0.10
 neighbor 172.16.10.6 FastEthernet0/0.10
!



Here are some show command

R3
Routing Protocol is "eigrp 100"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  EIGRP maximum hopcount 100
  EIGRP maximum metric variance 1
  Default redistribution metric is 10000 100 255 1 1500
  Redistributing: eigrp 100, eigrp 300, rip
  EIGRP NSF-aware route hold timer is 240s
  Automatic network summarization is in effect
  Maximum path: 4
  Routing for Networks:
    172.16.35.3/32
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: internal 90 external 170


R3#    sh int f0/0
FastEthernet0/0 is up, line protocol is up
  Hardware is AmdFE, address is 0014.a92f.7680 (bia 0014.a92f.7680)
  MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation 802.1Q Virtual LAN, Vlan ID  1., loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, 100BaseTX/FX
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 1 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     2648 packets input, 193930 bytes
     Received 2291 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog
     0 input packets with dribble condition detected
     3744 packets output, 352763 bytes, 0 underruns
     0 output errors, 0 collisions, 3 interface resets
     0 unknown protocol drops
     0 babbles, 0 late collision, 0 deferred
     80 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out

Debug on R3
R3#debug ip packet 101 detail
IP packet debugging is on (detailed) for access list 101
R3#
*Feb 17 20:55:55.760: IP: s=172.16.34.3 (local), d=224.0.0.10 (Serial0/0.34), len 60, sending broad/multicast, proto=88
*Feb 17 20:55:57.243: IP: s=172.16.35.3 (local), d=224.0.0.10 (FastEthernet0/0.60), len 60, sending broad/multicast, proto=88
*Feb 17 20:55:57.247: IP: s=172.16.35.5 (FastEthernet0/0.60), d=224.0.0.10, len 60, rcvd 2, proto=88
*Feb 17 20:55:57.251: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 172.16.35.5 (FastEthernet0/0.60) is up: new adjacency
*Feb 17 20:55:57.251: IP: s=172.16.35.3 (local), d=224.0.0.10 (FastEthernet0/0.60), len 60, sending broad/multicast, proto=88
*Feb 17 20:55:57.251: IP: tableid=0, s=172.16.35.5 (FastEthernet0/0.60), d=172.16.35.3 (FastEthernet0/0.60), routed via RIB
*Feb 17 20:55:57.255: IP: s=172.16.35.5 (FastEthernet0/0.60), d=172.16.35.3 (FastEthernet0/0.60), len 40, rcvd 3, proto=88
*Feb 17 20:55:57.259: IP: s=172.16.35.3 (local), d=172.16.35.5 (FastEthernet0/0.60), len 40, sending, proto=88
*Feb 17 20:55:57.259: IP: s=172.16.35.5 (FastEthernet0/0.60), d=224.0.0.10, len 77, rcvd 2, proto=88
*Feb 17 20:55:57.263: IP: s=172.16.35.5 (FastEthernet0/0.60), d=224.0.0.10, len 40, rcvd 2, proto=88
*Feb 17 20:55:57.267: IP: s=172.16.35.3 (local), d=224.0.0.10 (FastEthernet0/0.60), len 77, sending broad/multicast, proto=88
*Feb 17 20:55:57.267: IP: s=172.16.35.3 (local), d=224.0.0.10 (FastEthernet0/0.60), len 857, sending broad/multicast, proto=88
*Feb 17 20:55:59.254: IP: tableid=0, s=172.16.35.5 (FastEthernet0/0.60), d=172.16.35.3 (FastEthernet0/0.60), routed via RIB
*Feb 17 20:55:59.254: IP: s=172.16.35.5 (FastEthernet0/0.60), d=172.16.35.3 (FastEthernet0/0.60), len 40, rcvd 3, proto=88
*Feb 17 20:55:59.262: IP: s=172.16.35.3 (local), d=172.16.35.5 (FastEthernet0/0.60), len 40, sending, proto=88
*Feb 17 20:56:00.480: IP: s=172.16.34.3 (local), d=224.0.0.10 (Serial0/0.34), len 60, sending broad/multicast, proto=88
*Feb 17 20:56:01.506: IP: s=172.16.35.5 (FastEthernet0/0.60), d=224.0.0.10, len 60, rcvd 2, proto=88
*Feb 17 20:56:01.850: IP: s=172.16.35.3 (local), d=224.0.0.10 (FastEthernet0/0.60), len 60, sending broad/multicast, proto=88
*Feb 17 20:56:02.255: IP: tableid=0, s=172.16.35.5 (FastEthernet0/0.60), d=172.16.35.3 (FastEthernet0/0.60), routed via RIB
*Feb 17 20:56:02.255: IP: s=172.16.35.5 (FastEthernet0/0.60), d=172.16.35.3 (FastEthernet0/0.60), len 40, rcvd 3, proto=88
*Feb 17 20:56:02.263: IP: s=172.16.35.3 (local), d=172.16.35.5 (FastEthernet0/0.60), len 40, sending, proto=88



R5 Show commands
Routing Protocol is "eigrp 100"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  EIGRP maximum hopcount 100
  EIGRP maximum metric variance 1
  Redistributing: eigrp 100
  EIGRP NSF-aware route hold timer is 240s
  Automatic network summarization is in effect
  Maximum path: 4
  Routing for Networks:
    172.16.35.5/32
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: internal 90 external 170


R5(config-if)#do sh int f0/0
FastEthernet0/0 is up, line protocol is up
  Hardware is AmdFE, address is 0012.da88.4fc0 (bia 0012.da88.4fc0)
  MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation 802.1Q Virtual LAN, Vlan ID  1., loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, 100BaseTX/FX
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 1000 bits/sec, 1 packets/sec
     5252 packets input, 501733 bytes
     Received 628 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog
     0 input packets with dribble condition detected
     7726 packets output, 659302 bytes, 0 underruns
     0 output errors, 0 collisions, 3 interface resets
     0 unknown protocol drops
     0 babbles, 0 late collision, 0 deferred
     4 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out


R5 Debug
R5#debug ip packet 101 det
IP packet debugging is on (detailed) for access list 101
R5#
*Mar  1 02:40:13.787: IP: s=172.16.10.5 (local), d=172.16.10.1 (FastEthernet0/0.10), len 60, sending, proto=88
*Mar  1 02:40:13.787: IP: s=172.16.10.5 (local), d=172.16.10.6 (FastEthernet0/0.10), len 60, sending, proto=88
*Mar  1 02:40:14.464: IP: tableid=0, s=172.16.35.3 (FastEthernet0/0.60), d=172.16.35.5 (FastEthernet0/0.10), routed via RIB
*Mar  1 02:40:14.468: IP: s=172.16.35.3 (FastEthernet0/0.60), d=172.16.35.5 (FastEthernet0/0.10), g=172.16.10.1, len 40, forward, proto=88
*Mar  1 02:40:14.488: IP: s=172.16.35.5 (local), d=172.16.35.3 (FastEthernet0/0.60), len 40, sending, proto=88
*Mar  1 02:40:15.077: IP: s=172.16.35.5 (local), d=224.0.0.10 (FastEthernet0/0.60), len 60, sending broad/multicast, proto=88
*Mar  1 02:40:15.129: IP: tableid=0, s=172.16.10.6 (FastEthernet0/0.10), d=172.16.10.5 (FastEthernet0/0.10), routed via RIB
*Mar  1 02:40:15.129: IP: s=172.16.10.6 (FastEthernet0/0.10), d=172.16.10.5 (FastEthernet0/0.10), len 60, rcvd 3, proto=88
*Mar  1 02:40:15.289: IP: tableid=0, s=172.16.10.1 (FastEthernet0/0.10), d=172.16.10.5 (FastEthernet0/0.10), routed via RIB
*Mar  1 02:40:15.289: IP: s=172.16.10.1 (FastEthernet0/0.10), d=172.16.10.5 (FastEthernet0/0.10), len 60, rcvd 3, proto=88
*Mar  1 02:40:16.102: IP: s=172.16.35.3 (FastEthernet0/0.60), d=224.0.0.10, len 60, rcvd 2, proto=88
*Mar  1 02:40:16.531: IP: s=172.16.200.13 (local), d=224.0.0.10 (Loopback2013), len 60, sending broad/multicast, proto=88
*Mar  1 02:40:16.531: IP: s=172.16.200.13 (Loopback2013), d=224.0.0.10, len 60, rcvd 2, proto=88
*Mar  1 02:40:18.146: IP: s=172.16.10.5 (local), d=172.16.10.1 (FastEthernet0/0.10), len 60, sending, proto=88
*Mar  1 02:40:18.146: IP: s=172.16.10.5 (local), d=172.16.10.6 (FastEthernet0/0.10), len 60, sending, proto=88
*Mar  1 02:40:19.464: IP: tableid=0, s=172.16.35.3 (FastEthernet0/0.60), d=172.16.35.5 (FastEthernet0/0.10), routed via RIB
*Mar  1 02:40:19.468: IP: s=172.16.35.3 (FastEthernet0/0.60), d=172.16.35.5 (FastEthernet0/0.10), g=172.16.10.1, len 40, forward, proto=88
*Mar  1 02:40:19.488: IP: s=172.16.35.5 (local), d=172.16.35.3 (FastEthernet0/0.60), len 40, sending, proto=88
*Mar  1 02:40:19.849: IP: tableid=0, s=172.16.10.1 (FastEthernet0/0.10), d=172.16.10.5 (FastEthernet0/0.10), routed via RIB
*Mar  1 02:40:19.849: IP: s=172.16.10.1 (FastEthernet0/0.10), d=172.16.10.5 (FastEthernet0/0.10), len 60, rcvd 3, proto=88
*Mar  1 02:40:19.945: IP: s=172.16.35.5 (local), d=224.0.0.10 (FastEthernet0/0.60), len 60, sending broad/multicast, proto=88
*Mar  1 02:40:20.009: IP: tableid=0, s=172.16.10.6 (FastEthernet0/0.10), d=172.16.10.5 (FastEthernet0/0.10), routed via RIB
*Mar  1 02:40:20.009: IP: s=172.16.10.6 (FastEthernet0/0.10), d=172.16.10.5 (FastEthernet0/0.10), len 60, rcvd 3, proto=88
*Mar  1 02:40:20.698: IP: s=172.16.35.3 (FastEthernet0/0.60), d=224.0.0.10, len 60, rcvd 2, proto=88
*Mar  1 02:40:20.794: IP: s=172.16.200.13 (local), d=224.0.0.10 (Loopback2013), len 60, sending broad/multicast, proto=88
*Mar  1 02:40:20.794: IP: s=172.16.200.13 (Loopback2013), d=224.0.0.10, len 60, rcvd 2, proto=88
*Mar  1 02:40:22.485: IP: s=172.16.10.5 (local), d=172.16.10.1 (FastEthernet0/0.10), len 60, sending, proto=88
*Mar  1 02:40:22.485: IP: s=172.16.10.5 (local), d=172.16.10.6 (FastEthernet0/0.10), len 60, sending, proto=88
*Mar  1 02:40:24.384: IP: tableid=0, s=172.16.10.1 (FastEthernet0/0.10), d=172.16.10.5 (FastEthernet0/0.10), routed via RIB
*Mar  1 02:40:24.384: IP: s=172.16.10.1 (FastEthernet0/0.10), d=172.16.10.5 (FastEthernet0/0.10), len 60, rcvd 3, proto=88
*Mar  1 02:40:24.468: IP: tableid=0, s=172.16.35.3 (FastEthernet0/0.60), d=172.16.35.5 (FastEthernet0/0.10), routed via RIB
*Mar  1 02:40:24.468: IP: s=172.16.35.3 (FastEthernet0/0.60), d=172.16.35.5 (FastEthernet0/0.10), g=172.16.10.1, len 40, forward, proto=88
*Mar  1 02:40:24.488: IP: s=172.16.35.5 (local), d=224.0.0.10 (FastEthernet0/0.60), len 60, sending broad/multicast, proto=88
*Mar  1 02:40:24.488: IP: s=172.16.35.5 (local), d=172.16.35.3 (FastEthernet0/0.60), len 40, sending, proto=88
*Mar  1 02:40:24.949: IP: tableid=0, s=172.16.10.6 (FastEthernet0/0.10), d=172.16.10.5 (FastEthernet0/0.10), routed via RIB
*Mar  1 02:40:24.949: IP: s=172.16.10.6 (FastEthernet0/0.10), d=172.16.10.5 (FastEthernet0/0.10), len 60, rcvd 3, proto=88
*Mar  1 02:40:25.446: IP: s=172.16.35.3 (FastEthernet0/0.60), d=224.0.0.10, len 60, rcvd 2, proto=88


Thanks in advance
David G.
http://gomezd.com <
My Tshoot test Blog
http://twitter.com/ipnet255

Comments

Sign In or Register to comment.