Can't see ISO

brownwrapbrownwrap Member Posts: 549
I am trying to build a linux vm. I have tried everything I can think of, but it still tried to boot from the net and thus doesn't find an OS. I have a datastore on my Esxi host and a usb drive. Server did not come with a built in drive, but I was able to load the Esxi software. I sftp'd my Linus OSes to the host and placed them on the datastore volume. I can browse to their location. I can also ssh into the host and cd to the datastore and see that they are there. On the vm I can browse to their location, and I have booted the vm to its bios and made cdrom the top choice. I don't even know if it make an attempt, the first thing I see is DHCP and trying to boot on the net which fail. I've used the change cd connection to poit to the datastore, and then changed it back trying to use the host cdrom. I one ISO I am working on has no trouble booting and starting a debian install, but VMware just doesn't see it. Any ideas?

Comments

  • EssendonEssendon Member Posts: 4,548 ■■■■■■■■■■
    There should be two boxes where you choose between Host device/Client Device/ISO file that say Connected and Connect at power on. Are they checked?
    NSX, NSX, more NSX..

    Blog >> http://virtual10.com
  • brownwrapbrownwrap Member Posts: 549
    I am not at the system right now, but I know the connect at power on is checked. I will have to verify the other setting.
  • brownwrapbrownwrap Member Posts: 549
    The connect at power up is checked, the other is greyed out. When I power the vm up it changes to connected, but never attempts to boot from the cdrom, which is usb.
  • paul78paul78 Member Posts: 3,016 ■■■■■■■■■■
    If you are using the vSphere Client, when you edit the guest OS settings, select the "Options" tab, under the Advance section, try setting the Boot Options to "Force BIOS Setup". Then in the BIOS, take a look and make sure that you have setup the boot order correctly.
  • brownwrapbrownwrap Member Posts: 549
    Yes, I have tried that. I forced it to boot the the bios, and cdrom is the top choice.
  • paul78paul78 Member Posts: 3,016 ■■■■■■■■■■
    Let me see if I understand - you have an ISO file that is located on a USB drive and the USB drive is one of your datastores? Or do you have a USB CDRom drive and you are trying to access a CD in the CDRom drive?

    Have you tried using an ISO file on one of your datastores and setting the CDROM device type to "Datastore ISO File"? That's usually how I do it.
  • brownwrapbrownwrap Member Posts: 549
    I have tried both ways. I have a USB drive and tried accessing it using the cdrom setup under edit setting, and I have the ISO on a datastore that I can browse to. It is not booting off either.
  • paul78paul78 Member Posts: 3,016 ■■■■■■■■■■
    Hmm - are you sure it's a bootable ISO?
  • brownwrapbrownwrap Member Posts: 549
    Yes, it is bootable.
  • kj0kj0 Member Posts: 767
    If the USB isn't actually a datastore, you will want to power own the VM in Console view and then go up to the top and click on the cd to choose where to boot the cd from > select from Local Computer and then locate the USB and select the ISO.

    You can only do this step when the VM is powered on, so once you've selected from Local computer, you will need to reset/restart the VM without powering it off.
    2017 Goals: VCP6-DCV | VCIX
    Blog: https://readysetvirtual.wordpress.com
  • paul78paul78 Member Posts: 3,016 ■■■■■■■■■■
    It's really quite odd that you would have your ISO on a datastore but it still isn't bootable. Is this a Linux ISO that you created or one that you downloaded? If it's an ISO that is readily available, I am happy to try to download it and see if it works.

    Having an ISO on a recognized datastore and booting from it is how I typically install guests and test ISO's that I create. I place all my ISOs on an NFS share which I access from my ESXi hosts. What you are describing should work if it's on a datastore that is recognized by the host.
  • TheNewITGuyTheNewITGuy Member Posts: 169 ■■■■□□□□□□
    Move the ISO to your machine, mount it from vmware and see if it sees it then. This is going to tell you if it's an image issue - I'm going to say the ISO isnt recognized but who knows..
  • brownwrapbrownwrap Member Posts: 549
    I am not sure what you mean by 'move it to your machine'. My setup is a Dell blade without and cdrom in it. I was able to load the ESXI software using a usb external drive. I installed the vSphere client on my notebook and talk to the Dell that way. I turned on SSH and sftp'd the ISOs to the ESXI host. I have not been able to try anything today. I will take a look at it again tomorrow. I'd be happy if it was operator error.
  • TheNewITGuyTheNewITGuy Member Posts: 169 ■■■■□□□□□□
    Move the ISO to your notebook (which has a cdrom) follow these instructions


    • Log into your server using vShpere



    • Right-click on the VM in the left navigation pane and click on Edit Settings.



    • In the Virtual Machine Properties window, click on CD/DVD Drive 1. In the right of the window, there will be a Device Type section. Select Client Deviceand clik OK to save the changes.



    • Before you can mount the ISO, the VM needs to be started. You can do so by right-clicking on the VM and selecting power -> Power On.



    • In the top menu, click on the CD-ROM icon and select CD/DVD Drive 1 ->Connect to ISO image on local disk.
  • brownwrapbrownwrap Member Posts: 549
    I was able to connect to the usb drive on the laptop, but the machine had already booted. Once I connected and hit reset, it disconnects the drive.
  • tstrip007tstrip007 Member Posts: 308 ■■■■□□□□□□
    Try this... Open the VM console and power on the VM (with no OS). While its powering on, connect to your ISO through the console (hit CD icon and "Connect to iso image on local disk". Once connected, click inside the console to make sure you in there and hit ctrl+alt+del to reboot the VM. Should boot from the ISO when it comes back up. Should also take your physical pc to the ctrl+alt+del screen, just click task manager to get back to your desktop.
  • brownwrapbrownwrap Member Posts: 549
    That did it. It is starting to boot. Thanks to all.
  • kj0kj0 Member Posts: 767
    tstrip007 wrote: »
    Try this... Open the VM console and power on the VM (with no OS). While its powering on, connect to your ISO through the console (hit CD icon and "Connect to iso image on local disk". Once connected, click inside the console to make sure you in there and hit ctrl+alt+del to reboot the VM. Should boot from the ISO when it comes back up. Should also take your physical pc to the ctrl+alt+del screen, just click task manager to get back to your desktop.
    That's what I said. You said it better. ;)
    2017 Goals: VCP6-DCV | VCIX
    Blog: https://readysetvirtual.wordpress.com
  • brownwrapbrownwrap Member Posts: 549
    Again, thanks to all. Since it kept trying to boot off the net, I thought I was going to have to set up a boot server. I am not at all happy with the machine I purchased. It is a Dell blade that someone here had ordered. Extremely loud, would not boot Red Hat from cd. when I called to complain, it is used, they said it ran RH. Turns out they back a boot server and had never really tried from a cd. I'm sure I am going to run into some other issue, since I am actually installing a Rocks cluster under VMware.
  • brownwrapbrownwrap Member Posts: 549
    Actually this process brings on another question. Why doesn't ESXI see the drive on the laptop in the first place? I was indeed able to boot, and start the install process, but although I could see the cdrom being accessed, it didn't seem like any progress was being made, and I waited well over an hour.

    I am wondering could this same trick be used to connect to the datastore on the ESXI host? That would certainly get around the slowness issue.
Sign In or Register to comment.