Ccnp - basic l3 switch routing issue

samuel.lao85samuel.lao85 Member Posts: 19 ■□□□□□□□□□
Hi guys,

Im studying CCNP SWITCH. I was checking IP CEF features, so I decided to start using 3550 Catalyst switch in order to do InterVlan Routing (VLAN 1 and VLAN 2). Here is my info

Building configuration...

Current configuration : 2802 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname SW1925_Internet
!
enable password cisco
!
ip subnet-zero
ip routing ---> # IP ROUTING ENABLED #
!
vtp mode transparent
!
!
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree uplinkfast max-update-rate 50
spanning-tree vlan 1 priority 24576
spanning-tree vlan 2 priority 24576
spanning-tree vlan 3 priority 24576
!
!
vlan 2
name prueba2
!
vlan 3
name prueba3
!
interface FastEthernet0/1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1-3
switchport mode trunk
no ip address
duplex full
speed 100
udld port
!
interface FastEthernet0/2
switchport mode access
no ip address
!
interface FastEthernet0/3
switchport trunk encapsulation dot1q
switchport mode trunk
no ip address
duplex full
speed 100
udld port
!
interface FastEthernet0/4
switchport mode access
no ip address
!
interface FastEthernet0/5 ----> # PC1 ( IP 172.16.1.5)#
switchport access vlan 2
switchport mode access
no ip address
spanning-tree portfast
!
interface FastEthernet0/6
switchport mode access
no ip address
!
interface FastEthernet0/7
switchport mode access
no ip address
!
interface FastEthernet0/8
switchport mode access
no ip address
!
interface FastEthernet0/9
switchport mode access
no ip address
!
interface FastEthernet0/10
switchport mode access
no ip address
!
interface FastEthernet0/11
switchport mode access
no ip address
!
interface FastEthernet0/12
switchport mode access
no ip address
!
interface FastEthernet0/13
switchport mode access
no ip address
!
interface FastEthernet0/14
switchport mode access
no ip address
!
interface FastEthernet0/15
switchport mode access
no ip address
!
interface FastEthernet0/16
switchport mode access
no ip address
!
interface FastEthernet0/17
switchport mode access
no ip address
!
interface FastEthernet0/18
switchport mode access
no ip address

interface FastEthernet0/19
switchport mode access
no ip address
!
interface FastEthernet0/20
switchport mode access
no ip address
!
interface FastEthernet0/21
switchport mode access
no ip address
!
interface FastEthernet0/22
switchport mode access
no ip address
!
interface FastEthernet0/23
switchport trunk encapsulation dot1q
switchport mode trunk
no ip address
!
interface FastEthernet0/24 ---> # PC 2 (IP 192.168.1.25)#
switchport mode access
no ip address
spanning-tree portfast
!
interface GigabitEthernet0/1
no ip address
!
interface GigabitEthernet0/2
no ip address
!
interface Vlan1
ip address 192.168.1.20 255.255.255.0 # GATEWAY FOR PC 2 #
!
interface Vlan2
ip address 172.16.1.20 255.255.255.0 # GATEWAY FOR PC 1 #
!
ip default-gateway 192.168.1.20
ip classless
ip http server
!
!
!
line con 0
line vty 0 4
exec-timeout 20 0
password cisco
login
line vty 5 15
exec-timeout 20 0
password cisco
login
!
end

SW1925_Internet#

But, I still can't route traffic between those VLANS. Both VLANS show LINE UP, PROTOCOL UP, but there is only routing in 1 direction.

Ping from 172.16.1.5 ---> 192.168.1.25 works
Ping from 192.168.1.25 ---> 172.16.1.5 not working

Additionally, the same happens if you try to use ping within the catalyst.

I would appreciate your advices....

Comments

Sign In or Register to comment.