Options

Ip helper

danyzukodanyzuko Member Posts: 40 ■■□□□□□□□□
QUESTION... is the helper address only used when your hopping over a router(broadcast domain)? Because I was looking at this guys tutorial and he's using a server to do DHCP but everything is in one domain. So i'm just puzzled on why he had to use ip helper? --> Inter VLAN Configuration plus IP- Helper Address - YouTube

I replicated it with DHCP on the Router instead of the server and it worked fine without ip helpers on vlans 10 and 20. Please advise:

ROUTER
ip dhcp pool VLAN10
network 10.100.0.32 255.255.255.224
default-router 10.100.0.62
ip dhcp pool VLAN20
network 10.100.0.64 255.255.255.224
default-router 10.100.0.94
ip dhcp pool VLAN30
network 10.100.0.96 255.255.255.224
default-router 10.100.0.126
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.2
encapsulation dot1Q 2
ip address 10.100.0.30 255.255.255.224
!
interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 10.100.0.62 255.255.255.224
!
interface FastEthernet0/0.20
encapsulation dot1Q 20
ip address 10.100.0.94 255.255.255.224
!
interface FastEthernet0/0.30
encapsulation dot1Q 30
ip address 10.100.0.126 255.255.255.224
ip helper-address 10.100.0.1
!
interface FastEthernet0/0.40
encapsulation dot1Q 40
ip address 10.100.0.158 255.255.255.224
ip helper-address 10.100.0.1
!
interface FastEthernet0/0.50
encapsulation dot1Q 50
ip address 10.100.0.190 255.255.255.224
ip helper-address 10.100.0.1


CORE SWITCH
hostname CORE
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
switchport access vlan 2
switchport mode access
!
interface FastEthernet0/2
switchport access vlan 2
switchport mode access
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
switchport trunk allowed vlan 1-99
switchport mode trunk
!
interface FastEthernet0/20
switchport trunk allowed vlan 1-99
switchport mode trunk
!
interface FastEthernet0/21
switchport trunk allowed vlan 1-99
switchport mode trunk
!
interface FastEthernet0/22
switchport trunk allowed vlan 1-99
switchport mode trunk
!
interface FastEthernet0/23
switchport trunk allowed vlan 1-99
switchport mode trunk
!
interface FastEthernet0/24
switchport trunk allowed vlan 1-99
switchport mode trunk




VLANS
CORE#sh vlan


VLAN Name Status Ports
----


1 default active Fa0/3, Fa0/4, Fa0/5, Fa0/6
Fa0/7, Fa0/8, Fa0/9, Fa0/10
Fa0/11, Fa0/12, Fa0/13, Fa0/14
Fa0/15, Fa0/16, Fa0/17, Fa0/18
Gig1/1, Gig1/2
2 admin active Fa0/1, Fa0/2
10 10 active
20 20 active
30 30 active
40 40 active
50 50 active


Switch 1
interface FastEthernet0/1
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/2
switchport trunk allowed vlan 1-99
switchport mode trunk

Comments

  • Options
    networker050184networker050184 Mod Posts: 11,962 Mod
    You need the helper to send it to another subnet.
    An expert is a man who has made all the mistakes which can be made.
  • Options
    FloOzFloOz Member Posts: 1,614 ■■■■□□□□□□
    As you know Routers do not forward broadcasts so the Router will need to be configured with the ip-helper command in order to relay dhcp requests
  • Options
    StaunchyStaunchy Member Posts: 180
    an example would be if you have a network with multiple IP subnets but don't have a DHCP server on the same subnet than you will put in an IP helper on your router sub-interface or interface depending if you do ROAS or not but if you use a L3 switch you will put it on the SVI.
    2016 Goals: CCNP R&S, CCNA Security, CCNP Security
    LinkedIn
  • Options
    DCDDCD Member Posts: 473 ■■■■□□□□□□
    He's using 5 different domains and not one domain and a router on the stick configuration. You're using the router that is directly connected to the switch you don't need to use IP helper address.
  • Options
    Magic JohnsonMagic Johnson Member Posts: 414
    Yeah as the requests are sent on 255.255.255.255 normally routers discard this, but if you tell the router not to discard DHCP messages sent to 255.255.255.255 using the ip-helper command on the interface that will receive it, with the remote server IP listed. So when the packet is received the source IP is removed (255.255.255.255) and replaced with the interface it was received on's IP as the source instead, so the remote server knows where to send it back.
  • Options
    danyzukodanyzuko Member Posts: 40 ■■□□□□□□□□
    How am I not using 5 different domains. I modeled my setup after his with 5 different sub-interfaces and different vlans.
  • Options
    danyzukodanyzuko Member Posts: 40 ■■□□□□□□□□
    I understand what you guys are telling me about the mechanics of vlans. I'm just curious why in spite of the fact that the video shows 5 sub-interfaces and 5 different vlans on the core switch (as I have replicated without using ip-helpers on the vlans 10 and 20). Why am I able to get these computers to pull DHCP when they seem to be on different broadcast domains?

    I pulled the ip-helpers off the vlans 10 and 20 subnets to try it and they pulled IPs with no problem.

    Not trying to argue with anyone, I'm just confused with that. :)
  • Options
    Magic JohnsonMagic Johnson Member Posts: 414
    Your router is the dhcp server? Which is technically connected to all your vlans through the stick configuration. So why would it need a helper to tell it to pass dhcp requests to itself?
  • Options
    networker050184networker050184 Mod Posts: 11,962 Mod
    As Magic Johnson pointed out you have local scopes built for all of these VLANs. It's not needed if you have a local scope already built.
    An expert is a man who has made all the mistakes which can be made.
  • Options
    danyzukodanyzuko Member Posts: 40 ■■□□□□□□□□
    Ahaa... So that's the difference between his setup and mine.
    Beautiful! I get it guys. I'm just used to using dhcp on routers. And that was the difference.
    Technically his DHCP server is on a different network. The device has to hop thru the router to get to it.
    So obviously the helper is needed.

    thanks a mucho!
  • Options
    Magic JohnsonMagic Johnson Member Posts: 414
    As Magic Johnson pointed out you have local scopes built for all of these VLANs. It's not needed if you have a local scope already built.

    I would so rep myself right now if I could. :Dicon_cool.gif
  • Options
    networker050184networker050184 Mod Posts: 11,962 Mod
    If you look at what the IP helper does down to a packet level it will be more obvious. What is it actually doing to the packet and why? Answer those and all doubt should be cleared.
    An expert is a man who has made all the mistakes which can be made.
Sign In or Register to comment.