Spanning Tree
danyzuko
Member Posts: 40 ■■□□□□□□□□
in CCNA & CCENT
Okay so I'm doing a lab with 3 switches. One is a 2960 and the other two for Voice are 3560s. I ran "show spanning-tree vlan 1" on all 3 machines expecting one of them to say "This is the Root". Now I know every VLAN has it's own Root but ignoring that for now. On the 2960 in the Root ID section under port it points to Fa0/2.
So I follow that port to one of the 3960s which under the same section, says Port Fa0/4
That port points out a non-configured port to a PC
All three switches have trunking turned on between them and the layer 3 switches have DOT1Q on for trunking as well. So why are they acting wierd like this?
If I'm running "show span vlan 1", isolating the vlan 1, shouldn't one of them say ROOT?
Here are the 3 configs:
Layer 2 switch
spanning-tree mode pvst
spanning-tree vlan 1 priority 4096
!
interface FastEthernet0/1
!
interface FastEthernet0/2
switchport mode trunk
!
interface FastEthernet0/3
switchport mode trunk
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!
interface Vlan1
ip address 172.16.1.1 255.255.255.0
shutdown
!
ip default-gateway 172.16.1.254
1st Layer 3 switch
spanning-tree mode pvst
!
!
!
!
interface FastEthernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
2nd Layer 3 switch
spanning-tree mode pvst
!
!
!
!
interface FastEthernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
So I follow that port to one of the 3960s which under the same section, says Port Fa0/4
That port points out a non-configured port to a PC
All three switches have trunking turned on between them and the layer 3 switches have DOT1Q on for trunking as well. So why are they acting wierd like this?
If I'm running "show span vlan 1", isolating the vlan 1, shouldn't one of them say ROOT?
Here are the 3 configs:
Layer 2 switch
spanning-tree mode pvst
spanning-tree vlan 1 priority 4096
!
interface FastEthernet0/1
!
interface FastEthernet0/2
switchport mode trunk
!
interface FastEthernet0/3
switchport mode trunk
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!
interface Vlan1
ip address 172.16.1.1 255.255.255.0
shutdown
!
ip default-gateway 172.16.1.254
1st Layer 3 switch
spanning-tree mode pvst
!
!
!
!
interface FastEthernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
2nd Layer 3 switch
spanning-tree mode pvst
!
!
!
!
interface FastEthernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
Comments
-
CoolAsAFan Member Posts: 239I just read a chapter in my ICND2 Odom book about this. I think you need to use the VLAN int and not fa eth int for inter-vlan routing. The book says, "The (layer-3) switch config adds each matched subnet and associated VLAN to a VLAN interface." Hope this helps.IvyTech - AS CINS (Completed: May, 2013)
WGU Indiana - BS IT Security (Started: August 1st, 2013)
Transferred: AGC1 CDP1 BVC1 CLC1 CVV1 DHV1 DJV1 GAC1 CIC1 CDC1 UBT1 IWC1 IWT1 TCP1 TJP1 TJC1 EBV1 WFV1 EUP1 EUC1 CJC1 UBC1 TBP1
Completed: CUV1 BOV1 DRV1 DSV1 CTV1 CJV1 COV1 CQV1 CNV1 TPV1 MGC1 TXC1 TXP1 BNC1 TYP1 TYC1
Required: SBT1 RGT1 RIT1 -
danyzuko Member Posts: 40 ■■□□□□□□□□Sorry, I think I miss-spoke. I meant to say that these outputs were there after I trunked the lines between them, and of course after I entered "Switch(config)#spanning-tree vlan 1 priority 1024", the core switch reads as ROOT.
But I'm just curious why there is not an official ROOT output prior to entering that statement.
I know there's a good reason, Just wanted to see more into why...
Here is the output you requested for VLAN 1: Is one of my mistakes assuming that all I need to be looking at is VLAN 1?
I will put the full show spanning-tree underneath the 3 VLAN 1 outputs in case you need to see the full output.
Core Layer 2 switch
Switch#sh spanning-tree vlan 1
VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 4097
Address 00E0.8FE9.493D
This bridge is the root
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 4097 (priority 4096 sys-id-ext 1)
Address 00E0.8FE9.493D
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 20
Interface Role Sts Cost Prio.Nbr Type
---- ---
Fa0/2 Desg FWD 19 128.2 P2p
Fa0/3 Desg FWD 19 128.3 P2p
1st Layer 3 switch
Switch#sh span vlan 1
VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 4097
Address 00E0.8FE9.493D
Cost 19
Port 1(FastEthernet0/1)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)
Address 000A.41EB.64DB
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 20
Interface Role Sts Cost Prio.Nbr Type
---- ---
Fa0/1 Root FWD 19 128.1 P2p
Fa0/2 Desg FWD 19 128.2 P2p
Fa0/3 Desg FWD 19 128.3 P2p
Fa0/4 Desg FWD 19 128.4 P2p
Fa0/5 Desg FWD 19 128.5 P2p
Fa0/6 Desg FWD 19 128.6 P2p
Fa0/7 Desg FWD 19 128.7 P2p
Fa0/24 Desg FWD 19 128.24 P2p
2nd Layer 3 switch
Switch#sh span vlan 1
VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 4097
Address 00E0.8FE9.493D
Cost 19
Port 1(FastEthernet0/1)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)
Address 0060.5C1A.5433
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 20
Interface Role Sts Cost Prio.Nbr Type
---- ---
Fa0/1 Root FWD 19 128.1 P2p
Fa0/2 Desg FWD 19 128.2 P2p
Fa0/3 Desg FWD 19 128.3 P2p
Fa0/4 Desg FWD 19 128.4 P2p
Fa0/5 Desg FWD 19 128.5 P2p
Fa0/6 Desg FWD 19 128.6 P2p
Fa0/7 Desg FWD 19 128.7 P2p
Fa0/24 Altn BLK 19 128.24 P2p
FULL OUTPUT
________________________________________________________________________
Switch#
%SYS-5-CONFIG_I: Configured from console by console
Switch#sh span
VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 4097
Address 00E0.8FE9.493D
This bridge is the root
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 4097 (priority 4096 sys-id-ext 1)
Address 00E0.8FE9.493D
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 20
Interface Role Sts Cost Prio.Nbr Type
---- ---
Fa0/2 Desg FWD 19 128.2 P2p
Fa0/3 Desg FWD 19 128.3 P2p
VLAN0010
Spanning tree enabled protocol ieee
Root ID Priority 32778
Address 000A.41EB.64DB
Cost 19
Port 2(FastEthernet0/2)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 32778 (priority 32768 sys-id-ext 10)
Address 00E0.8FE9.493D
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 20
Interface Role Sts Cost Prio.Nbr Type
---- ---
Fa0/2 Root FWD 19 128.2 P2p
Fa0/3 Altn BLK 19 128.3 P2p
VLAN0030
Spanning tree enabled protocol ieee
Root ID Priority 32798
Address 000A.41EB.64DB
Cost 19
Port 2(FastEthernet0/2)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 32798 (priority 32768 sys-id-ext 30)
Address 00E0.8FE9.493D
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 20
Interface Role Sts Cost Prio.Nbr Type
---- ---
Fa0/2 Root FWD 19 128.2 P2p
Fa0/3 Altn BLK 19 128.3 P2p
VLAN0040
Spanning tree enabled protocol ieee
Root ID Priority 32808
Address 000A.41EB.64DB
Cost 19
Port 2(FastEthernet0/2)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 32808 (priority 32768 sys-id-ext 40)
Address 00E0.8FE9.493D
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 20
Interface Role Sts Cost Prio.Nbr Type
---- ---
Fa0/2 Root FWD 19 128.2 P2p
Fa0/3 Altn BLK 19 128.3 P2p
Switch#sh span
VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 4097
Address 00E0.8FE9.493D
Cost 19
Port 1(FastEthernet0/1)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)
Address 000A.41EB.64DB
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 20
Interface Role Sts Cost Prio.Nbr Type
---- ---
Fa0/1 Root FWD 19 128.1 P2p
Fa0/2 Desg FWD 19 128.2 P2p
Fa0/3 Desg FWD 19 128.3 P2p
Fa0/4 Desg FWD 19 128.4 P2p
Fa0/5 Desg FWD 19 128.5 P2p
Fa0/6 Desg FWD 19 128.6 P2p
Fa0/7 Desg FWD 19 128.7 P2p
Fa0/24 Desg FWD 19 128.24 P2p
VLAN0010
Spanning tree enabled protocol ieee
Root ID Priority 32778
Address 000A.41EB.64DB
This bridge is the root
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 32778 (priority 32768 sys-id-ext 10)
Address 000A.41EB.64DB
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 20
Interface Role Sts Cost Prio.Nbr Type
---- ---
Fa0/1 Desg FWD 19 128.1 P2p
Fa0/24 Desg FWD 19 128.24 P2p
VLAN0030
Spanning tree enabled protocol ieee
Root ID Priority 32798
Address 000A.41EB.64DB
This bridge is the root
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 32798 (priority 32768 sys-id-ext 30)
Address 000A.41EB.64DB
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 20
Interface Role Sts Cost Prio.Nbr Type
---- ---
Fa0/1 Desg FWD 19 128.1 P2p
Fa0/24 Desg FWD 19 128.24 P2p
VLAN0040
Spanning tree enabled protocol ieee
Root ID Priority 32808
Address 000A.41EB.64DB
This bridge is the root
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 32808 (priority 32768 sys-id-ext 40)
Address 000A.41EB.64DB
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 20
Interface Role Sts Cost Prio.Nbr Type
---- ---
Fa0/1 Desg FWD 19 128.1 P2p
Fa0/24 Desg FWD 19 128.24 P2p
Switch#sh span
VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 4097
Address 00E0.8FE9.493D
Cost 19
Port 1(FastEthernet0/1)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)
Address 0060.5C1A.5433
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 20
Interface Role Sts Cost Prio.Nbr Type
---- ---
Fa0/1 Root FWD 19 128.1 P2p
Fa0/2 Desg FWD 19 128.2 P2p
Fa0/3 Desg FWD 19 128.3 P2p
Fa0/4 Desg FWD 19 128.4 P2p
Fa0/5 Desg FWD 19 128.5 P2p
Fa0/6 Desg FWD 19 128.6 P2p
Fa0/7 Desg FWD 19 128.7 P2p
Fa0/24 Altn BLK 19 128.24 P2p
VLAN0010
Spanning tree enabled protocol ieee
Root ID Priority 32778
Address 000A.41EB.64DB
Cost 19
Port 24(FastEthernet0/24)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 32778 (priority 32768 sys-id-ext 10)
Address 0060.5C1A.5433
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 20
Interface Role Sts Cost Prio.Nbr Type
---- ---
Fa0/1 Desg FWD 19 128.1 P2p
Fa0/24 Root FWD 19 128.24 P2p
VLAN0030
Spanning tree enabled protocol ieee
Root ID Priority 32798
Address 000A.41EB.64DB
Cost 19
Port 24(FastEthernet0/24)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 32798 (priority 32768 sys-id-ext 30)
Address 0060.5C1A.5433
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 20
Interface Role Sts Cost Prio.Nbr Type
---- ---
Fa0/1 Desg FWD 19 128.1 P2p
Fa0/24 Root FWD 19 128.24 P2p
VLAN0040
Spanning tree enabled protocol ieee
Root ID Priority 32808
Address 000A.41EB.64DB
Cost 19
Port 24(FastEthernet0/24)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 32808 (priority 32768 sys-id-ext 40)
Address 0060.5C1A.5433
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 20
Interface Role Sts Cost Prio.Nbr Type
---- ---
Fa0/1 Desg FWD 19 128.1 P2p
Fa0/24 Root FWD 19 128.24 P2p -
networker050184 Mod Posts: 11,962 ModRead the fifth line of output from the first switch you posted.An expert is a man who has made all the mistakes which can be made.
-
danyzuko Member Posts: 40 ■■□□□□□□□□networker050184 wrote: »Read the fifth line of output from the first switch you posted.
Sorry, I really mudled up my question. What I meant to post is this:
Switch#sh span vlan 1
VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 32769
Address 0001.6475.B61D
Cost 38
Port 2(FastEthernet0/2)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)
Address 00E0.8FE9.493D
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 20
Interface Role Sts Cost Prio.Nbr Type
---- ---
Fa0/2 Root FWD 19 128.2 P2p
Fa0/3 Altn BLK 19 128.3 P2p
Switch#sh span vlan 1
VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 32769
Address 0001.6475.B61D
Cost 19
Port 4(FastEthernet0/4)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)
Address 000A.41EB.64DB
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 20
Interface Role Sts Cost Prio.Nbr Type
---- ---
Fa0/1 Desg FWD 19 128.1 P2p
Fa0/2 Desg FWD 19 128.2 P2p
Fa0/3 Desg FWD 19 128.3 P2p
Fa0/4 Root FWD 19 128.4 P2p
Fa0/5 Desg FWD 19 128.5 P2p
Fa0/6 Desg FWD 19 128.6 P2p
Fa0/7 Desg FWD 19 128.7 P2p
Fa0/24 Desg FWD 19 128.24 P2p
Switch#sh span vlan 1
VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 32769
Address 0001.6475.B61D
Cost 38
Port 24(FastEthernet0/24)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)
Address 0060.5C1A.5433
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 20
Interface Role Sts Cost Prio.Nbr Type
---- ---
Fa0/1 Desg FWD 19 128.1 P2p
Fa0/2 Desg FWD 19 128.2 P2p
Fa0/3 Desg FWD 19 128.3 P2p
Fa0/4 Desg FWD 19 128.4 P2p
Fa0/5 Desg FWD 19 128.5 P2p
Fa0/6 Desg FWD 19 128.6 P2p
Fa0/7 Desg FWD 19 128.7 P2p
Fa0/24 Root FWD 19 128.24 P2p
these outputs were right after I trunked the lines between them, and of course after I entered "Switch(config)#spanning-tree vlan 1 priority 1024", the core switch reads as ROOT as you pointed out.
But I'm just curious why there is not an official ROOT output prior to entering that statement.
In the workplace are all the switches in this state of limbo before you declare a root with the priority statement? -
networker050184 Mod Posts: 11,962 ModHard to say without knowing the topology, but there is obviously a root somewhere.An expert is a man who has made all the mistakes which can be made.
-
danyzuko Member Posts: 40 ■■□□□□□□□□Yeah I think it's a packet tracer glitch, because all the other vlans clearly decided on a root bridge.
The command I used to give the core switch priority was:
spanning-tree vlan 10,30,40 priority 4096
I don't mean to waste anyone's time. It's just because I haven't been working in the field, it's hard to remember and we never went over other finer options like Port-priority, which I just read up on and understand the differences now.
Also, some great posts in her like;
http://www.techexams.net/forums/ccna-ccent/26363-spanning-tree-port-priority.html
Taking this second look now, it's beautifully coming together. I'm doing a huge lab from hell. Lol
Thanks Mr. CoolasaFan and Networker.