Help IP Telephony With router On A Stick
M1S0
Member Posts: 41 ■■□□□□□□□□
in CCNA & CCENT
Hi
I did a router on a stick configuration and I have a problem not sure how I can configure the IP Telephony Service
in order the ip cisco phones to get a number.
I did the configuration and all the end devices are getting an ip address from the dhcp server.
Thx
///////Router Configuration
R1#sh run
Building configuration...
Current configuration : 1282 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
spanning-tree mode pvst
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 172.16.0.193 255.255.255.224
ip helper-address 172.16.0.194
!
interface FastEthernet0/0.30
encapsulation dot1Q 30
ip address 172.16.0.1 255.255.255.128
ip helper-address 172.16.0.194
!
interface FastEthernet0/0.40
encapsulation dot1Q 40
ip address 172.16.1.1 255.255.255.224
ip helper-address 172.16.0.194
!
interface FastEthernet0/0.41
encapsulation dot1Q 41
ip address 172.16.1.33 255.255.255.224
ip helper-address 172.16.0.194
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
!
interface FastEthernet0/1.15
encapsulation dot1Q 15
ip address 172.16.0.225 255.255.255.224
!
interface Serial0/0/0
no ip address
!
interface Serial0/2/0
no ip address
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
!
interface FastEthernet1/1
no ip address
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
ip classless
line con 0
line aux 0
line vty 0 4
login
end
/////Multilayer Switch
S1#sh run
Building configuration...
Current configuration : 1543 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname S1
!
spanning-tree mode pvst
!
interface FastEthernet0/1
switchport trunk allowed vlan 10,30,40-41
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/2
switchport trunk allowed vlan 10,30,40-41
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/3
switchport trunk allowed vlan 10,30,40-41
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/4
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/5
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/6
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
ip classless
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
end
I did a router on a stick configuration and I have a problem not sure how I can configure the IP Telephony Service
in order the ip cisco phones to get a number.
I did the configuration and all the end devices are getting an ip address from the dhcp server.
Thx
///////Router Configuration
R1#sh run
Building configuration...
Current configuration : 1282 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
spanning-tree mode pvst
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 172.16.0.193 255.255.255.224
ip helper-address 172.16.0.194
!
interface FastEthernet0/0.30
encapsulation dot1Q 30
ip address 172.16.0.1 255.255.255.128
ip helper-address 172.16.0.194
!
interface FastEthernet0/0.40
encapsulation dot1Q 40
ip address 172.16.1.1 255.255.255.224
ip helper-address 172.16.0.194
!
interface FastEthernet0/0.41
encapsulation dot1Q 41
ip address 172.16.1.33 255.255.255.224
ip helper-address 172.16.0.194
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
!
interface FastEthernet0/1.15
encapsulation dot1Q 15
ip address 172.16.0.225 255.255.255.224
!
interface Serial0/0/0
no ip address
!
interface Serial0/2/0
no ip address
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
!
interface FastEthernet1/1
no ip address
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
ip classless
line con 0
line aux 0
line vty 0 4
login
end
/////Multilayer Switch
S1#sh run
Building configuration...
Current configuration : 1543 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname S1
!
spanning-tree mode pvst
!
interface FastEthernet0/1
switchport trunk allowed vlan 10,30,40-41
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/2
switchport trunk allowed vlan 10,30,40-41
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/3
switchport trunk allowed vlan 10,30,40-41
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/4
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/5
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/6
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
ip classless
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
end
Comments
-
networker050184 Mod Posts: 11,962 ModWhat are you asking? How to configure CUCME on the router or something else?An expert is a man who has made all the mistakes which can be made.
-
M1S0 Member Posts: 41 ■■□□□□□□□□How to configure the Telephony Service VOIP on the router in order the IP Cisco Phones to get a Phone Number
at the moment they get only IP address ?
thx -
networker050184 Mod Posts: 11,962 ModSo CUCME on the router? A quick google should get you started and you can ask any specific questions you have.An expert is a man who has made all the mistakes which can be made.
-
M1S0 Member Posts: 41 ■■□□□□□□□□I tried this on the router under the subinterface f0/0.30 and interface fa0/0 as well but didn't work
option 150 ip 172.16.0.196
max-ephones 5
max-dn 5
ip source-address 172.16.0.194 port 2000
auto assign 1 to 5
exit
ephone-dn 1
number 1001
ephone-dn 2
number 1002
ephone-dn 3
number 1003
not sure about the option 150 IP address and the ip source address
the ip source address should be the location where I configure the VOIP to assign ip addresses which is the dhcp server 172.16.0.194 and the option 150 address should be the location for the tftp server which is 172.16.0.196 ? -
networker050184 Mod Posts: 11,962 ModLook here for config examples.
Cisco Unified Communications Manager Express - Configuration Examples and TechNotes - CiscoAn expert is a man who has made all the mistakes which can be made.