Issue with Default route/ redistribution in EIGRP
Hi,
I am stuck doing a project of my own. Here is my setup: Sydney, Melbourne, Auckland have routers connected to eachother via wan link. Each site is connected to internet via WAN. Sydney, Melbourne, Auckland is using EIGRP as their routing protocol. Each have default route pointed to the Internet. This topology might help understand the design a bit more.
but i can't ping the 8.8.8.0 network from 10.1.1.0 network. if i add 8.8.8.0 network in EIGRP, it works, but i kind of trying to replicate internet and want to have default route to this network.
Sydney Router:
SYDR01#sh run
Building configuration...
Current configuration : 1378 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname SYDR01
!
!
!
!
ip dhcp excluded-address 10.1.1.1 10.1.1.100
!
ip dhcp pool SYDNEY_POOL
network 10.1.1.0 255.255.255.0
default-router 10.1.1.1
!
!
!
!
!
!
!
no ip domain-lookup
!
!
spanning-tree mode pvst
!
!
!
!
interface FastEthernet0/0
ip address 10.1.1.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0/0
ip address 150.0.0.1 255.255.255.252
!
interface Serial0/0/1
ip address 160.0.0.1 255.255.255.252
!
interface Serial0/1/0
ip address 170.0.0.1 255.255.255.252
!
interface Serial0/1/1
no ip address
shutdown
!
interface Serial0/2/0
no ip address
shutdown
!
interface Serial0/2/1
no ip address
shutdown
!
interface Serial0/3/0
no ip address
shutdown
!
interface Serial0/3/1
no ip address
shutdown
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet1/1
no ip address
duplex auto
speed auto
shutdown
!
interface Vlan1
no ip address
shutdown
!
router eigrp 1
redistribute static
network 160.0.0.0
network 10.0.0.0
network 170.0.0.0
auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 150.0.0.0
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end
SYDR01#sh run
Building configuration...
Current configuration : 1378 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname SYDR01
!
!
!
!
ip dhcp excluded-address 10.1.1.1 10.1.1.100
!
ip dhcp pool SYDNEY_POOL
network 10.1.1.0 255.255.255.0
default-router 10.1.1.1
!
!
!
!
!
!
!
no ip domain-lookup
!
!
spanning-tree mode pvst
!
!
!
!
interface FastEthernet0/0
ip address 10.1.1.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0/0
ip address 150.0.0.1 255.255.255.252
!
interface Serial0/0/1
ip address 160.0.0.1 255.255.255.252
!
interface Serial0/1/0
ip address 170.0.0.1 255.255.255.252
!
interface Serial0/1/1
no ip address
shutdown
!
interface Serial0/2/0
no ip address
shutdown
!
interface Serial0/2/1
no ip address
shutdown
!
interface Serial0/3/0
no ip address
shutdown
!
interface Serial0/3/1
no ip address
shutdown
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet1/1
no ip address
duplex auto
speed auto
shutdown
!
interface Vlan1
no ip address
shutdown
!
router eigrp 1
redistribute static
network 160.0.0.0
network 10.0.0.0
network 170.0.0.0
auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 150.0.0.0
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end
SYDR01#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is 150.0.0.0 to network 0.0.0.0
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
D 10.0.0.0/8 is a summary, 03:50:04, Null0
C 10.1.1.0/24 is directly connected, FastEthernet0/0
D 140.0.0.0/16 [90/2681856] via 170.0.0.2, 03:48:53, Serial0/1/0
[90/2681856] via 160.0.0.2, 02:48:13, Serial0/0/1
150.0.0.0/30 is subnetted, 1 subnets
C 150.0.0.0 is directly connected, Serial0/0/0
160.0.0.0/16 is variably subnetted, 2 subnets, 2 masks
D 160.0.0.0/16 is a summary, 03:50:04, Null0
C 160.0.0.0/30 is directly connected, Serial0/0/1
170.0.0.0/16 is variably subnetted, 2 subnets, 2 masks
D 170.0.0.0/16 is a summary, 03:49:54, Null0
C 170.0.0.0/30 is directly connected, Serial0/1/0
D 172.16.0.0/16 [90/2172416] via 170.0.0.2, 03:48:53, Serial0/1/0
D 192.168.0.0/24 [90/2172416] via 160.0.0.2, 02:48:13, Serial0/0/1
S* 0.0.0.0/0 [1/0] via 150.0.0.0
I am stuck doing a project of my own. Here is my setup: Sydney, Melbourne, Auckland have routers connected to eachother via wan link. Each site is connected to internet via WAN. Sydney, Melbourne, Auckland is using EIGRP as their routing protocol. Each have default route pointed to the Internet. This topology might help understand the design a bit more.
but i can't ping the 8.8.8.0 network from 10.1.1.0 network. if i add 8.8.8.0 network in EIGRP, it works, but i kind of trying to replicate internet and want to have default route to this network.
Sydney Router:
SYDR01#sh run
Building configuration...
Current configuration : 1378 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname SYDR01
!
!
!
!
ip dhcp excluded-address 10.1.1.1 10.1.1.100
!
ip dhcp pool SYDNEY_POOL
network 10.1.1.0 255.255.255.0
default-router 10.1.1.1
!
!
!
!
!
!
!
no ip domain-lookup
!
!
spanning-tree mode pvst
!
!
!
!
interface FastEthernet0/0
ip address 10.1.1.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0/0
ip address 150.0.0.1 255.255.255.252
!
interface Serial0/0/1
ip address 160.0.0.1 255.255.255.252
!
interface Serial0/1/0
ip address 170.0.0.1 255.255.255.252
!
interface Serial0/1/1
no ip address
shutdown
!
interface Serial0/2/0
no ip address
shutdown
!
interface Serial0/2/1
no ip address
shutdown
!
interface Serial0/3/0
no ip address
shutdown
!
interface Serial0/3/1
no ip address
shutdown
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet1/1
no ip address
duplex auto
speed auto
shutdown
!
interface Vlan1
no ip address
shutdown
!
router eigrp 1
redistribute static
network 160.0.0.0
network 10.0.0.0
network 170.0.0.0
auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 150.0.0.0
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end
SYDR01#sh run
Building configuration...
Current configuration : 1378 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname SYDR01
!
!
!
!
ip dhcp excluded-address 10.1.1.1 10.1.1.100
!
ip dhcp pool SYDNEY_POOL
network 10.1.1.0 255.255.255.0
default-router 10.1.1.1
!
!
!
!
!
!
!
no ip domain-lookup
!
!
spanning-tree mode pvst
!
!
!
!
interface FastEthernet0/0
ip address 10.1.1.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0/0
ip address 150.0.0.1 255.255.255.252
!
interface Serial0/0/1
ip address 160.0.0.1 255.255.255.252
!
interface Serial0/1/0
ip address 170.0.0.1 255.255.255.252
!
interface Serial0/1/1
no ip address
shutdown
!
interface Serial0/2/0
no ip address
shutdown
!
interface Serial0/2/1
no ip address
shutdown
!
interface Serial0/3/0
no ip address
shutdown
!
interface Serial0/3/1
no ip address
shutdown
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet1/1
no ip address
duplex auto
speed auto
shutdown
!
interface Vlan1
no ip address
shutdown
!
router eigrp 1
redistribute static
network 160.0.0.0
network 10.0.0.0
network 170.0.0.0
auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 150.0.0.0
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end
SYDR01#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is 150.0.0.0 to network 0.0.0.0
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
D 10.0.0.0/8 is a summary, 03:50:04, Null0
C 10.1.1.0/24 is directly connected, FastEthernet0/0
D 140.0.0.0/16 [90/2681856] via 170.0.0.2, 03:48:53, Serial0/1/0
[90/2681856] via 160.0.0.2, 02:48:13, Serial0/0/1
150.0.0.0/30 is subnetted, 1 subnets
C 150.0.0.0 is directly connected, Serial0/0/0
160.0.0.0/16 is variably subnetted, 2 subnets, 2 masks
D 160.0.0.0/16 is a summary, 03:50:04, Null0
C 160.0.0.0/30 is directly connected, Serial0/0/1
170.0.0.0/16 is variably subnetted, 2 subnets, 2 masks
D 170.0.0.0/16 is a summary, 03:49:54, Null0
C 170.0.0.0/30 is directly connected, Serial0/1/0
D 172.16.0.0/16 [90/2172416] via 170.0.0.2, 03:48:53, Serial0/1/0
D 192.168.0.0/24 [90/2172416] via 160.0.0.2, 02:48:13, Serial0/0/1
S* 0.0.0.0/0 [1/0] via 150.0.0.0
Comments
-
fredrikjj Member Posts: 879This works assuming that there is no other configuration on any other router besides the internet router having an eigrp neighbor relationship with the sydney router (it's hard to predict exactly what you've done on the other routers). The internet router should have a route to 10.0.0.0/8 with the next hop 150.0.0.1 and a ping to 8.8.8.8 sourced from 10.1.1.0/24 should take the default route through s0/0/0. The return path will use the internet router's route to 10.0.0.0/8 via 150.0.0.1.
However, what you probably want is to originate a default route on the internet router, not the sydney router. But, it should still work.sydney(config)#do show ip route Gateway of last resort is 150.0.0.0 to network 0.0.0.0 10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks D 10.0.0.0/8 is a summary, 00:04:17, Null0 C 10.1.1.1/32 is directly connected, Loopback0 150.0.0.0/16 is variably subnetted, 2 subnets, 2 masks C 150.0.0.0/30 is directly connected, Serial0/0 D 150.0.0.0/16 is a summary, 00:04:17, Null0 S* 0.0.0.0/0 [1/0] via 150.0.0.0
internet(config)#do show ip route Gateway of last resort is 150.0.0.1 to network 0.0.0.0 8.0.0.0/32 is subnetted, 1 subnets C 8.8.8.8 is directly connected, Loopback0 D 10.0.0.0/8 [90/2297856] via 150.0.0.1, 00:06:11, Serial0/0 150.0.0.0/30 is subnetted, 1 subnets C 150.0.0.0 is directly connected, Serial0/0 D*EX 0.0.0.0/0 [170/2681856] via 150.0.0.1, 00:02:29, Serial0/0
sydney#ping 8.8.8.8 source lo0 Type escape sequence to abort. Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds: Packet sent with a source address of 10.1.1.1 !!!!! Success rate is 100 percent (5/5), round-trip min/avg/max = 4/31/48 ms sydney#
PS.
If this was Ethernet, using ip route 0.0.0.0 0.0.0.0 150.0.0.0 would cause the sydney router to ARP for every single destination that uses the default route. On a serial link however this works* even if it doesn't look very clean.
PPS
*yes it works on ethernet too but requires proxy arp. -
ranti13 Member Posts: 8 ■□□□□□□□□□Hey Thanks for your reply....
Basically i wanted to simulate internet provider. suppose i have router thats pointing to internet (ISP), i put a default route in my router, what does the ISP side to to reply? how do they configure their side to reply? Melbourne and Auckland has the same configuration as Sydney. Here is the configuration for Internet router.
PS. Thanks for that. that works now.
INTERNET#sh run
Building configuration...
Current configuration : 1141 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname INTERNET
!
!
!
!
!
!
!
!
!
!
!
!
no ip domain-lookup
!
!
spanning-tree mode pvst
!
!
!
!
interface FastEthernet0/0
ip address 8.8.8.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0/0
ip address 150.0.0.2 255.255.255.252
!
interface Serial0/0/1
ip address 190.0.0.2 255.255.255.252
!
interface Serial0/1/0
ip address 180.0.0.2 255.255.255.252
!
interface Serial0/1/1
no ip address
shutdown
!
interface Serial0/2/0
no ip address
shutdown
!
interface Serial0/2/1
no ip address
shutdown
!
interface Serial0/3/0
no ip address
shutdown
!
interface Serial0/3/1
no ip address
shutdown
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet1/1
no ip address
duplex auto
speed auto
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 8.8.8.0
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end
INTERNET# sh ip rou
INTERNET# sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is 8.8.8.0 to network 0.0.0.0
8.0.0.0/24 is subnetted, 1 subnets
C 8.8.8.0 is directly connected, FastEthernet0/0
150.0.0.0/30 is subnetted, 1 subnets
C 150.0.0.0 is directly connected, Serial0/0/0
180.0.0.0/30 is subnetted, 1 subnets
C 180.0.0.0 is directly connected, Serial0/1/0
190.0.0.0/30 is subnetted, 1 subnets
C 190.0.0.0 is directly connected, Serial0/0/1
S* 0.0.0.0/0 [1/0] via 8.8.8.0