GNS3 connecting router through telnet

JacobGatesJacobGates Member Posts: 33 ■■□□□□□□□□
Okay so I am studying on this site freeccnastudyguide.com and I have gotten to telnet and IOS 3-10 Using Telnet on IOS « Free CCNA Study Guide Free CCNA Study Guide

I have 2 3660 routers in GNS3 and they are connected via FastEthernet 0/0. If I do
show cdp entry *
I can see the other router is connected. But when I follow the site's tutorial for telnet I get a
% Destination unreachable; gateway or host down

I have set a password for both routers in vty and did
transport input ssh telnet
after setting up a hostname, ip domain-name, and encrypting.

So I don't know if I didn't do something I was supposed to or if the study site didn't tell me something or what but for some reason telnet is not connecting. Anyone's help is great appreciated.

Comments

  • Jon_CiscoJon_Cisco Member Posts: 1,772 ■■■■■■■■□□
    Can you ping between the hosts?
    Did you set up your vty lines to login and set a vty password?
  • JacobGatesJacobGates Member Posts: 33 ■■□□□□□□□□
    Jon_Cisco wrote: »
    Can you ping between the hosts?
    Did you set up your vty lines to login and set a vty password?

    I did set up the vty lines with password and login, but I thought I remembered pinging them before but I tried it just now and no, 0% success.
  • martell1000martell1000 Member Posts: 389
    paste you configs, so we can check.
    And then, I started a blog ...
  • JacobGatesJacobGates Member Posts: 33 ■■□□□□□□□□
    paste you configs, so we can check.
    Okay I have two (hostname Anna and Jacob [me and my girlfriend]) so I have just wrapped them in two separate code wraps:

    Anna:
    !!
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Anna
    !
    boot-start-marker
    boot-end-marker
    !
    enable secret 5 $1$Mh4O$5F1/YPUeJ5kwAPD.Vkci31
    enable password test
    !
    no aaa new-model
    memory-size iomem 5
    !
    !
    ip cef
    ip domain name test.edu
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    ! 
    !
    !
    !
    !
    interface FastEthernet0/0
     ip address 192.168.1.1 255.255.255.0
     duplex auto
     speed auto
    !
    interface FastEthernet0/1
     no ip address
     shutdown
     duplex auto
     speed auto
    !
    !
    ip http server
    no ip http secure-server
    !
    !
    !
    cdp timer 120
    cdp holdtime 240
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    banner motd 
    Testing banner *****
    !
    line con 0
     password test
     login
    line aux 0
     password test
     login
    line vty 0 4
     password test
     login
     transport input telnet ssh
    line vty 5 1276
     password test
     login
     transport input telnet ssh
    !
    !
    end
    

    Jacob:
    !!
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Jacob
    !
    boot-start-marker
    boot-end-marker
    !
    enable secret 5 $1$hWA2$FumWoUgYk95RbiNFFZon..
    enable password test
    !
    no aaa new-model
    memory-size iomem 5
    !
    !
    ip cef
    ip domain name jacob.edu
    ip host Jacob 192.168.2.1
    no ip dhcp use vrf connected
    ip dhcp excluded-address 192.168.2.1
    !
    ip dhcp pool test
       network 192.168.2.0 255.255.255.0
       default-router 192.168.2.1 
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    ! 
    !
    !
    !
    !
    interface FastEthernet0/0
     ip address 192.168.2.1 255.255.255.0
     duplex auto
     speed auto
    !
    interface FastEthernet0/1
     no ip address
     shutdown
     duplex auto
     speed auto
    !
    !
    ip http server
    no ip http secure-server
    !
    !
    !
    cdp timer 120
    cdp holdtime 240
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    banner login 
    Welcome to Jacob.
    banner motd 
    Welcome, please log in.
    !
    line con 0
     password test
     login
    line aux 0
    line vty 0 4
     password test
     login
     transport input telnet ssh
    line vty 5 1276
     password test
     login
     transport input telnet ssh
    !
    !
    end
    
  • EdTheLadEdTheLad Member Posts: 2,111 ■■■■□□□□□□
    Connected fast ethernet interfaces are not in the same subnet!
    Networking, sometimes i love it, mostly i hate it.Its all about the $$$$
  • JacobGatesJacobGates Member Posts: 33 ■■□□□□□□□□
    EdTheLad wrote: »
    Connected fast ethernet interfaces are not in the same subnet!
    so wait... even though they are two different routers they have to be in the same subnet? so one router's fast ethernet should be 192.168.1.x and the other routers fast ethernet should be 192.168.1.y?

    edit: Okay so I did what I described above (Anna set to 192.168.1.1 and Jacob set to 192.168.1.2) and it worked. Both ping and telnet. But now I have a new question. Why do both have to be in the same subnet? What if I wanted to ping and telnet across subnets. Why can I ping from my computer to another server across the world? Of course they are not in the same subnet.
  • davenulldavenull Member Posts: 173 ■■■□□□□□□□
    Think of subnet as a country and router as its border. You tried to put 2 countries within the same border.

    You can ping a server across the world because routers along the way were configured to know the path. By default, routers wouldn't know how to reach it.
  • JacobGatesJacobGates Member Posts: 33 ■■□□□□□□□□
    davenull wrote: »
    Think of subnet as a country and router as its border. You tried to put 2 countries within the same border.

    You can ping a server across the world because routers along the way were configured to know the path. By default, routers wouldn't know how to reach it.
    Oh okay, so I am assuming I will learn later how to configure the routers to know the paths later so I can ping outside subnets, right? Just for now I need to stick to the same subnet.
  • davenulldavenull Member Posts: 173 ■■■□□□□□□□
    Yes, later you'll get to static routing and then routing protocols. For now, just remember that every interface on a router is a separate network, however, if 2 routers are directly connected the subnets on both interfaces have to be the same.
  • JacobGatesJacobGates Member Posts: 33 ■■□□□□□□□□
    davenull wrote: »
    Yes, later you'll get to static routing and then routing protocols. For now, just remember that every interface on a router is a separate network, however, if 2 routers are directly connected the subnets on both interfaces have to be the same.
    Okay! great, thank you so much for your help. Whew, one more step closer.
  • davenulldavenull Member Posts: 173 ■■■□□□□□□□
    No problem! I'd also recommend reviewing what broadcast domain is, because that's what the 'country' analogy is about.
  • JacobGatesJacobGates Member Posts: 33 ■■□□□□□□□□
    davenull wrote: »
    No problem! I'd also recommend reviewing what broadcast domain is, because that's what the 'country' analogy is about.
    Oh yeah I remember broadcast domain. So all these routers in the same subnet are now in the same broadcast domain then? I guess I'm still working on putting all this information together in my head.
  • davenulldavenull Member Posts: 173 ■■■□□□□□□□
    Not really, a router itself can't belong to a broadcast domain, just like a border doesn't belong to either country. However, a router's interface can and does belong to a broadcast domain. An router's interface is where the broadcast domain ends, so to say.

    Think of space between routers as a broadcast domain that has to have the same subnet, while the router itself being just a border device.
  • JacobGatesJacobGates Member Posts: 33 ■■□□□□□□□□
    davenull wrote: »
    Not really, a router itself can't belong to a broadcast domain, just like a border doesn't belong to either country. However, a router's interface can and does belong to a broadcast domain. An router's interface is where the broadcast domain ends, so to say.

    Think of space between routers as a broadcast domain that has to have the same subnet, while the router itself being just a border device.
    Okay, I think I understand. This is all new to me so I will just do a lot of labs until I can be sure I understand it completely.
Sign In or Register to comment.