My head hurts!!

billybob01billybob01 Member Posts: 504
i still have an issue with Ghost 8.3 clients not showing up on the console so i cant even get to the stage of choosing multicast or direct broadcast for imaging machines. I placed 2 machines on the same subnet as the server ( giving them both static ip`s) and they showed up and cloned fine. My issue is with the machines on different subnets to the server. The network company who installed the switches have given me details on configuring the core switches which i have done and all edge switches ( they are all identical make and model) are L3 switches and have IGMP Snooping turned on by default so as you can see i`m kinda up against a brick wall with no more ideas. Has anyone any ideas that i can try before bringing in the netwwork guys who will cost a fortune.


  • sprkymrksprkymrk Member Posts: 4,884 ■■■□□□□□□□

    Sorry you've been having so much trouble here, but maybe we can finally nail this down. Since everything works fine on the same subnet, let's assume you have Ghost configured correctly and the problem lies in your layer 3 switches (or routers) that divide your subnets. Ghostcast works with multicast by default, so your layer 3 devices must be configured to allow multicast traffic - I think you said you already did that, and it seems that you can't even get to the point of attempting multicast because you can't get the client to appear in the console.

    I finally found this document that I think should help you get things worked out, let me know if it helps.
    All things are possible, only believe.
  • WanBoy67WanBoy67 Member Posts: 225
    It would seem to be an issue with your switches/configuration (with details from your previous post) but without specifics it's hard to say for sure, but I think you need to whip out Wireshark to see what traffic is or isn't going on (on the problem subnet, your core switches, outer switches).

    Were you able to clone machines on the other subnet before the new switches were installed?

    You can ping everything in sight across the two subnets?
    Yes we can, yes we can...
  • billybob01billybob01 Member Posts: 504
    i have downloaded wireshark but i have never used this product before so i would`nt know what i am looking for!! or how to use it.

    I have contacted our network gurus who have suggested that the firmware be upgraded on our core switches and all other switches. They sent me details of how to configure the 2 core switches to enable multicast and they confirmed that this has been successful. All the other switches being Layer 3 have IGMP Snooping on by default, so i dont need to do anything with these. We dont have routers on our network as the Layer 3 switches manage themselves, so i am happy that our network is setup correctly apart from the firmware upgrade, but i cant see that it would make a difference. But i`ll try as i am out of ideas. Thanks for the link guys.
  • dtlokeedtlokee Member Posts: 2,378 ■■■■□□□□□□
    IGMP Snooping is not multicast routing. By default a Cisco (if that's what you're using) Router or L3 switch will not forward multicast packets from one interface to another, or from one VLAN to another. I think you problem lies in the configuration of multicast routing since you say it works on the local subnet but not others.
    The only easy day was yesterday!
  • billybob01billybob01 Member Posts: 504
    we use Allied telesys AT 8848 switches and 2 core switches AT9924T and one odd switch thats a Netgear GSM 7225. According to the guys who installed our network (before my time) all these switches have IGMP enabled by default.
  • billybob01billybob01 Member Posts: 504
    Many thanks wanboy67.
  • WanBoy67WanBoy67 Member Posts: 225
    No problem. Did you get it sorted?
    Yes we can, yes we can...
  • billybob01billybob01 Member Posts: 504
    not yet as its the weekend but will let you know next week.
  • billybob01billybob01 Member Posts: 504
    Just a stab in the dark guys, just incase anyone knows this, but i am still reading into all this and came across this bit from the switch manual:

    "IGMP must be enabled on an interface before it can send or receive IGMP
    messages on the interface. If DVMRP is used for multicast routing, IGMP must
    also be enabled on interfaces that DVMRP uses. To enable or disable IGMP on
    an interface, use the commands:"
    enable ip igmp interface=interface

    It states that IGMP must be enabled on the "interface" would this be the vlans that i have set up on the core switches? Core switch setup below:

    Iam almost there but getting bogged down with the technical stuff.

    add pim interface=vlan1
    add pim interface=vlan2
    add pim interface=vlan3
    add pim interface=vlan4
    add pim interface=vlan5
    add pim interface=vlan6
    add pim interface=vlan7
    add pim interface=vlan8
    add pim interface=vlan9
    add pim interface=vlan10
    add pim bsrcandidate interface=vlan1
    add pim rpcandidate group= mask= interface=vlan1
    disable pim bsmsecuritycheck
    enable pim

    ena ip igmp
    set ip igmp que=5
    set ip igmp timeo=80
    ena ip igmp int=vlan1
    ena ip igmp int=vlan2
    ena ip igmp int=vlan3
    ena ip igmp int=vlan4
    ena ip igmp int=vlan5
    ena ip igmp int=vlan6
    ena ip igmp int=vlan7
    ena ip igmp int=vlan8
    ena ip igmp int=vlan9
    ena ip igmp int=vlan10
  • WanBoy67WanBoy67 Member Posts: 225
    If you look at Page 7 near the bottom it says you need a special feature license to enable PIM. I don't think you need to use PIM, enabling IGMP for the specific VLANs I would think should be enough if it hasn't been enabled so far. I wouldn't suggest any wholesale changes across the board, one change at a time. But check what's configured first.

    show vlan=all
    show igmpsnooping
    show ip igmp
    then enable ip igmp interface=number of VLAN

    Don't bring down the network! icon_lol.gif
    Yes we can, yes we can...
  • billybob01billybob01 Member Posts: 504
    This is what has caused me all the confusion. I emailed our Network specialist who came in and installed the switches some time ago and he replied with what i needed to configure to use multicast. The info i posted earlier was what he suggested i do on both my core switches and do nothing else on the other switches as he pointed out that igmp snooping is already enabled by default, but what about enabling igmp? i thought to myself. So i made these changes on the core switches which were successful as ststed after each change but still nothing works with ghost. He also said that upgrading all switches tothe latest software release was vital to have multicast working, but iam unsure this is the case. When i made the changes i saved the config under a different name so i still have the original config to switch back to. Do you think i should enable IGMP on the other switches and get rid of the PIM on both core switches?
  • WanBoy67WanBoy67 Member Posts: 225
    Well if you don't have a specific license for PIM functionality, you can include it in the configs but the switch will probably just ignore it anyway. Wherever the IGMP traffic is meant to be going, IGMP should be enabled, be it on the core or the other switches. According to that manual, IGMP Snooping is enabled by default on your core switches but IGMP isn't, as for your other switches I don't know. I couldn't find the manuals for those but perhaps it's a similar setup. I agree with you - upgrading to the latest software release is probably recommended, but I would doubt it's directly related to the problem (you could well be surprised as well though!)

    I'd run the show commands and check the VLAN setup and then enable IGMP on all the relevant VLANs. After that I'd pull Wireshark out if it's not working, to analyse the traffic and get a full picture of what's going on in the different segments of the network.
    Yes we can, yes we can...
  • TBLTZTBLTZ Member Posts: 49 ■■□□□□□□□□
    Your problem is ghost 8.3
  • billybob01billybob01 Member Posts: 504
    what makes you say that TBLTZ??
  • billybob01billybob01 Member Posts: 504
    You`ll be glad to know i made some changes to our switches today and Ghost server has recognised some of the vlans, and machines ( not all) are showing up on the console. Still not reognising 2 vlans though which has stumped me again, but it seems i am going in the right direction.
  • WanBoy67WanBoy67 Member Posts: 225
    What got it working in the end? icon_confused.gif
    Yes we can, yes we can...
  • billybob01billybob01 Member Posts: 504
    i had the mask wrong in the rpcandidate group. Doh!!!!!! But i still have 2 vlans out there that are not being seen by the console!! Almost there but not quite. Also many clients are still not showing even though they are in the same rooom as others that show!! When i try and install the client remotely onto a workstation thats in the same room as another workstation that has been successfully installed and showing up on the console i receive an error when i view the logs saying "Location could not be determined"!!!
Sign In or Register to comment.