need IOS for 2511 with TLC?

itdaddyitdaddy Senior MemberMember Posts: 2,089 ■■■■□□□□□□
hey guys
I have looked all over and I cannot find the right IOS to work with my limited 2511 access router. I have a current image of


but it doesnt have a TLC and I want TLC desperately to run some scripts on my access router to take care of some thing automatically.

Do you know of any IOS image I can have that works with this.
with my limited resources, I could not find the right one? Is there a 12.0 IOS that has TLC??? or another 12.1 ios image that has TLC?

flash size limitation is like 8MB only anything bigger it goes nutz ;)
thanks guys


  • mikej412mikej412 Member Posts: 10,086 ■■■■■■■■■■
    TLC as in Tender Loving Care? Or TCL as in Tool Command Language?

    TCL became available in IOS 12.3T

    The latest/greatest 2500 IOS Version is only a 12.3 version -- no TLC for you and your 2500.
    :mike: Cisco Certifications -- Collect the Entire Set!
  • itdaddyitdaddy Senior Member Member Posts: 2,089 ■■■■□□□□□□
    TLC is what I need for my 2511 mikej this is what is happening.
    Every time I want to open my tabbed sessions I have to run he clear line # command like I am not kidding 7 times per line just to allow my telnet session to take effect. Once I go through each clear line # statement on every
    telnet session line # then I can remote into each device. It sucks. I wanted to script it if I could with the TCL. It has the alias exec command in which I make a macro like program so all I have to type is c (line #) and hit enter 3 times to clear the line. My 2511 works well but the initial getting into each session is cumbersome with the clear line of each? Hey I just thought of this.

    Is there a clear line range command??? that would help vs having to clear each line so I can telnet into that device. Once I do the clear line # command the telnet session runs fine! Do I need a new 2511? but they run 300 bucks on eBay don't they?
  • tierstentiersten Member Posts: 4,505
    You could make an alias so you don't have to type out "clear line" every time.
  • jason_lundejason_lunde Member Posts: 567
    Not to question your config without even seeing it...but do you have the "no exec" command under your line configs?
  • itdaddyitdaddy Senior Member Member Posts: 2,089 ■■■■□□□□□□

    thanks bud yeah I have alias exec c clear line

    so all I have to do is type the letter c and the number like this

    c 5

    but I have to do it for 16 devices it sucks every time.


    you know I think I have

    line vty 0 4 and line con 0
    exec time-out 0 0 or no exec time-out
    logging synchronous
    privilege level 15

    is that my problem. I have to clear line for each telnet session.
    I use absolute telnet program to use multiple tabbed session of which I love! click to each session bam bam bam and can config much faster
    with the tabbed sessions vs a 52 in monitor and hundreds of windows hhaaha

    what do you think it is?
  • jason_lundejason_lunde Member Posts: 567
    you should have something like this:

    line 1 8
    no exec
    transport input all

    otherwise some exec sessions get out of control and you get that ...refused connection message. If you dont have it in there...go ahead and put it in. Then reboot your 2511 and give it a go.
  • itdaddyitdaddy Senior Member Member Posts: 2,089 ■■■■□□□□□□

    Omg dont quote me on this but " i love you man!"

    holy crap! it worked I do not have to clear l ine any more
    all my tabbed telnet session after highlighted all them and bam
    they are came in without that error. OMG!!!!!!!!!!

    I DIDNT KNOW WHAT TO DO and that fixed it no more issues man you are the man dude you are the man!
    thanks so much it worked...YUO ARE A GENIUS!!!!!!!!!!!icon_thumright.gificon_thumright.gificon_thumright.gif
Sign In or Register to comment.