Options

Mutual Redistribution Problem

JASON123JASON123 Member Posts: 57 ■■□□□□□□□□
I am trying to do mutual redistribution of rip and ospf using just route tags. The routers are connected to form a diamond. The problem that I am getting is that the router running just rip (R3) sees the routes from the ospf domain; yet, the router only running ospf (R1) doesn’t see the routes from the rip domain. I thought I had the route-maps configured correctly, but I just can’t understand why it is showing up on R1. Am I configuring the route tags wrong? Thank you very much for all your help.

R1

interface Loopback1
ip address 9.9.9.9 255.255.255.255
!
interface Ethernet0
ip address 10.0.0.2 255.255.255.252
media-type 10BaseT
!
interface Ethernet1
ip address 10.0.1.2 255.255.255.252
media-type 10BaseT

router ospf 1
log-adjacency-changes
network 9.9.9.9 0.0.0.0 area 0
network 10.0.0.0 0.0.0.3 area 0
network 10.0.1.0 0.0.0.3 area 0

R2
interface Ethernet0
ip address 10.0.0.1 255.255.255.252
no ip directed-broadcast

interface Serial1
ip address 192.168.2.2 255.255.255.252
no ip directed-broadcast
!
router ospf 1
redistribute rip subnets route-map rip2ospf
passive-interface Serial1
network 10.0.0.0 0.0.0.3 area 0
default-metric 2
!
router rip
version 2
redistribute ospf 1 route-map ospf2rip
passive-interface Ethernet0
network 192.168.2.0
default-metric 2
no auto-summary

route-map rip2ospf deny 10
match tag 200
!
route-map rip2ospf permit 20
set tag 100
!
route-map ospf2rip deny 10
match tag 100
!
route-map ospf2rip permit 20
set tag 200


R3

interface Loopback1
ip address 2.2.2.2 255.255.255.255

interface Serial0
ip address 192.168.1.1 255.255.255.252
no fair-queue
clockrate 64000
!
interface Serial1
ip address 192.168.2.1 255.255.255.252
no fair-queue
clockrate 64000

router rip
version 2
network 2.0.0.0
network 192.168.1.0
network 192.168.2.0
no auto-summary

R4

interface Ethernet0
ip address 10.0.1.1 255.255.255.252
!
interface Serial0
ip address 192.168.1.2 255.255.255.252

router ospf 1
redistribute rip subnets route-map rip2ospf
passive-interface Serial0
network 10.0.1.0 0.0.0.3 area 0
default-metric 2
!
router rip
version 2
redistribute ospf 1 route-map ospf2rip
passive-interface Ethernet0
network 192.168.1.0
default-metric 2
no auto-summary

route-map rip2ospf deny 10
match tag 200
!
route-map rip2ospf permit 20
set tag 100
!
route-map ospf2rip deny 10
match tag 100
!
route-map ospf2rip permit 20
set tag 200



R1 show ip route

Gateway of last resort is not set

9.0.0.0/32 is subnetted, 1 subnets
C 9.9.9.9 is directly connected, Loopback1
10.0.0.0/30 is subnetted, 2 subnets
C 10.0.0.0 is directly connected, Ethernet0
C 10.0.1.0 is directly connected, Ethernet1


R3 show ip route

Gateway of last resort is not set

2.0.0.0/32 is subnetted, 1 subnets
C 2.2.2.2 is directly connected, Loopback1
9.0.0.0/32 is subnetted, 1 subnets
R 9.9.9.9 [120/2] via 192.168.2.2, 00:00:24, Serial1
[120/2] via 192.168.1.2, 00:00:07, Serial0
10.0.0.0/30 is subnetted, 2 subnets
R 10.0.0.0 [120/2] via 192.168.2.2, 00:00:24, Serial1
[120/2] via 192.168.1.2, 00:00:07, Serial0
R 10.0.1.0 [120/2] via 192.168.2.2, 00:00:24, Serial1
[120/2] via 192.168.1.2, 00:00:07, Serial0
192.168.1.0/30 is subnetted, 1 subnets
C 192.168.1.0 is directly connected, Serial0
192.168.2.0/30 is subnetted, 1 subnets
C 192.168.2.0 is directly connected, Serial1

Comments

  • Options
    EdTheLadEdTheLad Member Posts: 2,111 ■■■■□□□□□□
    Hi Jason, ive been playing around with these tags on afew 2500's i have in my office and i've noticed a problem when redistributing.For some reason when i create a route-map and only have a match tag 100, the router ends up matching everything as if the match tag 100 wasnt there.
    The set command is working correctly! as when i check the routes in the routing table they have the tag.

    So in your config since you have on R2

    route-map rip2ospf deny 10
    match tag 200

    Everything is getting denied.I bet if you switch the numbers of the permit to 10 and deny to 20 you will all routes,but still this isnt what u want as this bigs you back to the mutual redist problem.

    If you want this mutual redistribution to function you will have to use
    match ip route-source instead of match tag.
    Seems like an IOS bug to me, but i wont be able to check on my 2600's till next week.
    Networking, sometimes i love it, mostly i hate it.Its all about the $$$$
  • Options
    JASON123JASON123 Member Posts: 57 ■■□□□□□□□□
    Thanks ed_the_lad. I also noticed that when I take out route-map rip2ospf deny 10 that the routes get redistributed but it caused the routes to flap. I'll try and check the match ip route-source when I get back to the lab. Thanks for all your help. I was hoping that I wasn't going crazy!! I'll also check to see how it works on the 4500 routers to see if that does the trick.

    Jason
Sign In or Register to comment.