GSN3 virtualized or Saas?

mguymguy Member Posts: 167 ■■■□□□□□□□
I want to run GSN3 in my work computer, unfortunately I need WINPCAP.dll installed and I don't have enough access to install this.

How else can I circumvent this? Could I run a virtualized box within my box so I can use this application or is there remote servers where I can use this application?

Thanks for the advise


  • cpartincpartin Member Posts: 84 ■■□□□□□□□□
    I haven't tried running it in a VM but I can't think of any reason why that wouldn't work.

    There is a pre-built linux VMware image with GNS3 already installed available for download @ GNS3 Workbench | RedNectar's Blog if you don't feel like building one out yourself.
  • TehToGTehToG Member Posts: 194
    You probably aren't 'just' missing that dll. One of the prerequisite programs for GNS3 to work requires elevation to install so that's why it doesn't work. If you want to run it on your work computer than ask for ITs help. If they say no (which they rightly should) then you have to live with that.
  • neoteslaneotesla Member Posts: 37 ■■□□□□□□□□
    I also haven't had GNS3 running in a VM, but I suspect there could be issue with resources. GNS3 can be pretty hungry (admittedly, I only run it on older gear).

    Another reason that GNS3 can have a limited functionality if you don't have admin/root access, is that it cannot access the network adapters (I'm talking about the physical machine here).

    If you're left with the possibility to choose the boot media on your work PC, perhaps you could bring your own external HDD with a (let's say) Ubuntu install on it. Then boot from that, and you can run everything nicely. However, I suspect your Bios could also be tied down and won't allow you to choose the boot media.
Sign In or Register to comment.