I have a question about using putty to config a router.

Night GoatNight Goat Member Posts: 5 ■□□□□□□□□□
Hello everyone, this is my first post and I am not too sure if this is the right sub-forum for this question or not. I have managed to find a good deal on a CCNA lab kit that included 3 1841s with the dual serial WIC cards and IOS 15, two 2950s and a 3550 along with a bunch of straight through, crossover, and rollover cables as well as a rack all for under $300 and all in excellent, like new condition.

My problem is that when I try to connect to a router using an old PC that is running Lubuntu 14.4 via putty, I get a message saying "putty cant open serial port". I am new to Linux but I am fairly decent with the CLI but I am not sure how to find my serial port info. I ran dmesg command and I am not entirely sure if the info is in the output since I don't really know what I am looking for and even if I did I am not sure how to fix this problem. Does anyone have any solution or a starting point?

Edit: I also made sure the cable is in the console port of the router and that the serial cable is properly attached to the pc so this is not the problem.


  • davenulldavenull Member Posts: 173 ■■■□□□□□□□
    I used minicom instead of putty on my arch linux laptop, see if it works for you. Look here for clues:


    Edit: also, kde terminal is fantastic with GNS3, supports multitabbing and there's an option to send the command you are typing to multiple tabs at the same time.
  • EdTheLadEdTheLad Member Posts: 2,111 ■■■■□□□□□□
    Assuming your cable is correct and you have a built in serial port i.e. no serial usb adapter with driver issues.
    Sounds like you are trying to open the wrong com port. On windows under device manager its possible to see which com port the pc is using, there should be a way under linux, otherwise just reconfig the com port on putty from 1 through to about 8 and check each one.
    Networking, sometimes i love it, mostly i hate it.Its all about the $$$$
  • Night GoatNight Goat Member Posts: 5 ■□□□□□□□□□
    My com port is on the motherboard and there is only one, so no, I am not using an adapter. The com port is ttyS0 and that is what is shown by default when I opened putty. If I run the command dmesg | grep tty the output is:
    [ 0.763063] 00:07: ttyS0 at I/O 0x3f8 (irq = 4, base_baud = 115200) is a 1655.

    I know that in order to use S0 as a console connection the IRQ 4 cannot be shared with other devices. I dont know how to find out if this is even relevant though. Ithink it has something to do with the speed. putty says 9600 but the dmesg says 115200, although I am not sure if I am reading this right.
  • davenulldavenull Member Posts: 173 ■■■□□□□□□□
    Using Putty in linux is frowned upon in certain circles. It may or may not be the reason of your problem but I'd try a linux-native utility first, like the one I suggested earlier.
  • Night GoatNight Goat Member Posts: 5 ■□□□□□□□□□
    I have tried minicom a few hours ago and I am sure that it would work but it won't let me save my changes even though I am in the sudo/admin group.
  • tasman35tasman35 Member Posts: 40 ■■□□□□□□□□
    I also use linux to connect to my home cisco home lab. Go with minicom It takes some reading to get it working right but it is well worth it in the long run...You do have open it up then make the changes that you want to use to comunicate to cisco routers and switches. Just make sure you save them as default and i also save them as minicom cisco. If you do some searching around there are lots of write ups on the net to help you....But like i said minicom is what i use easy to set up and just works.
  • Night GoatNight Goat Member Posts: 5 ■□□□□□□□□□
    As I said, I can't save the changes that I make for some reason. I am on the admin/root/wheel group though. Anyone know why?
  • tasman35tasman35 Member Posts: 40 ■■□□□□□□□□
    Tell us how you using the linux....?
  • Night GoatNight Goat Member Posts: 5 ■□□□□□□□□□
    I am not sure I understand what you mean by how I am using it. I have lubuntu on an old desktop, I chose this OS because it is light on system requirements and free. I have no special configuration or use other then as a console terminal for the routers when I get to that point.

    EDIT: I figured out the problem ... I was logged into the guest account for some reason, I need to pay attention next time. I would still like to get putty working just because I feel like I gotta tie up loose ends and I need closure and all that other nonsense.
Sign In or Register to comment.