router commands

sleemiesleemie Posts: 109Member
Okay, i'm new to fooling around with routers and all the resources I've seen on this site and other places don't really seem to be consistent with a beginning place for learning this stuff. They all throw something different at you and none of them really take you threw the steps first do this, then that then this and so on. I realize there are a lot of differents ways you can go once you log in, but none of them really tell me what I should be learning and nothing really leading you step by step from the basics to the more advanced. Anyways...

I'm connected to a 2800 through hyper terminal and after it finishes booting up it tells you to hit enter to begin, then it prompts you for a user name and password and tells you the default is cisco and cisco and then gives you the command for changing it. I managed to create a new ID and password, but one of the guides I'm looking at mentions the user EXEC mode and priveliged EXEC mode and that when in user exec I should see the router name and a > sign and # for privlidged, but after logging in there are no symbols at all. Just the router name: myrouter I type enable as instructed by the guide and it just returns to the prompt. I then do conf term and then is says yourname(config)# I then try enable again and it says incomplete command. seeing the # sign I guess tells me i'm in privileged exec mode, but I've always gotten that even before I ever tried the enable command. So, the question is....

1. am I really in priv exec mode since the # appears after entering the conf term command? If so, it came that way by default because from the very beginning I've gotten that, which is contradictory to everything i've read.
2. howcome I have no symbol after the prompt?
3. shouldn't I have the # symbol at the prompt if in priv exec mode and not just in config mode?
4. at what point am I supposed to use the enable command? at the prompt or in config mode?
5. why does it say "yourname(config)" when going in to the config term command? the user id I created is "routeuser" and I've also used the "cisco" ID, shouldn't the user name or router name appear?
6. how do I step back one level at a time? the cntrl Z takes you all the way back to the prompt?
7. What command do I use to check which ID I'm logged in as? of course I should know who I'm logged in as, but after switching back and forth between the users I would like to be able to check and verify which one i'm logged in as.

I know this all sounds kinda convaluted, but that's how my brain is right now with this stuff.

Comments

  • EricOEricO Posts: 93Member ■■□□□□□□□□
    Do a "show run" from priveledged exec and post the output here. It sounds like your router could be configured to use AAA from a local database. With AAA, in many cases, a user already has a preconfigured prveidge level. I'll confess that I've not used anything as new as a 2800, so I'm not familiar with its default config.
  • sleemiesleemie Posts: 109Member
    I've got a 2600 to work on also, would I be better off using that since it may be more in line of what they're trying to teach since it's not as new?
  • EricOEricO Posts: 93Member ■■□□□□□□□□
    From my perspective the 2600 would be a better choice for the current test.
  • sleemiesleemie Posts: 109Member
    Here's the config info from the 2800, but may be moot cuz I'll probably go more with the 2600 in preparation for the test, although I'll still be working on the 2800 some for work.

    any light you can shed on this would be helpful...

    myroutershow run
    Building configuration...

    Current configuration : 1874 bytes
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname yourname
    !
    boot-start-marker
    boot-end-marker
    !
    logging buffered 51200 warnings
    !
    no aaa new-model
    !
    resource policy
    !
    prompt myrouter
    ip subnet-zero
    !
    !
    ip cef
    !
    !
    ip domain name yourdomain.com
    !
    username cisco privilege 15 secret 5 $1$K3ed$RL7lPFfzIycSM30J.j8Rd1
    !
    !
    !
    interface GigabitEthernet0/0
    description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$
    ip address 10.10.10.1 255.255.255.248
    duplex auto
    speed auto
    !
    interface GigabitEthernet0/1
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    interface Serial0/0/0
    no ip address
    shutdown
    clock rate 2000000
    !
    interface Serial0/0/1
    no ip address
    shutdown
    clock rate 2000000
    !
    ip classless
    !
    ip http server
    ip http authentication local
    ip http timeout-policy idle 5 life 86400 requests 10000
    !
    !
    control-plane
    !
    banner login ^C
    Cisco Router and Security Device Manager (SDM) is installed on this device.
    This feature requires the one-time use of the username "cisco"
    with the password "cisco".

    Please change these publicly known initial credentials using SDM or the IOS CLI.

    Here are the Cisco IOS commands.

    username <myuser> privilege 15 secret 0 <mypassword>
    no username cisco

    Replace <myuser> and <mypassword> with the username and password you want to use
    .

    For more information about SDM please follow the instructions in the QUICK START

    GUIDE for your router or go to http://www.cisco.com/go/sdm
    ^C
    !
    line con 0
    login local
    line aux 0
    line vty 0 4
    privilege level 15
    login local
    transport input telnet
    line vty 5 15
    privilege level 15
    login local
    transport input telnet
    !
    scheduler allocate 20000 1000
    !
    end
  • EricOEricO Posts: 93Member ■■□□□□□□□□
    Well there you have it. You have your command prompt manually set in your configuration. The configuration you have on your console references a local database. I have to run to a hair cut appointment right now , but I will post you command fixes up here tonight. That is if one of my esteemed colleagues here doesn't beat me to it.
  • EricOEricO Posts: 93Member ■■□□□□□□□□
    Ok. icon_redface.gif For the purposes of CCNA study make the following modifications to your config:

    en
    conf t
    enable secret cisco
    line con 0
    no login local
    login
    password cisco
    exit
    line vty 0 4
    no privilege level 15
    no login local
    login
    password cisco
    exit
    exit
    copy run start
  • sleemiesleemie Posts: 109Member
    thanx for the info...could you tell me what all that means?
Sign In or Register to comment.