Dial-peers via T1 crossover

nagennagen Member Posts: 23 ■□□□□□□□□□
Hi,
Trying to connect two analogue phone sets via T1 crossover cable but so far no luck. Any help to find a solution will be much appreciated.
Thanks
Topology:
Phone x1111
fxs-(R1)-T1
crossover T1
T1-(R2)-fxs
x2222 Phone
Home made T1 cross over cable
1 – 4
2 – 5
4 – 1
5 – 2
Almost same config on Router 2 (R2_3725) except clock source for T1 is set to Line
R1_3640#sh run
controller T1 1/0
framing esf
clock source internal
linecode b8zs
ds0-group 0 timeslots 1-8 type fxo-loop-start
ds0-group 1 timeslots 9-16 type e&m-wink-start
!
voice-port 1/0:0
output attenuation 0
voice-port 1/0:1
voice-port 3/0/0
voice-port 3/0/1
voice-port 3/1/0
voice-port 3/1/1
!
dial-peer voice 1111 pots
destination-pattern 1111
port 3/0/0
!
dial-peer voice 1000 pots
destination-pattern 2222
port 1/0:0
forward-digits all

R1_3640#sh voice port sum
IN OUT
PORT CH SIG-TYPE ADMIN OPER STATUS STATUS EC
============== == ============ ===== ==== ======== ======== ==
1/0:0 01 fxo-ls up dorm idle on-hook y
1/0:0 02 fxo-ls up dorm idle on-hook y
1/0:0 03 fxo-ls up dorm idle on-hook y
1/0:0 04 fxo-ls up dorm idle on-hook y
1/0:0 05 fxo-ls up dorm idle on-hook y
1/0:0 06 fxo-ls up dorm idle on-hook y
1/0:0 07 fxo-ls up dorm idle on-hook y
1/0:0 08 fxo-ls up dorm idle on-hook y
1/0:1 09 e&m-wnk up dorm idle idle y
1/0:1 10 e&m-wnk up dorm idle idle y
1/0:1 11 e&m-wnk up dorm idle idle y
1/0:1 12 e&m-wnk up dorm idle idle y
1/0:1 13 e&m-wnk up dorm idle idle y
1/0:1 14 e&m-wnk up dorm idle idle y
1/0:1 15 e&m-wnk up dorm idle idle y
1/0:1 16 e&m-wnk up dorm idle idle y
3/0/0 -- fxs-ls up dorm on-hook idle y
3/0/1 -- fxs-ls up dorm on-hook idle y
3/1/0 -- fxo-ls up dorm idle on-hook y
3/1/1 -- fxo-ls up dorm idle on-hook y

R1_3640#sh controllers t1 1/0
T1 1/0 is up.
Applique type is Channelized T1
Cablelength is long gain36 0db
No alarms detected.
alarm-trigger is not set
Soaking time: 3, Clearance time: 10
AIS State:Clear LOS State:Clear LOF State:Clear
Version info Firmware: 20051006, FPGA: 20, spm_count = 0
Framing is ESF, Line Code is B8ZS, Clock Source is Internal.
CRC Threshold is 320. Reported from firmware is 320.
Data in current interval (729 seconds elapsed):
0 Line Code Violations, 0 Path Code Violations
0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
Data in Interval 1:
4 Line Code Violations, 9798 Path Code Violations
4 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
4 Errored Secs, 0 Bursty Err Secs, 4 Severely Err Secs, 501 Unavail Secs
Total Data (last 1 15 minute intervals):
4 Line Code Violations, 9798 Path Code Violations,
4 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,
4 Errored Secs, 0 Bursty Err Secs, 4 Severely Err Secs, 501 Unavail Secs

Comments

  • nice343nice343 Member Posts: 391
    check the voice config on the 1000 dial peer.

    it should be
    dial-peer voice 1000 voip
    destination-pattern 2222
    session target ipv4:192.168.1.1
    
    assuming 192.168.1.1 is the ip address of the remote router
    My daily blog about IT and tech stuff
    http://techintuition.com/
  • nagennagen Member Posts: 23 ■□□□□□□□□□
    nice343 wrote:
    check the voice config on the 1000 dial peer.

    it should be
    dial-peer voice 1000 voip
    destination-pattern 2222
    session target ipv4:192.168.1.1
    
    assuming 192.168.1.1 is the ip address of the remote router

    Thanks for your reply,
    but I am trying to simulate PSTN, trying to route call through digital T1 CAS.
    It should be pots and ports based. I don't think there is a need of IP address cause IP WAN is broken in this scenario.
  • LuckycharmsLuckycharms Member Posts: 267
    As for what is not exactly working I don't know, primarily because I don't know the problems...Is it one way calling?? are you even seeing the call legs being established?

    I would also look into timing on you T1.... Looks like you might be having problems.


    4 Line Code Violations, 9798 Path Code Violations
    4 Errored Secs, 0 Bursty Err Secs, 4 Severely Err Secs, 501 Unavail Secs
    The quality of a book is never equated to the number of words it contains. -- And neither should be a man by the number of certifications or degree's he has earned.
  • nagennagen Member Posts: 23 ■□□□□□□□□□
    As for what is not exactly working I don't know, primarily because I don't know the problems...Is it one way calling?? are you even seeing the call legs being established?

    I would also look into timing on you T1.... Looks like you might be having problems.


    4 Line Code Violations, 9798 Path Code Violations
    4 Errored Secs, 0 Bursty Err Secs, 4 Severely Err Secs, 501 Unavail Secs

    Well it's a two way calling, I cleared the error log counter, so there is no more error and interface is in up state but still no calls going through.
  • tech-airmantech-airman Member Posts: 953
    nagen,
    nagen wrote:
    Hi,
    Trying to connect two analogue phone sets via T1 crossover cable but so far no luck. Any help to find a solution will be much appreciated.
    Thanks

    Have you verified that you're getting a dialtone on both of your phones?
    nagen wrote:
    Topology:
    Phone x1111
    fxs-(R1)-T1
    crossover T1
    T1-(R2)-fxs
    x2222 Phone
    Home made T1 cross over cable
    1 – 4
    2 – 5
    4 – 1
    5 – 2
    Almost same config on Router 2 (R2_3725) except clock source for T1 is set to Line
    R1_3640#sh run
    controller T1 1/0
    framing esf
    clock source internal
    linecode b8zs
    ds0-group 0 timeslots 1-8 type fxo-loop-start
    ds0-group 1 timeslots 9-16 type e&m-wink-start
    !
    voice-port 1/0:0
    output attenuation 0
    voice-port 1/0:1
    voice-port 3/0/0
    voice-port 3/0/1
    voice-port 3/1/0
    voice-port 3/1/1
    !
    dial-peer voice 1111 pots
    destination-pattern 1111
    port 3/0/0
    !
    dial-peer voice 1000 pots
    destination-pattern 2222
    port 1/0:0
    forward-digits all

    R1_3640#sh voice port sum
    IN OUT
    PORT CH SIG-TYPE ADMIN OPER STATUS STATUS EC
    ============== == ============ ===== ==== ======== ======== ==
    1/0:0 01 fxo-ls up dorm idle on-hook y
    1/0:0 02 fxo-ls up dorm idle on-hook y
    1/0:0 03 fxo-ls up dorm idle on-hook y
    1/0:0 04 fxo-ls up dorm idle on-hook y
    1/0:0 05 fxo-ls up dorm idle on-hook y
    1/0:0 06 fxo-ls up dorm idle on-hook y
    1/0:0 07 fxo-ls up dorm idle on-hook y
    1/0:0 08 fxo-ls up dorm idle on-hook y
    1/0:1 09 e&m-wnk up dorm idle idle y
    1/0:1 10 e&m-wnk up dorm idle idle y
    1/0:1 11 e&m-wnk up dorm idle idle y
    1/0:1 12 e&m-wnk up dorm idle idle y
    1/0:1 13 e&m-wnk up dorm idle idle y
    1/0:1 14 e&m-wnk up dorm idle idle y
    1/0:1 15 e&m-wnk up dorm idle idle y
    1/0:1 16 e&m-wnk up dorm idle idle y
    3/0/0 -- fxs-ls up dorm on-hook idle y
    3/0/1 -- fxs-ls up dorm on-hook idle y
    3/1/0 -- fxo-ls up dorm idle on-hook y
    3/1/1 -- fxo-ls up dorm idle on-hook y

    R1_3640#sh controllers t1 1/0
    T1 1/0 is up.
    Applique type is Channelized T1
    Cablelength is long gain36 0db
    No alarms detected.
    alarm-trigger is not set
    Soaking time: 3, Clearance time: 10
    AIS State:Clear LOS State:Clear LOF State:Clear
    Version info Firmware: 20051006, FPGA: 20, spm_count = 0
    Framing is ESF, Line Code is B8ZS, Clock Source is Internal.
    CRC Threshold is 320. Reported from firmware is 320.
    Data in current interval (729 seconds elapsed):
    0 Line Code Violations, 0 Path Code Violations
    0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
    0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
    Data in Interval 1:
    4 Line Code Violations, 9798 Path Code Violations
    4 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
    4 Errored Secs, 0 Bursty Err Secs, 4 Severely Err Secs, 501 Unavail Secs
    Total Data (last 1 15 minute intervals):
    4 Line Code Violations, 9798 Path Code Violations,
    4 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,
    4 Errored Secs, 0 Bursty Err Secs, 4 Severely Err Secs, 501 Unavail Secs
  • nagennagen Member Posts: 23 ■□□□□□□□□□
    nagen,
    nagen wrote:
    Hi,
    Trying to connect two analogue phone sets via T1 crossover cable but so far no luck. Any help to find a solution will be much appreciated.
    Thanks

    Have you verified that you're getting a dialtone on both of your phones?
    nagen wrote:
    Topology:
    Phone x1111
    fxs-(R1)-T1
    crossover T1
    T1-(R2)-fxs
    x2222 Phone
    Home made T1 cross over cable
    1 – 4
    2 – 5
    4 – 1
    5 – 2
    Almost same config on Router 2 (R2_3725) except clock source for T1 is set to Line
    R1_3640#sh run
    controller T1 1/0
    framing esf
    clock source internal
    linecode b8zs
    ds0-group 0 timeslots 1-8 type fxo-loop-start
    ds0-group 1 timeslots 9-16 type e&m-wink-start
    !
    voice-port 1/0:0
    output attenuation 0
    voice-port 1/0:1
    voice-port 3/0/0
    voice-port 3/0/1
    voice-port 3/1/0
    voice-port 3/1/1
    !
    dial-peer voice 1111 pots
    destination-pattern 1111
    port 3/0/0
    !
    dial-peer voice 1000 pots
    destination-pattern 2222
    port 1/0:0
    forward-digits all

    R1_3640#sh voice port sum
    IN OUT
    PORT CH SIG-TYPE ADMIN OPER STATUS STATUS EC
    ============== == ============ ===== ==== ======== ======== ==
    1/0:0 01 fxo-ls up dorm idle on-hook y
    1/0:0 02 fxo-ls up dorm idle on-hook y
    1/0:0 03 fxo-ls up dorm idle on-hook y
    1/0:0 04 fxo-ls up dorm idle on-hook y
    1/0:0 05 fxo-ls up dorm idle on-hook y
    1/0:0 06 fxo-ls up dorm idle on-hook y
    1/0:0 07 fxo-ls up dorm idle on-hook y
    1/0:0 08 fxo-ls up dorm idle on-hook y
    1/0:1 09 e&m-wnk up dorm idle idle y
    1/0:1 10 e&m-wnk up dorm idle idle y
    1/0:1 11 e&m-wnk up dorm idle idle y
    1/0:1 12 e&m-wnk up dorm idle idle y
    1/0:1 13 e&m-wnk up dorm idle idle y
    1/0:1 14 e&m-wnk up dorm idle idle y
    1/0:1 15 e&m-wnk up dorm idle idle y
    1/0:1 16 e&m-wnk up dorm idle idle y
    3/0/0 -- fxs-ls up dorm on-hook idle y
    3/0/1 -- fxs-ls up dorm on-hook idle y
    3/1/0 -- fxo-ls up dorm idle on-hook y
    3/1/1 -- fxo-ls up dorm idle on-hook y

    R1_3640#sh controllers t1 1/0
    T1 1/0 is up.
    Applique type is Channelized T1
    Cablelength is long gain36 0db
    No alarms detected.
    alarm-trigger is not set
    Soaking time: 3, Clearance time: 10
    AIS State:Clear LOS State:Clear LOF State:Clear
    Version info Firmware: 20051006, FPGA: 20, spm_count = 0
    Framing is ESF, Line Code is B8ZS, Clock Source is Internal.
    CRC Threshold is 320. Reported from firmware is 320.
    Data in current interval (729 seconds elapsed):
    0 Line Code Violations, 0 Path Code Violations
    0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
    0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
    Data in Interval 1:
    4 Line Code Violations, 9798 Path Code Violations
    4 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
    4 Errored Secs, 0 Bursty Err Secs, 4 Severely Err Secs, 501 Unavail Secs
    Total Data (last 1 15 minute intervals):
    4 Line Code Violations, 9798 Path Code Violations,
    4 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,
    4 Errored Secs, 0 Bursty Err Secs, 4 Severely Err Secs, 501 Unavail Secs
    Yes, I am getting dial tone on both sets, when I dial a number I can see in debug out put that it accepts the digits.
  • mikej412mikej412 Member Posts: 10,086 ■■■■■■■■■■
    nagen wrote:
    Almost same config on Router 2 (R2_3725) except clock source for T1 is set to Line
    R1_3640#sh run
    controller T1 1/0
    framing esf
    clock source internal
    linecode b8zs
    ds0-group 0 timeslots 1-8 type fxo-loop-start
    ds0-group 1 timeslots 9-16 type e&m-wink-start
    So you're trying to connect with fxo-loop-start signaling on both ends?

    Does it work any better if you change it to fxs on one end?
    :mike: Cisco Certifications -- Collect the Entire Set!
  • nagennagen Member Posts: 23 ■□□□□□□□□□
    mikej412 wrote:
    nagen wrote:
    Almost same config on Router 2 (R2_3725) except clock source for T1 is set to Line
    R1_3640#sh run
    controller T1 1/0
    framing esf
    clock source internal
    linecode b8zs
    ds0-group 0 timeslots 1-8 type fxo-loop-start
    ds0-group 1 timeslots 9-16 type e&m-wink-start
    So you're trying to connect with fxo-loop-start signaling on both ends?

    Does it work any better if you change it to fxs on one end?

    It works absolutely fine now, Thank you very very much teacher. I really appreciate it. I am doing self study. It was a valuable learning experience for me.
  • mikej412mikej412 Member Posts: 10,086 ■■■■■■■■■■
    nagen wrote:
    I am trying to simulate PSTN, trying to route call through digital T1 CAS.
    I think I learned more by trying to figure out how to use voice routers to simulate the PSTN and PBXs then if I actually had access to different PBXs and multiple PSTN connections.

    It makes you start to understand what a PBX person is thinking, but without having to become a PBX person. icon_lol.gif
    :mike: Cisco Certifications -- Collect the Entire Set!
  • pullin-gspullin-gs Member Posts: 38 ■■□□□□□□□□
    I have two-way audio....it is the dialing that is odd.
    On the gateway with the config:
    !
    controller T1 0
    mode cas
    framing esf
    linecode b8zs
    ds0-group 0 timeslots 1-4 type fxo-loop-start

    I can dial to the gateway with the config:
    !
    controller T1 0
    mode cas
    framing esf
    linecode b8zs
    ds0-group 0 timeslots 1-4 type fxs-loop-start

    I can not dial the other way though unless I configure TWO ds0-groups....one FXS, and another FXO group for both gateways.

    Thanks
  • pullin-gspullin-gs Member Posts: 38 ■■□□□□□□□□
    pullin-gs wrote:
    I have two-way audio....it is the dialing that is odd.
    On the gateway with the config:
    !
    controller T1 0
    mode cas
    framing esf
    linecode b8zs
    ds0-group 0 timeslots 1-4 type fxo-loop-start

    I can dial to the gateway with the config:
    !
    controller T1 0
    mode cas
    framing esf
    linecode b8zs
    ds0-group 0 timeslots 1-4 type fxs-loop-start

    I can not dial the other way though unless I configure TWO ds0-groups....one FXS, and another FXO group for both gateways.

    Strange.
    FXO on both ends does not work at all
    FXS on both ends does not work at all.

    However, e&m-wink-start works fine both ways

    Thanks
  • FlyingputFlyingput Virtual USAMember Posts: 114 ■■■□□□□□□□
    I am way late to this thread....
    But today I was listening to Jeremy's GWGK video for reference on something, I happened to catch him saying "when configuring T1 CAS, fxo-fxo or fxs-fxs...." :D
    fxo-fxs is the answer.
    mikej412 wrote: »
    I think I learned more by trying to figure out how to use voice routers to simulate the PSTN and PBXs then if I actually had access to different PBXs and multiple PSTN connections.

    It makes you start to understand what a PBX person is thinking, but without having to become a PBX person. icon_lol.gif
Sign In or Register to comment.