NTLDR not found on Windows 98????

s0c0s0c0 Posts: 76Member ■■□□□□□□□□
So I am studying for the OS side of the A plus. I installed windows 98 the other day seeing as I've never used it before (went from 95 to 2000 pro). I put it on a spare hard drive, install went fine. I boot the drive the next day and get NTLDR not found. From my reading Windows 98 does not use the NTLDR as the boot loader, I forget what it does use, but I know it's not NTLDR. So my book contains nothing about resolving this. I went into the command prompt and tried rewritting the mbr with 'fdisk /mbr' (which may only work with NT based systems). After this did nothing to fix the problem I did an F&R, same problem.

It sounds like I bought a bad HDD. It sounds like the MBR is not being rewritten correctly when I install the O.S. Any ideas on how to fix this or do I maybe have a bad hard drive. Thanks.

Comments

  • jescabjescab Posts: 1,321Inactive Imported Users
    Make sure the hard drives are jumpered correctly. I had this message on an in-correctly jumpered hard drive once.
    GO STEELERS GO - STEELERS RULE
  • s0c0s0c0 Posts: 76Member ■■□□□□□□□□
    Good call. I didn't event think to check the jumper settings!
  • PlantwizPlantwiz Posts: 5,057Mod Mod
    I've not seen it happen with a W98 install so perhaps something else is going on here. Before I dive into that, here are some links you may find useful:

    http://www.webopedia.com/TERM/N/NTLDR.html
    http://support.microsoft.com/default.aspx?id=kb;en-us;Q314057
    http://support.microsoft.com/?kbid=255220

    1. DId you have a dual boot system at some point?
    2. Which brand of HDD do you have? You may wish to run HDD Diagnostics on it if you suspect it is failing.
    3. Check your setting in the BIOS - be certain the drive is recognized
    4. Double check cables and jumpers


    Otherwise, FDISK/mbr should have permitted you a clean install. How did you run your install? From the CD? Or did you copy to the HDD and install from there?

    Thanks
    Plantwiz
    _____
    "Grammar and spelling aren't everything, but this is a forum, not a chat room. You have plenty of time to spell out the word "you", and look just a little bit smarter." by Phaideaux

    ***I'll add you can Capitalize the word 'I' to show a little respect for yourself too.

    'i' before 'e' except after 'c'.... weird?
  • jescabjescab Posts: 1,321Inactive Imported Users
    You could just re-format (FDISK) the hard drive with a win98 boot disk with cd-rom support. Then partition the hard drive. Then install the OS.
    GO STEELERS GO - STEELERS RULE
  • PoisonwormPoisonworm Posts: 8Member ■□□□□□□□□□
    You said on a spare drive. Did you mean swapped out this drive, it's currently t the only drive? or is this a slave? in my experience (limited compared to quite a few people on this forum, only 9 years here), win98/me (anything on the 9x kernel) hates to run on a second hard drive. XP/2k doesn't whine about it as much. Just my two cents...


    ::edit:: wow...mavis beacon really didn't help me...ugh...
    I implore you, my dear friend, what would become of our world if those "failsafes" you rely upon were to mysteriously....fail...?
  • s0c0s0c0 Posts: 76Member ■■□□□□□□□□
    I bought the drive from some random guy for a few bucks a couple of months. It's a used 5gig hard drive and I'm not sure what has been done with it. In fact I bought several of these 5gig drives mainly so I could have lots of Linux distributions at my disposal. This is the only strange one of out of the bunch.

    There is no master-slave configuration. Whenever I want to play around with another O.S. I just hook it up on my testing computer (an machine with a 1ghz processor). I also leave the side off so this is real simple.

    I should also mention that I had Windows 2000 server installed on this at one point and experienced the exact same problem. I ensured the jumper settings matched my other test drives (they are all the maxtor 5gig drives). I'll try fooling around with the BIOS tonight, it sounds like I may have a bad drive though. Come to think of it I had strange problems with various nix boot loaders (bsd, lilo, grub...). Sounds like a unique issue I guess icon_cool.gif
  • s0c0s0c0 Posts: 76Member ■■□□□□□□□□
    jescab wrote:
    You could just re-format (FDISK) the hard drive with a win98 boot disk with cd-rom support. Then partition the hard drive. Then install the OS.

    This has been done. My thinking was F&R should have fixed this, but no. What the hell is going on here. As long as I insert the win98 disk it will give me the option to boot from hdd. I could always strap a pipe bomb to the hard drive and have some fun I guess.
  • PlantwizPlantwiz Posts: 5,057Mod Mod
    How many partitions do you see when you FDISK?

    Are any of them labled?

    AFTER FDISK, you'll want to reboot after and then run your format C:/s/u/q (or whichever flavor of format you desire).


    Otherwise, check the MFG of your HDD and run their diagnosis, it could be that the drive is failing and cannot completely clear out the NTFS. Win98 will not have a NT loader so your receving the error from some trace of another program.
    Plantwiz
    _____
    "Grammar and spelling aren't everything, but this is a forum, not a chat room. You have plenty of time to spell out the word "you", and look just a little bit smarter." by Phaideaux

    ***I'll add you can Capitalize the word 'I' to show a little respect for yourself too.

    'i' before 'e' except after 'c'.... weird?
  • PoisonwormPoisonworm Posts: 8Member ■□□□□□□□□□
    Writing Zero's may work well to your advantage...It takes time (to do the entire drive) but it should fix pretty much any errors...I know the maxblast software can do it. lost the link though, and too lazy to go find it (just got off work, two days off starting) :d
    I implore you, my dear friend, what would become of our world if those "failsafes" you rely upon were to mysteriously....fail...?
  • jescabjescab Posts: 1,321Inactive Imported Users
    Only hook up the hdd that you want to run 98 and do an FDISK. I know you say you already did fdisk but just do it again when only one drive i shooked up. Make sure the hdd is jumpered correctly. This way it will not be looking for the NTLDR file because it will be 98. Then on dual boot machines with 98 always put 98 first.
    GO STEELERS GO - STEELERS RULE
Sign In or Register to comment.