A little help

thomaja53thomaja53 Registered Users Posts: 4 ■□□□□□□□□□
I'm a noob. If the answer is obvious, don't make me feel dumb about it.

I have two seperate servers running Server 2008 r2 on Virtual Box. I created a Forwarder in both domains in the DNS manager. I thought I'd done everything right, but whenever I try to create a two way transitive forest trust between the servers using a Windows domain under "Trust Type", I get the error "Cannot continue The New Trust Wizard cannot continue because the specified domain cannot be contacted." When I ping either server, I get the error "Destination Host Unreachable" I am using the internal network in Virtual Box and have no problem connecting domain controllers in the same tree. I'm open to any suggestions.

Comments

  • CrikeyCrikey Member Posts: 59 ■■□□□□□□□□
  • BGravesBGraves Member Posts: 339
    ^Agree with above, and then from there verifying network settings on each server. You def will want to be able to ping between the servers before trying to establish a trust.
  • LunchbocksLunchbocks Senior Member FloridaMember Posts: 319 ■■■■□□□□□□
    Also, make sure that both servers are in the same subnet, and are pointing to the same gateway. Try pinging each other's IP address. If the pings work, then ping each other using the host name to make sure DNS is resolving correctly. Also, make sure you turn on network discovery in the Network and Sharing Center.
    If you set up DNS correctly and it is using root hints, you shouldn't need to set up manual forwarders.
    Degree: Liberty University - B.S Computer Science (In Progress)
    Current Certs: CCENT | MCTS | Network+
    Currently Working On: Security+
    2020 Goals: CCNA, CCNP Security, Linux+


  • thomaja53thomaja53 Registered Users Posts: 4 ■□□□□□□□□□
    I've turned off all firewalls. I am not able to ping either host name. Network discovery is enabled. I have tried all VB connection types (Hostt, Internal, and bridged: didn't use NAT because I'm not using a router which is probably the problem but I'm too new to see if this is the issue or not and I'm not using "Generic Adapter".)
    Let me know what information any of you would need to help me fix this and I'll provide. Thanks, guys...and gals!













    1
  • BGravesBGraves Member Posts: 339
    Are you able to ping between by IP Address? You said you couldn't by host name (testing dns) but what about just IP address?
    From what I read here:
    https://www.virtualbox.org/manual/ch06.html
    You should be using Internal or Bridged for both.
  • thomaja53thomaja53 Registered Users Posts: 4 ■□□□□□□□□□
    BGraves - I can't ping by IP address either. I'm losing sleep over this! LOL!
  • BGravesBGraves Member Posts: 339
    What are your network settings on both the servers?
    IP address
    Subnet Mask
    Default Gateway
    Verify both servers are set to the same type of virtual switch in Virtual box?
  • thomaja53thomaja53 Registered Users Posts: 4 ■□□□□□□□□□
    Remember, I'm trying to set up a trust between two forests so the ip network ids are not in the same subnet.
    Delta1
    IP: 192.168.3.2
    Mask: 255.255.255.0
    Default Gateway: 192.168.3.0

    Echo1
    IP: 192.168.4.2
    Mask: 255.255.255.0
    Default Gateway: 192.168.4.0
  • BGravesBGraves Member Posts: 339
    I'm not expert on Virtual box, but I assume it operates similarly to VmWare's virtual networking. ?
    I would say, if you can't ping from Delta1 to the Default gateway of Echo1, you have a routing problem at the network layer.
    I've never actually tested this using Virtual Box, but what is the issue with having them on the same subnets? Have you tried putting both on the same subnet, pinging between them to verify connectivity and then trying to set up the trust? I'd obviously give them unqiue IP addresses...
  • cruwlcruwl Member Posts: 341 ■■□□□□□□□□
    pretty sure your gateway address are incorrect. you are using the Network ID rather then the first usable IP which would be 192.168.3.1 and 192.168.4.1
  • wweboywweboy Member Posts: 287 ■■■□□□□□□□
    What are you using for a router?
  • EssendonEssendon Member Posts: 4,546 ■■■■■■■■■■
    Continuing what wweboy said, put 'em both on the same subnet and this should work. The two are on different subnet and without a router, they cant get to each other - hence why you cannot ping. Internal network setting will work.
    NSX, NSX, more NSX..

    Blog >> http://virtual10.com
Sign In or Register to comment.