Options

Route Redistribution and Tagging help

MrXpertMrXpert Member Posts: 586 ■■■□□□□□□□
I'm stuck on this problem. I have two routers running both OSPF and EIGRP and am performing 2way redistribution on them both. I have set the metrics and also included a route map so that routes are tagged. Problem is that router JACK is using the path through 192.168.23.3 to reach the 1.1.1.0/24 network which is in EIGRP domain. This is sub optimal. I want both routers JACK and JOHN to use the most efficient paths so I did route tagging. Can anyone please look at this config and tell me what I have done wrong?



JOHN#SHOW IP ROUTE
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

D 192.168.12.0/24 [90/307200] via 192.168.13.1, 00:28:24, FastEthernet0/0
1.0.0.0/24 is subnetted, 1 subnets
D EX 1.1.1.0 [170/409600] via 192.168.13.1, 00:28:24, FastEthernet0/0
C 192.168.13.0/24 is directly connected, FastEthernet0/0
10.0.0.0/28 is subnetted, 2 subnets
S 10.0.45.0 [1/0] via 10.0.34.4
C 10.0.34.0 is directly connected, Serial0/0
C 192.168.23.0/24 is directly connected, FastEthernet0/1
C 150.0.0.0/8 is directly connected, Tunnel0


router eigrp 1
redistribute ospf 1 metric 10000 100 255 1 1500 route-map OSPF>EIGRP
network 150.0.0.0
network 192.168.13.0
no auto-summary
!
router ospf 1
router-id 3.3.3.3
log-adjacency-changes
redistribute eigrp 1 subnets route-map EIGRP>OSPF
network 192.168.23.3 0.0.0.0 area 0
!
ip forward-protocol nd
ip route 10.0.45.0 255.255.255.240 10.0.34.4
!
!
ip http server
no ip http secure-server
!
access-list 1 permit 1.1.1.0 0.0.0.255
!
route-map OSPF>EIGRP deny 5
match tag 77
!
route-map OSPF>EIGRP permit 10
set tag 88
!
route-map EIGRP>OSPF deny 5
match tag 88
!
route-map EIGRP>OSPF permit 10
set tag 77
!

************************************************


JACK#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C 192.168.12.0/24 is directly connected, FastEthernet0/0
1.0.0.0/24 is subnetted, 1 subnets
O E2 1.1.1.0 [110/20] via 192.168.23.3, 00:06:25, FastEthernet0/1
D 192.168.13.0/24 [90/307200] via 192.168.12.1, 00:42:15, FastEthernet0/0
10.0.0.0/28 is subnetted, 1 subnets
O IA 10.0.34.0 [110/74] via 192.168.23.3, 00:06:25, FastEthernet0/1
C 192.168.23.0/24 is directly connected, FastEthernet0/1
D 150.0.0.0/8 [90/297295616] via 192.168.12.1, 00:16:17, FastEthernet0/0

router eigrp 1
redistribute ospf 1 metric 10000 100 255 1 1500 route-map OSPF>EIGRP
network 192.168.12.0
no auto-summary
!
router ospf 1
router-id 2.2.2.2
log-adjacency-changes
redistribute eigrp 1 subnets route-map EIGRP>OSPF
network 192.168.23.0 0.0.0.255 area 0
!
ip forward-protocol nd
!
!
ip http server
no ip http secure-server
!
access-list 1 permit 1.1.1.0 0.0.0.255
!
route-map OSPF>EIGRP deny 5
match tag 77
!
route-map OSPF>EIGRP permit 10
set tag 88
!
route-map EIGRP>OSPF deny 5
match tag 88
!
route-map EIGRP>OSPF permit 10
set tag 77
I'm an Xpert at nothing apart from remembering useless information that nobody else cares about.

Comments

  • Options
    mattaumattau Member Posts: 218
    without a diagram it is abit hard to visualise but I have a question. How are you putting 1.1.1.0 into eigrp? is it already an external eigrp route at AD170?

    Because this will cause it to be preferred in ospf. A deny or permit TAG is not going to stop a route from being installed in the routing table on jack. The tag will only permit or deny a prefix from being redistributed from 1 routing domain to another. You would either need to modify the AD for that prefix or put in an ospf distribute list. I believe you can match a tag in a route map in combination with a distribute list also

    I think this is what you're doing. on john eigrp to ospf tag = 77
    then on jack ospf to eigrp deny tag 77

    so the route will still be installed as ospf. Just not allowed to be redistributed back into eigrp. which causes suboptimal routing

    ps. If you put the distribute list on jack for 1.1.1.0 then be sure to do it on john also ;) because D EX 1.1.1.0 will be installed in the table and jack will send this to john and john will then have the same problem as what jack did
    _____________________________________
    CCNP ROUTE - passed 20/3/12
    CCNP SWITCH - passed 25/10/12
    CCNP TSHOOT - passed 11/12/12




  • Options
    MrXpertMrXpert Member Posts: 586 ■■■□□□□□□□
    Hi,

    On router JAMES iIam redistributing its loopback 1.1.1.0/24 interface into EIGRP. Using a route map
    router eigrp 1
    redistribute connected route-map CONN>EIGRP
    network 192.168.12.1 0.0.0.0
    network 192.168.13.1 0.0.0.0
    no auto-summary


    route-map CONN>EIGRP permit 10
    match interface Loopback1


    Sorry I didn't attached the topology before. I totally forgot.
    I actually thought that tagging routes this way would actually prevent sub optimal routing but in reality all it does it prevent routing loops. Although as you mentiond I could try changing the AD or even using a route-map coupled with a distribution-list. I will try this.
    I'm an Xpert at nothing apart from remembering useless information that nobody else cares about.
  • Options
    mattaumattau Member Posts: 218
    yeah you could either make ospf external routes ad of 171 or put a distribute list in ospf in a variety of ways :)
    _____________________________________
    CCNP ROUTE - passed 20/3/12
    CCNP SWITCH - passed 25/10/12
    CCNP TSHOOT - passed 11/12/12




Sign In or Register to comment.